Results 1 to 6 of 6

Thread: Logitech C910 showing a Green Image with 1080 resolution

  1. #1
    Join Date
    Jan 2011
    Posts
    40

    Logitech C910 showing a Green Image with 1080 resolution

    With my recently purchased Logitech C910 web cam, I am facing a peculiar type of problem, can’t figure out the problem. Before explain the problem, the specification of my system are running windows 7 OS, along with Intel dual core processor, NVIDIA graphical interface. The actual problem is, if I set the system resolution at 1080p, a green image box is appeared into the screen, and the most stranger is that is it only occurred with the web cam itself. But apart from that there is a problem that I am facing when I unplug the web cam that the desktop screen is completely freezes for few minute. Is here anyone having any suggestion for me to resolve this issue?

  2. #2
    Join Date
    Aug 2008
    Posts
    990

    Re: Logitech C910 showing a Green Image with 1080 resolution

    According to me, about the problem I think this is occurring for the web cam driver, either this one is not working properly or any of the file of this is corrupted. For that I recommend you to try once by reload the driver, run the installation process, at the beginning it will ask you to remove or overwrite the existing on, click on that option and terminate the installation process. I hope this will surely help you to overcome from the problem.

  3. #3
    Join Date
    May 2008
    Posts
    951

    Re: Logitech C910 showing a Green Image with 1080 resolution

    According to me I recommend you reload the software of web camera, because I think this is the cause of this problem, which I was also facing in last few months back, after that when I searched on this, I found that for other software application the execution of the web cam launching software might be getting the problem, so in that case you need to remove that application from your system if this works then ok other I suggest you to reload the web cam software, if there is any other application is collaborate with that software then by reload that one it will be solved.

  4. #4
    Join Date
    Jan 2011
    Posts
    34

    Re: Logitech C910 showing a Green Image with 1080 resolution

    Almost relevant type of problem that I have encountered in my system with the Logitech web cam, if I connect this with the system this flashes that the program is running with the other program, and directs me to stop the execution of that web cam program, after that if I stop that program, it stopped but till I reboot the system I was not able to start the web cam again in my system. What type of problem sir that? any one from here having any idea on this issue?

  5. #5
    Join Date
    May 2008
    Posts
    923

    Re: Logitech C910 showing a Green Image with 1080 resolution

    Check the screen resolution of your system, set the resolution in lower version and then start the web cam. If this also happening the similar thing then I recommend you to check the setting of the web cam appearance might be the problem is there. Try once by reset tag setting of the web cam and then reboot your system to apply the changes. Now if the problem still arriving in your system with this web cam then I recommends you to contact with the Logitech service engineer, they will surely help you to figure out the problem.

  6. #6
    Join Date
    Feb 2008
    Posts
    1,260

    Re: Logitech C910 showing a Green Image with 1080 resolution

    The graphics problem that you mentioned in your post, is also might be occurring for the other software application, did you installed or removed any other web cam software recently in your system? if you did this then by that installed or removed application files the problem can be happening, in that ace I recommend you to run the disc check up process either the windows default or any other .third party, it will remove the unused file of that application, and I hope this will be somehow help you to overcome from the problem.

Similar Threads

  1. Replies: 7
    Last Post: 15-02-2012, 05:29 AM
  2. Replies: 3
    Last Post: 10-02-2012, 06:00 PM
  3. Replies: 6
    Last Post: 04-07-2011, 08:12 PM
  4. Logitech C910 webcam not showing video on Mac Pro
    By Rawana in forum Hardware Peripherals
    Replies: 5
    Last Post: 24-03-2011, 10:15 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,708,953,894.11069 seconds with 17 queries