Results 1 to 6 of 6

Thread: Help, No sound in video

  1. #1

    Help, No sound in video

    Here's the story: download a file one day - it doesnt play sound but the video is perfect, so I guessed that it might be a dodgy file or it needed some new codec so I updated my Klite codec pack (which is meant to have all the right codecs). 2 days later all the video files I play (be it .avi or .mpeg or something else) also have the same problem. All other sound works, from mp3s and from the internet.

    I had the k-lite codec pack which I updated and now it gives me an error when I open a video saying:

    C:\1\video.avi::Audio 1
    ffdshow Audio Decoder::Out
    Audio Switcher::Out

    Media Type 0:
    Audio: WAVE_FORMAT_EXTENSIBLE 48000Hz stereo 3072Kbps

    majortype: MEDIATYPE_Audio {73647561-0000-0010-8000-00AA00389B71}
    subtype: MEDIASUBTYPE_PCM {00000001-0000-0010-8000-00AA00389B71}
    formattype: FORMAT_WaveFormatEx {05589F81-C356-11CE-BF01-00AA0055595A}
    bFixedSizeSamples: 1
    bTemporalCompression: 0
    lSampleSize: 1
    cbFormat: 40

    wFormatTag: 0xfffe
    nChannels: 2
    nSamplesPerSec: 48000
    nAvgBytesPerSec: 384000
    nBlockAlign: 8
    wBitsPerSample: 32
    cbSize: 22 (extra bytes)

    wValidBitsPerSample: 32
    dwChannelMask: 0x00000003
    SubFormat: {00000003-0000-0010-8000-00AA00389B71}

    [im guessing that the first 4 lines have alot of significance as (to me) it suggests that my ac3, ffdshow and audio switshers dont work. but I updated my ac3, reinstalled the klite codec pack 10 times, restored my system a couple of times and still nothing, oh and I dont know exactly what ffdshow Audio Decoder::Out
    Audio Switcher::Out]

    my system: windows Vista home premium (64bit)

    Everything worked fine for the 2 years that I've had this PC and I really dont want to have to buy a new one - any help would be great!!

  2. #2
    Join Date
    Feb 2009

  3. #3
    Join Date
    May 2008

    Re: Help, No sound in video

    i will suggest you to reinstall your audio driver as well as reinstall all the media software again. That may fix your problem

  4. #4
    Join Date
    Dec 2008

    Re: Help, No sound in video

    Some time its no matter what is your computer setting as downloaded file is corrupted that means while compressing that file author have made mistake to provide path of audio source so file have no audio, so you can not do it with that any thing.

  5. #5
    Join Date
    Apr 2008

    Re: Help, No sound in video

    Make this registry change and I'm pretty sure it will fix your problem. If it doesn't work, you can always change it back. It'll work.

    Go to the following registry folder:


    Double click on 'Auto Insert" on the right side of the box.

    Change the Value from "1" to "0" and click OK.

    You should be set.

  6. #6

    Re: Help, No sound in video

    thanks but theres no such file path in my computer:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\ NodeCLSIDs\{95037DA1-6ED9-4B27-8CFF-9AD3DFB0B2F2}]

    its, its, its just so excrutiating not being able to play videos with sound

Similar Threads

  1. VLC with sound but no video
    By CRiley in forum Windows Software
    Replies: 5
    Last Post: 25-04-2010, 04:16 AM
  2. No sound for video on net
    By garfield1 in forum Windows Software
    Replies: 3
    Last Post: 04-12-2009, 11:34 AM
  3. No sound after converting a video
    By Brendan18 in forum Windows Software
    Replies: 3
    Last Post: 31-07-2009, 12:35 AM
  4. Replies: 4
    Last Post: 04-03-2009, 10:10 PM
  5. Extract the sound of a video
    By mauricio in forum Tips & Tweaks
    Replies: 1
    Last Post: 10-10-2008, 07:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts