Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 27-02-2012
Member
 
Join Date: Jan 2012
Posts: 50
Unable to fix broken Samba by using revdep-rebuild as it needs libdmalloc.so.

as the title of thread is saying what I am looking to ask you over here. whenever I am trying to run revdep-rebuild I am getting number of entries which can be mentioned as follow.
?require libdmalloc.so.5?
I have also run ?/etc/samba/smb.conf? but it did not helped me anymore. Any help will be appreciated. Thanks a lot in advance.
Reply With Quote
  #2  
Old 27-02-2012
Member
 
Join Date: Jul 2011
Posts: 319
Re: Unable to fix broken Samba by using revdep-rebuild as it needs libdmalloc.so.

After going through the problem you should provide the output from revdep-rebuild.
Also you should run below mentioned command.
Code:
emerge --sync

emerge portage

emerge -avuDN
Reply With Quote
  #3  
Old 27-02-2012
Member
 
Join Date: Jan 2012
Posts: 50
Re: Unable to fix broken Samba by using revdep-rebuild as it needs libdmalloc.so.

Hey buddy thanks a lot for the prompt replies of yours. I used the above mentioned commands but I found myself stuck in to the third command. Should I use wgetpaste?
Reply With Quote
  #4  
Old 27-02-2012
Member
 
Join Date: Jul 2011
Posts: 319
Re: Unable to fix broken Samba by using revdep-rebuild as it needs libdmalloc.so.

Sorry I have done typo error in the third command. The actual command should be as follow.
Quote:
emerge -avuDN @system @world


nk portage # emerge -avuDN @system #world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] app-arch/xz-utils-5.0.3 USE="nls -static-libs -threads*" 1,228 kB
[ebuild N ] net-dns/c-ares-1.7.5 USE="-static-libs" 0 kB
[ebuild N ] app-crypt/p11-kit-0.9 USE="debug" 0 kB
[ebuild N ] media-gfx/shared-color-profiles-0.1.4 0 kB
[ebuild UD ] sys-apps/net-tools-1.60_p20111120203157 [1.60_p201111202031570500] USE="nls -old-output -static" 0 kB
[ebuild R ] sys-auth/pambase-20101024-r1 USE="consolekit cracklib debug* gnome-keyring sha512 -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux)" 0 kB
[ebuild U ] app-admin/python-updater-0.10 [0.9-r1] 0 kB
[ebuild U ] x11-proto/inputproto-2.1 [2.0.2] 0 kB
[ebuild U ] x11-libs/pixman-0.24.0 [0.22.2] USE="(-altivec) (-iwmmxt) -mmx (-neon) -sse2 -static-libs" 0 kB
[ebuild U ] x11-libs/libdrm-2.4.29 [2.4.26] USE="-libkms -static-libs" VIDEO_CARDS="intel -nouveau -radeon -vmware" 0 kB
[ebuild U ] x11-libs/libXi-1.5.0 [1.4.3] USE="-doc -static-libs" 0 kB
[ebuild U ] sys-libs/zlib-1.2.5.1-r2 [1.2.5-r2] USE="-minizip% -static-libs%" 0 kB
[ebuild U ] media-libs/libpng-1.5.7 [1.5.6] USE="apng (-neon) -static-libs" 0 kB
[ebuild U ] media-libs/tiff-4.0.0 [3.9.5] USE="cxx jpeg zlib -jbig -lzma% -static-libs" 0 kB
[ebuild U ] media-libs/lcms-2.3 [2.2-r1] USE="jpeg tiff zlib -doc -static-libs -test" 0 kB
[ebuild R ] dev-lang/perl-5.12.4-r1 USE="berkdb debug gdbm -build -doc -ithreads*" 0 kB
[ebuild U ] sys-kernel/linux-headers-3.2 [3.1] 4,814 kB
[ebuild N ] dev-perl/GSSAPI-0.280.0 USE="-test" 0 kB
[ebuild R ] dev-perl/Authen-SASL-2.150.0 USE="kerberos*" 0 kB
[ebuild R ] dev-lang/python-2.7.2-r3 USE="examples gdbm ipv6 ncurses readline sqlite ssl tk (wide-unicode) xml -berkdb -build -doc -threads* -wininst" 0 kB
[ebuild N ] dev-util/gdbus-codegen-2.30.2 0 kB
[ebuild U ] dev-libs/glib-2.30.2 [2.28.8] USE="debug* fam utils%* -doc (-selinux) -static-libs* -systemtap% -test -xattr (-introspection%)" 0 kB
[ebuild U ] dev-util/desktop-file-utils-0.19 [0.18] USE="-emacs" 0 kB
[ebuild U ] sys-apps/sed-4.2.1-r1 [4.2.1] USE="acl nls (-selinux) -static" 0 kB
[ebuild U ] dev-libs/gobject-introspection-1.30.0-r1 [0.10.8] USE="-doc -test" 0 kB
[ebuild R ] dev-libs/libIDL-0.8.14 USE="debug*" 0 kB
[ebuild U ] sys-apps/dbus-1.4.16-r2 [1.4.16] USE="X debug* -doc (-selinux) -static-libs -test" 0 kB
[ebuild R ] dev-libs/dbus-glib-0.98 USE="debug* -doc -static-libs -test" 0 kB
[ebuild R ] dev-libs/libxml2-2.7.8-r3 USE="debug* examples* ipv6 python readline -doc -icu -static-libs -test" 0 kB
[ebuild U ] x11-proto/xcb-proto-1.6-r2 [1.6-r1] 0 kB
[ebuild U ] x11-libs/gtk+-2.24.8-r1 [2.24.5-r1] USE="cups debug* examples* introspection (-aqua) -doc -test -vim-syntax -xinerama" 0 kB
[ebuild U ] media-libs/fontconfig-2.8.0-r2 [2.8.0-r1] USE="-doc -static-libs%" 0 kB
[ebuild R ] media-libs/freetype-2.4.8 USE="X bzip2 debug* utils* -auto-hinter -bindist -doc -fontforge -static-libs" 0 kB
[ebuild U ] dev-libs/openssl-1.0.0f [1.0.0e] USE="kerberos* zlib -bindist -gmp -rfc3779 -sse2 -static-libs% -test" 3,949 kB
[ebuild U ] dev-perl/Net-SSLeay-1.420.0 [1.360.0] 0 kB
[ebuild U ] dev-perl/IO-Socket-SSL-1.530.0 [1.440.0] USE="-idn" 0 kB
[ebuild R ] x11-libs/qt-core-4.7.4-r1 USE="debug* exceptions glib iconv jit qt3support ssl (-aqua) -optimized-qmake -pch -private-headers" 0 kB
[ebuild R ] x11-libs/qt-script-4.7.4 USE="debug* exceptions iconv jit (-aqua) -pch -private-headers" 0 kB
[ebuild R ] x11-libs/qt-dbus-4.7.4 USE="debug* exceptions (-aqua) -pch" 0 kB
[ebuild NS ] dev-lang/python-3.2.2 [2.7.2-r3, 3.1.4-r3] USE="examples gdbm ipv6 ncurses readline sqlite ssl tk (wide-unicode) xml -build -doc -threads -wininst" 0 kB
[ebuild U ] dev-python/setuptools-0.6.24 [0.6.21] 0 kB
[ebuild U ] sys-apps/file-5.10 [5.09] USE="python zlib -static-libs" 0 kB
[ebuild U ] sys-libs/cracklib-2.8.18-r1 [2.8.16] USE="nls python -static-libs%" 0 kB
[ebuild U ] dev-python/numpy-1.6.1-r1 [1.6.0] USE="-doc -lapack -test" 0 kB
[ebuild NS ] dev-java/icedtea-bin-7.2.0-r2 [6.1.10.4-r1] USE="X alsa examples nsplugin -cjk -doc -source" 0 kB
[ebuild NS ] virtual/jdk-1.7.0 [1.6.0] 0 kB
[ebuild NS ] virtual/jre-1.7.0 [1.6.0] 0 kB
[ebuild U ] media-libs/libjpeg-turbo-1.1.90 [1.1.1] USE="java%* -static-libs" 0 kB
[ebuild U ] sys-devel/gettext-0.18.1.1-r3 [0.18.1.1-r1] USE="acl cxx git java%* nls openmp -doc -emacs -static-libs%" 0 kB
[ebuild U ] dev-libs/atk-2.2.0 [1.32.0-r1] USE="introspection nls -doc" 0 kB
[ebuild U ] x11-misc/shared-mime-info-0.91 [0.90] 0 kB
[ebuild U ] sys-apps/attr-2.4.46-r1 [2.4.46] USE="nls -static-libs" 0 kB
[ebuild U ] sys-devel/binutils-2.22-r1 [2.21.1-r1] USE="nls zlib -multislot -multitarget -static-libs -test -vanilla" 0 kB
[ebuild U ] sys-apps/findutils-4.5.10-r1 [4.4.2] USE="nls (-selinux) -static" 0 kB
[ebuild U ] sys-libs/e2fsprogs-libs-1.42 [1.41.14] USE="nls -static-libs%" 0 kB
[ebuild U ] sys-devel/make-3.82-r3 [3.82-r1] USE="nls -static" 0 kB
[ebuild U ] sys-apps/diffutils-3.2 [3.0] USE="nls -static" 0 kB
[ebuild U ] dev-libs/libgpg-error-1.10-r1 [1.10] USE="nls -common-lisp -static-libs" 0 kB
[ebuild U ] x11-libs/gtksourceview-2.10.5-r2 [2.10.5-r1] USE="-doc -glade -test" 0 kB
[ebuild U ] sys-apps/gawk-4.0.0 [3.1.8] USE="nls readline%*" 0 kB
[ebuild U ] app-arch/tar-1.26 [1.23-r2] USE="nls -static" 0 kB
[ebuild U ] sys-devel/bison-2.5 [2.4.3] USE="nls -static" 0 kB
[ebuild R ] app-crypt/mit-krb5-1.9.2-r2 USE="keyutils pkinit -doc -openldap -test -threads* -xinetd" 0 kB
[ebuild U ] dev-libs/libtasn1-2.11 [2.9-r1] USE="-doc -static-libs" 0 kB
[ebuild U ] sys-apps/coreutils-8.15 [8.7] USE="acl nls unicode -caps -gmp (-selinux) -static -vanilla -xattr" 4,832 kB
[uninstall ] app-misc/realpath-1.16 USE="nls"
[blocks b ] app-misc/realpath ("app-misc/realpath" is blocking sys-apps/coreutils-8.15)
[ebuild U ] app-admin/eselect-1.2.18 [1.2.15] USE="-doc" 0 kB
[ebuild U ] net-print/cups-1.4.8-r22 [1.4.8-r1] USE="X acl dbus debug* gnutls java jpeg kerberos* ldap pam perl* png python ssl tiff usb%* -php -samba -slp -static-libs -threads* -xinetd" LINGUAS="-da -de -es -eu -fi -fr -id -it -ja -ko -nl -no -pl -pt -pt_BR -ru -sv -zh -zh_TW" 0 kB
[ebuild R ] x11-libs/qt-gui-4.7.4-r1 USE="accessibility cups dbus debug* exceptions glib mng qt3support tiff (-aqua) -egl -gtkstyle -nas -nis -pch -private-headers -raster -trace -xinerama" 0 kB
[ebuild R ] x11-libs/qt-sql-4.7.4 USE="debug* exceptions iconv qt3support sqlite (-aqua) -firebird -freetds -mysql -odbc -pch -postgres" 0 kB
[ebuild R ] x11-libs/qt-qt3support-4.7.4 USE="accessibility debug* exceptions (-aqua) -kde -pch -phonon" 0 kB
[ebuild U ] dev-db/sqlite-3.7.9 [3.7.7.1] USE="debug* extensions fts3 readline threadsafe -doc -icu -secure-delete -soundex -tcl -test -unlock-notify" 0 kB
[ebuild U ] gnome-base/gconf-3.2.3 [2.32.4] USE="debug* introspection ldap orbit%* policykit -doc" 0 kB
[ebuild U ] sys-apps/texinfo-4.13-r1 [4.13] USE="nls -static" 0 kB
[ebuild U ] sys-devel/gcc-4.5.3-r2 [4.5.3-r1] USE="cxx fortran gtk mudflap nls nptl openmp (-altivec) -bootstrap -build -doc (-fixed-point) -gcj -graphite (-hardened) (-libffi) (-libssp) -lto (-multilib) -multislot -nocxx -nopie -nossp -objc -objc++ -objc-gc -test -vanilla" 0 kB
[ebuild U ] sys-devel/automake-1.11.2 [1.11.1] 0 kB
[ebuild N ] sys-apps/ed-1.6 0 kB
[ebuild U ] sys-devel/llvm-3.0 [2.9-r2] USE="debug* libffi -gold% -multitarget -ocaml -test -udis86 -vim-syntax (-llvm-gcc%)" 0 kB
[ebuild U ] sys-devel/libtool-2.4.2 [2.4-r1] USE="-static-libs% -test -vanilla" 0 kB
[ebuild R ] x11-libs/cairo-1.10.2-r1 USE="X debug* glib opengl qt4* svg xcb (-aqua) -directfb -doc (-drm) (-gallium) (-openvg) -static-libs" 0 kB
[ebuild U ] dev-libs/libgcrypt-1.5.0-r1 [1.4.6] USE="-static-libs" 0 kB
[ebuild U ] x11-libs/gdk-pixbuf-2.24.1 [2.24.0-r1] USE="X debug* introspection jpeg tiff -doc -jpeg2k -test" 0 kB
[ebuild U ] dev-libs/libpcre-8.21 [8.12] USE="bzip2 cxx jit%* readline%* recursion-limit (unicode) zlib -static-libs" 0 kB
[ebuild U ] app-text/libpaper-1.1.24-r1 [1.1.23] 0 kB
[ebuild R ] sys-libs/db-4.8.30 USE="cxx examples* java -doc -tcl -test" 0 kB
[ebuild R ] dev-libs/libgamin-0.1.10-r2 USE="debug* python -static-libs" 0 kB
[ebuild U ] media-libs/mesa-7.11.2 [7.11] USE="classic debug* egl gallium llvm nptl shared-glapi -bindist -gbm -gles -motif -openvg -osmesa% -pax_kernel -pic (-selinux) -shared-dricore" VIDEO_CARDS="intel -mach64 -mga -nouveau -r128 -radeon -savage -sis -tdfx -via -vmware" 0 kB
[ebuild U ] dev-lang/tcl-8.5.10 [8.5.9] USE="debug* -threads" 0 kB
[ebuild R ] gnome-base/orbit-2.14.19-r1 USE="debug* -doc -test" 0 kB
[ebuild U ] sys-apps/usbutils-005 [001] USE="python%* zlib -network-cron" 0 kB
[ebuild R ] dev-libs/libusb-0.1.12-r7 USE="cxx debug* -doc -static-libs" 0 kB
[ebuild U ] sys-apps/groff-1.21-r1 [1.21] USE="X examples*" LINGUAS="-ja" 0 kB
[ebuild U ] x11-libs/pango-1.29.4 [1.28.4] USE="X debug* introspection -doc -test" 0 kB
[ebuild R ] net-libs/gnutls-2.10.5 USE="cxx examples* nls zlib -bindist -doc -guile -lzo -test" 0 kB
[ebuild U ] dev-lang/tk-8.5.10 [8.5.9-r1] USE="debug* truetype (-aqua) -threads -xscreensaver" 0 kB
[ebuild R ] dev-python/pycairo-1.10.0-r2 USE="examples* svg -doc -test" 0 kB
[ebuild R ] sys-libs/pam-1.1.5 USE="berkdb cracklib debug* nls -audit -nis (-selinux) -test -vim-syntax" 0 kB
[ebuild U ] app-text/ghostscript-gpl-9.04-r5 [9.04-r4] USE="X cups dbus gtk -bindist -djvu -idn -jpeg2k -static-libs" LINGUAS="-ja -ko -zh_CN -zh_TW" 0 kB
[ebuild R ] app-admin/gam-server-0.1.10 USE="debug*" 0 kB
[ebuild U ] sys-apps/grep-2.10 [2.5.4-r1] USE="nls pcre" 0 kB
[ebuild R ] dev-libs/libxslt-1.1.26-r2 USE="crypt debug* python -static-libs" 0 kB
[ebuild U ] dev-lang/swig-2.0.4-r1 [2.0.2] USE="pcre -ccache -doc" 0 kB
[ebuild U ] sys-apps/man-1.6g [1.6f-r4] USE="lzma* nls" 0 kB
[ebuild N ] sys-libs/libcap-ng-0.6.6 USE="python" 0 kB
[ebuild U ] net-misc/wget-1.13.4-r1 [1.12-r3] USE="debug* gnutls%* ipv6 nls ssl -idn -ntlm -static" 0 kB
[ebuild U ] dev-lang/vala-0.14.1 [0.14.0] USE="vapigen -test" 0 kB
[ebuild N ] x11-misc/colord-0.1.15 USE="examples introspection udev vala -doc -gusb -scanner" 0 kB
[ebuild U ] x11-libs/gtk+-3.2.3 [3.0.12-r1] USE="colord%* cups debug* examples* introspection (-aqua) -doc -packagekit% -test -vim-syntax -xinerama" 0 kB
[ebuild U ] sys-auth/polkit-0.104 [0.102] USE="debug* examples* gtk introspection nls pam -doc -kde (-systemd)" 1,384 kB
[ebuild U ] gnome-extra/polkit-gnome-0.105 [0.101-r1] USE="(-doc%) (-examples%) (-introspection%*)" 0 kB
[ebuild U ] sys-auth/consolekit-0.4.5-r2 [0.4.5-r1] USE="debug* pam policykit -doc -test" 0 kB
[ebuild U ] dev-python/pygobject-2.28.6-r51 [2.28.6] USE="examples* introspection -doc -libffi -test (-cairo%*)" 0 kB
[ebuild NS ] dev-python/pygobject-3.0.3 [2.28.6] USE="cairo examples -test -threads" 0 kB
[ebuild U ] dev-python/pygtk-2.24.0-r2 [2.24.0-r1] USE="examples* -doc -test" 0 kB
[ebuild R ] dev-python/pygtksourceview-2.10.1 USE="debug* -doc" 0 kB
[ebuild U ] gnome-base/gnome-keyring-3.2.2 [2.32.1-r1] USE="caps%* debug* pam -doc -test" 0 kB
[ebuild U ] gnome-base/libgnome-keyring-3.2.2 [2.32.0] USE="debug* -doc -test" 0 kB
[ebuild U ] app-shells/bash-4.2_p20 [4.1_p9] USE="examples* net nls -afs -bashlogger -mem-scramble -plugins -vanilla" 0 kB
[ebuild U ] app-admin/perl-cleaner-2.10 [2.7] 0 kB
[ebuild U ] net-nds/openldap-2.4.25-r1 [2.4.24] USE="berkdb crypt debug* gnutls ipv6 kerberos* minimal perl* ssl tcpd -cxx -experimental -icu -iodbc -odbc -overlays -samba -sasl (-selinux) -slp -smbkrb5passwd -syslog" 0 kB
[ebuild U ] net-misc/curl-7.23.1 [7.21.4] USE="ares* gnutls ipv6 kerberos* ldap ssl -idn -nss* -ssh -static-libs -test -threads" 0 kB
[ebuild U ] net-misc/openssh-5.9_p1-r3 [5.8_p1-r1] USE="X hpn kerberos* ldap pam tcpd -X509 -libedit (-selinux) -skey -static" 0 kB
[ebuild U ] dev-vcs/git-1.7.8.3 [1.7.3.4-r1] USE="blksha1 curl gtk iconv perl python%* tk* webdav -cgi -cvs -doc -emacs (-ppcsha1) -subversion -threads* -xinetd (-bash-completion%)" 3,946 kB
[ebuild U ] sys-fs/e2fsprogs-1.42 [1.41.14] USE="nls -static-libs%" 0 kB
[ebuild U ] app-arch/libarchive-2.8.5 [2.8.4-r1] USE="acl bzip2 lzma zlib -expat -static -static-libs -xattr" 0 kB
[ebuild R ] dev-util/cmake-2.8.6-r4 USE="ncurses qt4* -emacs -test -vim-syntax" 0 kB
[ebuild U ] app-text/poppler-0.18.2 [0.16.7] USE="cairo cxx debug* introspection jpeg lcms png qt4* tiff%* utils xpdf-headers -cjk -curl -doc -jpeg2k (-exceptions%)" 0 kB
[ebuild N ] sys-libs/gpm-1.20.6 USE="(-selinux)" 0 kB
[ebuild U ] sys-libs/ncurses-5.9-r1 [5.9] USE="cxx debug* gpm unicode -ada -doc -minimal -profile -static-libs -trace" 0 kB
[ebuild U ] sys-apps/openrc-0.9.8 [0.9.4] USE="debug* ncurses pam unicode (-selinux) -static-libs%" 163 kB
[ebuild U ] sys-apps/util-linux-2.20.1 [2.19.1-r1] USE="cramfs crypt ncurses nls perl* unicode -ddate% -loop-aes -old-linux (-selinux) -slang -static-libs% (-uclibc)" 0 kB
[ebuild U ] sys-apps/sysvinit-2.88-r3 [2.88-r2] USE="(-ibm) (-selinux) -static" 0 kB
[blocks b ] <sys-apps/sysvinit-2.88-r3 ("<sys-apps/sysvinit-2.88-r3" is blocking sys-apps/util-linux-2.20.1)
[blocks B ] <x11-libs/vte-0.28.2-r201:0 ("<x11-libs/vte-0.28.2-r201:0" is blocking x11-libs/gtk+-2.24.8-r1)

Total: 131 packages (88 upgrades, 1 downgrade, 9 new, 5 in new slots, 28 reinstalls, 1 uninstall), Size of downloads: 20,313 kB
Conflict: 3 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-script:4

(x11-libs/qt-script-4.7.4::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-script-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, ebuild scheduled for merge)

(x11-libs/qt-script-4.7.4::gentoo, installed) pulled in by
~x11-libs/qt-script-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, installed)

x11-libs/qt-core:4

(x11-libs/qt-core-4.7.4-r1::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-core-4.7.4[aqua=,debug=] required by (x11-libs/qt-script-4.7.4::gentoo, ebuild scheduled for merge)
~x11-libs/qt-core-4.7.4[aqua=,debug=] required by (x11-libs/qt-dbus-4.7.4::gentoo, ebuild scheduled for merge)
~x11-libs/qt-core-4.7.4[aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.4::gentoo, ebuild scheduled for merge)
~x11-libs/qt-core-4.7.4[aqua=,debug=,glib=,qt3support=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, ebuild scheduled for merge)
~x11-libs/qt-core-4.7.4[aqua=,debug=,qt3support=] required by (x11-libs/qt-sql-4.7.4::gentoo, ebuild scheduled for merge)

(x11-libs/qt-core-4.7.4-r1::gentoo, installed) pulled in by
~x11-libs/qt-core-4.7.4[aqua=,debug=] required by (x11-libs/qt-script-4.7.4::gentoo, installed)
~x11-libs/qt-core-4.7.4[aqua=,debug=,qt3support=] required by (x11-libs/qt-sql-4.7.4::gentoo, installed)
~x11-libs/qt-core-4.7.4[aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.4::gentoo, installed)
~x11-libs/qt-core-4.7.4[aqua=,debug=] required by (x11-libs/qt-dbus-4.7.4::gentoo, installed)
~x11-libs/qt-core-4.7.4[aqua=,debug=,glib=,qt3support=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, installed)

dev-lang/python:2.7

(dev-lang/python-2.7.2-r3::gentoo, installed) pulled in by
=dev-lang/python-2*[threads] required by (media-video/totem-2.32.0-r2::gentoo, installed)
=dev-lang/python-2*[threads,xml] required by (app-office/libreoffice-3.4.3.2-r1::gentoo, installed)

(dev-lang/python-2.7.2-r3::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

x11-libs/qt-sql:4

(x11-libs/qt-sql-4.7.4::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-sql-4.7.4[aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.4::gentoo, ebuild scheduled for merge)

(x11-libs/qt-sql-4.7.4::gentoo, installed) pulled in by
~x11-libs/qt-sql-4.7.4[aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.4::gentoo, installed)

x11-libs/qt-dbus:4

(x11-libs/qt-dbus-4.7.4::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-dbus-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, ebuild scheduled for merge)

(x11-libs/qt-dbus-4.7.4::gentoo, installed) pulled in by
~x11-libs/qt-dbus-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, installed)

x11-libs/qt-gui:4

(x11-libs/qt-gui-4.7.4-r1::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-gui-4.7.4[accessibility=,aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.4::gentoo, ebuild scheduled for merge)

(x11-libs/qt-gui-4.7.4-r1::gentoo, installed) pulled in by
~x11-libs/qt-gui-4.7.4[accessibility=,aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.4::gentoo, installed)
~x11-libs/qt-gui-4.7.4[accessibility=,aqua=,debug=] required by (x11-libs/qt-svg-4.7.4::gentoo, installed)

x11-libs/qt-qt3support:4

(x11-libs/qt-qt3support-4.7.4::gentoo, installed) pulled in by
~x11-libs/qt-qt3support-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, installed)

(x11-libs/qt-qt3support-4.7.4::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-qt3support-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

The cat /etc/make.conf should provide following output.

Quote:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -march=i686 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="i686-pc-linux-gnu"

PORT_LOGDIR=/var/log/portage
PORTAGE_BLOG_CLASSES="info warn error log"
PORTAGE_BLOG_SYSTEM="save"

MAKEOPTS="-j2"

GENTOO_MIRRORS="http://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://mirror.its.uidaho.edu/pub/gentoo/ ftp://ftp.wallawalla.edu/pub/mirrors/ftp.gentoo.org"

SYNC="rsync://rsync8.us.gentoo.org/gentoo-portage"

USE=" gtk gnome qt4 -kde cdr dvd alsa (ipc) epydoc hal dbus sqlite python branding eds gstreamer vba java pam winbind kerberos acl
a52 aac acpi alsa cairo dvdr emboss exif fam firefox flac gif hal jpeg lcms ldap libnotify mp4 mpeg ogg opengl pango pdf png ppds startup-notifation
svg tiff truetype vorbis unicode usb X xcb x264 xml xulrunner xv xvid ipv6 ssl connection-sharing dhcpcd gnutls ppp resolvconf
wimax autoipd introspection readline policykit nls mail nauilus bluetooth ~x86 tk ares -static-libs acl (-selinux) 32bit -vdpau nsplugin debug
examples swat tcpd perl -threads -rpc gtk3* qt4* -bookmarks -howl-compat -mdnsresponder -mono -test utils vala debug eds socialweb -test -tracker
-nss gdbm avahi "


SYNC="rsync://rsync26.us.gentoo.org/gentoo-portage"

VIDEO_CARDS="intel"

INPUT_DEVICES="evdev"

ACCEPT_KEYWORDS="~x86"
Reply With Quote
  #5  
Old 27-02-2012
Manthan-BSitia
 
Posts: n/a
Re: Unable to fix broken Samba by using revdep-rebuild as it needs libdmalloc.so.

Well in this particular situation you should add webdav to make.conf. you have to change
Code:
dev-lang/php truetype exif
to
Code:
>=dev-lang/php truetype exif
Reply With Quote
  #6  
Old 27-02-2012
Member
 
Join Date: Aug 2011
Posts: 393
Re: Unable to fix broken Samba by using revdep-rebuild as it needs libdmalloc.so.

You should go through the make.conf. if you wanted to use flags check then you should be aware of that they are not the internal flags. I recommend that you should stay with the single entry from package.use for package.
After that you should run emerge -pv package_name in order to get what can be used for the building of the package. also you have not stated about the version of php and git then you have to remove >= from the starting of package.use line.
Reply With Quote
  #7  
Old 27-02-2012
Member
 
Join Date: Aug 2011
Posts: 315
Re: Unable to fix broken Samba by using revdep-rebuild as it needs libdmalloc.so.

If you are having number of package which are failing then you should run below mentioned command.
Code:
emerge -avu --skip-first
if you wanted portage to proceed by any mean till it is not able to continue.
Code:
emerge -avu --keep-going
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Unable to fix broken Samba by using revdep-rebuild as it needs libdmalloc.so."
Thread Thread Starter Forum Replies Last Post
Unable to rebuild the partition of RAID 1 Desi.B@yZ Motherboard Processor & RAM 5 11-12-2011 08:00 PM
Unable to update samba in Cent OS 5.2 Kim|ball Operating Systems 5 07-05-2011 11:57 AM
Samba Authentication by using Kerberos: Unable to add to the AD machine Aerona Operating Systems 5 06-05-2011 10:27 AM
samba share from windows 7 command prompt unable to read Fred Fruax Networking & Security 4 06-04-2011 03:50 AM
Unable to save docx or excel in our samba server Karsten M Windows Software 4 25-12-2010 06:22 PM


All times are GMT +5.5. The time now is 04:00 AM.