Results 1 to 3 of 3

Thread: Change HAL from "Advanced Configuration and Power Interface (ACPI) PC" to "ACPI Multiprocessor PC"

  1. #1
    Join Date
    Oct 2004

    Change HAL from "Advanced Configuration and Power Interface (ACPI) PC" to "ACPI Multiprocessor PC"

    I have got an IBM M55 which is running on Windows XP and on it there is an intel core 2 duo as well. I installed CPU-z on it and it is reporting that 1 core is disabled and when I checked in Task Manager then I was only seeing 1 cpu. When I go into device manager then it reports that my computer is an "Advanced Configuration and Power Interface (ACPI) PC", so can you tell me how to change this from the current setting to "ACPI Multiprocessor PC", without reinstalling Windows XP? I have tried to update the driver but even after that I am getting "Advanced Configuration and Power Interface (ACPI) PC" and "Standard PC". Any ideas?

  2. #2
    Join Date
    Oct 2005

    RE: Change HAL from "Advanced Configuration and Power Interface (ACPI)

    Go to Device manager and then expand Computer and then under computer you should see the currently installed 'HAL' information "Advanced Configuration and Power Interface (ACPI) PC". After that right click the (ACPI)PC device and then chose 'Update driver' and then select the (Advance) radio button in the Hardware Update Wizard and then click next. Now you have to select 'Don't search, I will choose the driver to install' and click next. You have to then tick mark the check box for "Show compatible hardware" on the next screen and then select the correct HAL for your system type and then follow the instructions given to complete the install.

  3. #3
    Join Date
    Feb 2006

    HAL Utility to force changing the installed 'HAL' information

    I was also having the issue when upgrading the AMD 3500 to AMD Opteron 185 on my Asus motherboard. I was getting the same results like said in the first post. I had even tried the F5 option on a different spare hard drive at the time of Windows install but I was not able to see the option for Multiprocessor. After that I solved the issue by finding a Hal utility which is very simple to use. Download a software called HALu version 0.2.0 by searching it from google.

Similar Threads

  1. Replies: 5
    Last Post: 13-06-2011, 09:15 PM
  2. Change from ACPI Uniprocessor to ACPI Multiprocessor
    By Wafeeq in forum Motherboard Processor & RAM
    Replies: 6
    Last Post: 18-10-2010, 07:53 PM
  3. Replies: 6
    Last Post: 18-05-2010, 12:27 AM
  4. Replies: 3
    Last Post: 25-06-2009, 03:49 AM
  5. Replies: 6
    Last Post: 20-09-2007, 05:03 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,716,983,765.49436 seconds with 18 queries