Results 1 to 10 of 10

Thread: Error loading [...] shell32.dll; access is denied

  1. #1
    Kalvos Guest

    Error loading [...] shell32.dll; access is denied

    Hello all,

    Windows XP Pro SP2, all updates, 2GB memory, full virus scanning and
    firewall.

    Yesterday, after the latest Windows update (and it may be
    coincidental), a number of functions generate the following message:

    [X] Error loading C:\WINDOWS\system32\shell32.dll
    Access is denied

    The system works generally but there are a number of items, especially
    via Control Panel, that can no longer be accessed.

    I have searched online for solutions to this, but do not see this
    problem described. Details:

    ====================

    CANNOT access either via Control Panel (shell32.dll access denied) or
    via start-run .cpl files (nothing happens):

    Accessibility Options
    Add Hardware
    Add or Remove Programs
    Automatic Updates
    ClearType Tuning
    Color
    Date and Time
    Display
    Internet Options
    Java
    Keyboard
    Mouse
    Network Setup Wizard
    Phone and Modem Options
    Power Options
    Quicktime
    Regional and Language Options
    Security Center
    SoundMax
    Sounds and Audio Devices
    Speech
    System
    User Accounts
    Wacom Tablet Properties
    Windows CardSpace
    Windows Firewall
    Wireless Network Setup Wizard

    Also cannot access:
    System via Windows-Pause/Break
    Display options via right-click on desktop

    ====================

    CAN access via Control Panel:

    Administrative Tools
    Folder Options
    Fonts
    Network Connections
    Printers and Faxes
    Scanners and Cameras
    Scheduled Tasks
    Taskbar and Start Menu

    Also can access:

    CTL-ALT-DEL Task Manager
    CTL-ESC Programs and Documents
    Device Manager via Computer Management window
    Internet Options from IE (which I only use for Windows updates), but
    some options (such as delete history and temporary files) generate the
    same shell32.dll error.

    ====================

    The shell32.dll is:
    6.00.2900.3241 (xpsp_sp2_qfe.071025-1245)
    8,486,912 bytes
    October 25, 2007.

    ====================

    On the Microsoft support site, I re-ran the WindowsXP-KB943460-x86-
    ENU.exe, since this described a shell32.dll security issue. It
    installed, but there was no change.

    Where do I go from here?

    Thank you,
    Dennis


  2. #2
    John John Guest

    Re: Error loading [...] shell32.dll; access is denied

    Make sure that you have no malware and pests on the computer. To
    eliminate permissions issues on the \system32 file try the proceedure
    described in Aaron Stebner's WebLog:
    http://blogs.msdn.com/astebner/archi...04/739820.aspx

  3. #3
    Kalvos Guest

    Re: Error loading [...] shell32.dll; access is denied

    John,

    Thanks for your suggestions. I have Ad-Aware, Spybot Search & Destroy,
    Avast, and Comodo. The system is very clean -- it's my main machine
    with all the critical stuff, so I don't need any malware or viruses or
    other nasties, for sure. But I checked again, and it's clean.

    So I ran Stebner's fix, which did a lot of repairs, but didn't help.

    But then I thought -- wait, I've been using the somewhat balky
    ZoneAlarm for several years and switched to Comodo last week after a
    (trusted) reviewer pointed out how much more effective, transparent
    and easy to use it was. It's hard to find out exactly what
    applications are being dealt with, but I had no idea that it blocked
    access to many system tasks automatically! Temporarily disabling it
    allowed access to everything that was previously denied.

    Now I have to find out where Comodo stores its list of applications
    and permissions so I can allow access to the Control Panel. It's the
    admin account after all, so I'm not sure why Comodo would do that.
    Double-check for the double-dopey like me?

    Thanks very much again.

    Dennis

  4. #4
    John John Guest
    Glad to see that you found out the problem. There is an ever increasing
    number of Antivirus/Anti-spyware and other security suites and products
    that block valid Windows processes. I think that some of them overdo it
    a bit.

    I run Comodo v2.0 ; tried v3.0 but found it too aggresive .

  5. #5
    Kalvos Guest

    Re: Error loading [...] shell32.dll; access is denied

    bojimbo26...

    This is version 3, and it's new to me. The interface is so different
    from Zone Alarm that it will take me a while to learn. It gives both
    too little and too much information, I think. And I still haven't
    gotten it to allow those control panel applets to run while it is
    enabled. I tried adding *.cpl to its Windows system application list,
    but it still throws the shell32.dll error; I added that, too, but it
    didn't help. Funny it didn't ask in the first place.

  6. #6
    bojimbo26one@aol.com Guest
    i`ve used v2.0 since early 2007 and found v3.0 just after
    it came out . V2.0 is no bells and whistles and does exactly what I
    want ; in v3.0 you have to use the advanced system , which for me is
    too aggresive . Gone back to v2.0 and am quite happy .

    After trying everything else and still refusing to reinstall, I disabled the Comodo Defense Security Level. And everything works fine!

    Thanks for this solution, I had exact the same problem and now it's
    solved.

  7. #7
    Join Date
    Jan 2009
    Posts
    1

    Re: Error loading [...] shell32.dll; access is denied

    THANK YOU to all of you.
    I was losing my mind trying to fix my problem,(I could not access to control pannel for error loading shell32.dll access denied) looking for virus, malware, scanning my system but nothing was working.
    Just this morning I arrived to this thread and smply disabling the Comodo Defense Security Level, the error has disappeared

    THANK YOU AGAIN

  8. #8
    Join Date
    Feb 2009
    Posts
    1

    Re: Error loading [...] shell32.dll; access is denied

    HEY!

    I had same problem and I found an answer to it!
    go to COMODO Defence+ and switch to Advanced tab.
    Then select Computer Security Policy.
    Find the shell32.dll/shell32.exe and remove it from the list.

    After that my system worked normally again!

    OT: never install XP SP3. it WILL crash your system...

  9. #9
    Join Date
    May 2009
    Posts
    1

    Re: Error loading [...] shell32.dll; access is denied

    I want to thank you ever so much in helping me solve this most peculiar error message that I have run across. After trying to re-register the file (shell32.dll) and rebooting with no such luck, I've tried reseting the ACLs as desribed in the link that you offered (again, with no such luck). So, after the reply that John posted, I thought that I should check to see if it's being blocked somehow by Comodo Internet Security, and the file was.

    I don't know how, but rundll32.exe was being treated as an Isolated Application, not as Custom which allows CIS to allow rundll32.exe access the shell32.dll file.

    Well, thanks again for your suggestions and your help. It was most appreciative and informative.

  10. #10
    Join Date
    Jun 2009
    Posts
    1

    Re: Error loading [...] shell32.dll; access is denied

    Thanks for the tip. I had the same problem, which started spontaneously one day. The messages stopped when I deactivated the "Defense+" feature in comodo.
    I fixed it by uninstalling comodo, and then reinstalling it.
    V3 seems to work fine with my system now.

Similar Threads

  1. Replies: 1
    Last Post: 25-10-2012, 05:32 PM
  2. Replies: 6
    Last Post: 24-08-2011, 09:24 PM
  3. Error 0x80070005 access is denied
    By PARRISH in forum Windows Vista Network
    Replies: 2
    Last Post: 14-08-2009, 07:05 PM
  4. Replies: 2
    Last Post: 24-05-2007, 09:46 AM
  5. Getting Access Denied error on WMI / DCOM
    By sevaanan in forum Windows Security
    Replies: 1
    Last Post: 03-03-2007, 11:22 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,685,986,479.27405 seconds with 17 queries