Results 1 to 4 of 4

Thread: Synaptics Touchpad Advanced Problems

  1. #1
    Join Date
    Dec 2007

    Synaptics Touchpad Advanced Problems

    I have a Dell Inspiron E1705, running XP SP3. Today my scrolling feature on the Synaptics Touchpad stopped working. When I try to update the driver in device manager it says there is not a newer or better driver. I have also been to the Dell driver download site and when it checks my computer for updates, it does not find a Synaptics update that I need. This is driving me crazy. I need some help, please. Should I uninstall the driver (actually there are two drivers listed in the device manager)? If I uninstall it, where do I get a new version?

  2. #2
    Join Date
    Jan 2005

    Re: Synaptics Touchpad Advanced Problems

    Did you tried to update the drivers back again. Just go in the device manager and right click on the touchpad. Click on Properties and then click on details. You will find ample of information on the driver version. You can update the same to latest one and then check back. I am sure that will be quiet enough for you. Once you apply a good drivers in your system the touchpad will start working fine. You can also find the same on the official website of laptop manufacturer.

  3. #3
    Join Date
    Nov 2005
    I got the same kind of issue with HP Laptop. The model number of the same is DV9640US. It came with windows vista on the same. The driver stopped working suddenly due to which my touch pad failed. I had gone with all the drivers updates and whatever needed. But the same does not looks to be

  4. #4
    Join Date
    Apr 2010

    Re: Synaptics Touchpad Advanced Problems

    not sure if I should jump in here, I have a problem with my laptop....the touch pad was disabled by a friend (according to the kid it was basic as to get in back on) unfortunately, I cannot get it to work, have uninstalled and reinstalled the computer tells me the device is working, but it isnt and I cannot find an option anywhere to enable the device or use the device, even when I restart without the usb mouse plugged in....I know some ppl don't like the touch pad but I really do, I cart this thing everywhere and I hate haveing to use the usb!!!! oh and i downloaded a driver cure program it says the same thing, device is working and go to troubleshoot (which by the way cannot help me) I am not the most computer literate person, but I can do the basics, also tried roll back, apparently I have no driver to roll back to.

Similar Threads

  1. Synaptics touchpad's multi touch capabilities
    By Chitrakala in forum Portable Devices
    Replies: 3
    Last Post: 02-01-2011, 07:46 AM
  2. HP TouchSmart tm2 Synaptics Touchpad Not Working
    By fragranz in forum Hardware Peripherals
    Replies: 6
    Last Post: 29-06-2010, 11:42 AM
  3. Synaptics touchpad of laptop is not properly working
    By abigial_i in forum Portable Devices
    Replies: 3
    Last Post: 02-12-2009, 09:04 AM
  4. Synaptics touchpad driver for Vista
    By zaid in forum Operating Systems
    Replies: 2
    Last Post: 04-08-2009, 01:01 PM
  5. Replies: 2
    Last Post: 13-06-2008, 01:01 AM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,642,622,065.89384 seconds with 17 queries