Results 1 to 5 of 5

Thread: Windows Vista takes a very long time to login on SBS2003

  1. #1
    Join Date
    Oct 2005

    Windows Vista takes a very long time to login on SBS2003

    I am facing issue with Vista 64bit system. I am not able to work on the same. There is a Windows Server 2003 configured on the lan. I am not able to figure out why Windows Vista is taking so much time to connect to the server. The system is added on the domain and has valid access. But still when I try to login I it takes around 10 to 15 minutes to login. While if I do the same on the local computer it just take around some seconds. Is there any issue with Vista. How can reduce this login time.

  2. #2
    Join Date
    Jun 2007
    Go in Event Viewer and just check is there any error related to the connectivity. It is surely annoying when you find some issue like this. At number of places I had found that Vista is not happy to work with Windows Server 2003. There is some incompatible files which are causing the issue. You can run Windows Update and hope to get some fixes that would really work. Also if possible try to configure the dns and the server ip to the same. Means put your windows 2003 serve as the default dns in the system. I am sure it is going to help you in fixing the problem that you are facing and there will be ample of solution for the same.

  3. #3
    Join Date
    Jul 2007
    I think I might have a fix for this, it certainly sorted my issues out with slow boot and also dealing with slow networking talking to any domain resource.

    A feature of the IP stack in Vista is the ability to auto tune to make better use of high bandwidth networks. Windows Server 2003 support this but I have been finding that it can get problematic in certain circumstances. Needless to say that I managed to find one of them.

    To disable this feature on the Vista Client, to see if it affects you, run the following command as an administrator (you may need to turn UAC off, or open NETSH with a right click and run as admin selected).

    NETSH INTERFACE TCP GLOBAL set autotuninglevel=disabled

    If it works, it will do so immediately, no reboot required. If it doesn't you can turn it back on by the following command.

    NETSH INTERFACE TCP GLOBAL set autotuninglevel=normal

    There are some other levels if you wish to experiment; use a question mark after SET in the line above to see all the options.

    Hope that this sorts out your problems.


  4. #4
    Join Date
    Dec 2007
    Thanx a lot, Alex. It works in my situations.
    but correct set is
    netsh interface tcp set global autotuninglevel=disable

  5. #5
    Join Date
    Nov 2010

    re: Windows Vista takes a very long time to login on SBS2003

    Thanks for the resolution but I absolutely had to REBOOT!

    FYI my machines were W7 pro on a 2003 domain.
    Last edited by angri; 06-11-2010 at 03:45 AM.

Similar Threads

  1. Monitor takes long time to display windows screen?
    By Anvita in forum Monitor & Video Cards
    Replies: 5
    Last Post: 13-07-2011, 12:19 AM
  2. Windows Login takes too long to reach desktop
    By Charles1 in forum Operating Systems
    Replies: 4
    Last Post: 02-03-2011, 07:52 AM
  3. Bootcamp takes long time to boot Windows
    By KABIRA16 in forum Operating Systems
    Replies: 6
    Last Post: 14-01-2010, 04:52 PM
  4. Vista takes very long time during startup
    By Seraphim in forum Operating Systems
    Replies: 4
    Last Post: 21-11-2008, 04:04 AM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,702,170,015.76246 seconds with 17 queries