Results 1 to 4 of 4

Thread: wireless connection won't resume after sleep

  1. #1
    Join Date
    Sep 2004

    wireless connection won't resume after sleep

    I have a Dell E1505 laptop running with Windows Vista with all windows updates and recent drivers installed. Problem am facing with this laptop is when it goes to sleep mode and comes back, sometimes it says “limited only connection”, sometimes it takes about 30 minutes to reconnect itself and sometimes it just won’t connect at all.

    Every time I need to restart the computer to connect it online. During troubleshooting I found that running "ipconfig/release -> renew" OR "Diagnose and repair" help me sometime but not always. Only reboot is the proper solution for this issue.

    But why does it behave like this after waking up from sleep? Is there any permanent solution for the same?

  2. #2
    Join Date
    Sep 2004

    Re: wireless connection won't resume after sleep

    I don’t know what could be the reason but most of the time setting up Power Level to high fixes wireless sleep issue. You should try doing the same. Also check your BIOS if you found there anything related to this.

  3. #3
    Join Date
    Apr 2009

    Re: wireless connection won't resume after sleep

    I had very similar issues on my Vista x64 PC with a Netgear Rangemax WN111 wireless USB adapter. When the PC entered S3 sleep mode, the wireless adapter lost connection every time.

    Not sure if this will work on all PCs/network adapters, but what worked for me was the following:
    1. Go into Start > Control Panel > Hardware and Sound > Device Manager
    2. Accept UAC message
    3. Find the wireless network adapter under the Network adapter section and right-click it, then select Properties
    4. Click on the Advanced tab
    5. Scroll down to and click the Tx Power Level option

    My (and probably the default) setting was on 'High Power'. I changed this to 'Medium Power', pressed OK and waited for the adapter to reconnect.

    I haven't had any wireless dropout problems since, after the PC enters sleep mode.

    I am not sure if this will affect performance for other users (I'm guessing that Tx power level is the transmit level to the router), but it is working well for me. My router is about 6m away with 2 walls and timber furniture and metal cabinets in between.

    The other thing I noticed is the blue light on the adapter (indicating connection/activity) now stays on during sleep mode (not blinking, just on all the time). Before it used to glow very faintly.

    I can only put this down to the USB port not supplying enough power to the adapter when it goes into sleep mode. I have an Antec Earthwatts 500 power supply and a Gigabyte GA-MA78GM-S2HP mobo, both of which support S3 sleep. All other USB devices work fine during sleep and resume correctly without any problems.

    I hope this information can help others solve wireless connection issues when PC enters sleep mode.


  4. #4
    Join Date
    Sep 2004

    Re: wireless connection won't resume after sleep

    Just go to Power Saving setting of the Wireless card and check the see if you want to allow the Card to Power Save at all. Also check the settings to allow this computer to wake Up on Network traffic.

Similar Threads

  1. Unable to resume from sleep mode on MSI X 58 Pro-E
    By Borislav in forum Motherboard Processor & RAM
    Replies: 5
    Last Post: 19-07-2011, 11:10 PM
  2. Wireless connection falls down on windows 7 in sleep mode
    By Gania in forum Networking & Security
    Replies: 3
    Last Post: 10-01-2011, 04:53 AM
  3. Windiws 7: Crashes on Resume from Sleep
    By Doriquto in forum Operating Systems
    Replies: 3
    Last Post: 16-12-2010, 10:16 AM
  4. Sleep/Suspend Results in, no Resume
    By TanakL in forum Operating Systems
    Replies: 6
    Last Post: 15-10-2010, 12:11 AM
  5. Replies: 3
    Last Post: 11-09-2010, 07:16 PM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,656,142,763.10169 seconds with 17 queries