Results 1 to 12 of 12

Thread: error 80070424 windows update VISTA

  1. #1
    Join Date
    Sep 2007
    Posts
    5
    Hi, i've tried the solutions in the XP section to this error, but no joy.
    Anyone know what to do? Every time I click on 'check for updates' the screen changes to 'checking for updates' then a moment later says 'windows could not search for new updates' and Error found 80070424.

    if i put regsvr32.exe wuaueng.dll into run, i get this error msg:
    (in a RegSvr32 window) The module "wuaueng.dll" was loaded but the call to DllRegisterServer failed with error code 0x80070005.

    any help much appreciated!

  2. #2
    MowGreen [MVP] Guest
    Open the Services console from
    Start > Run > type in

    services.msc
    Click OK
    Click on Services and locate
    Background Intelligent Transfer Service [BITS]
    Double click on it to determine if it is Running and what the Startup
    type is. As mentioned previously, it can be set to Manual.
    See if you can stop and restart the service if it is currently running.

    There is no place to manually download the latest version of the Windows
    Update Agent [WUA] and the system can't access the Windows Update site,
    correct ?

    If the above is true than the only recourse is to completely and totally
    disable NAV for now. All of it's services must be stopped, too.
    Please consult the provided Help file or Symantec's web site to learn
    how to accomplish this.

    Then see if Internet Explorer can access Windows Update so that the
    latest version of WUA can be installed. This will be done in the
    background when, and if, the system can access WU.
    One last thing you can try, with Internet Explorer *closed*,
    open Internet Options in the Control Panel
    Click the Programs tab
    Click the Manage Add-ons button
    Look for WUWebControl Class
    Click on it to highlight it, then click the Update ActiveX button
    If it succeeds, then close Internet Options and see if IE can now
    access WU

    REMEMBER to reenable NAV after attempting the above.


    MowGreen [MVP 2003-2007]

  3. #3
    Join Date
    Sep 2007
    Posts
    5
    hi, and really thanks for your time,
    i've turned off nav and gone into services, and stopped everything to do with symantec. still the same bloody error code though when i check for updates.. i'm not sure if it is nav related, as the computer ran fine for months updating itself -WITH nav running..

    BITS was already running, when i checked. it was in auto with delay mode.

    There is no wuwebcontrol class in internet properties/programs/manage add ons, either :(

    the only program that was new at the time that this started going wrong was rainbow 6 vegas game, and daemon tools to simulate the dvd being in all the time. both are now uninstalled.

    the link from where i got the WUA was

    i have shown hidden files, folders, and system as explained at the link you provided; there is still no sign of wuweb.dll ...... there is a wuwebv.dll (160kb size) and nothing else close. In 'manage add ons', WuWebControll Class is not visible in any of the subsections (the pull down menu from 'show' -eg 'add-ons that have been used by internet explorer')

    if you're sure that NAV is the culprit, would an uninstall of that program put things right again? Not that this is an ideal solution. Otherwise I can call PSS... it's just that in my experience I expect to be put through to a man with a script, who will start at the very beginning and end up telling me i need to reformat my hard drive.

    is there really nothing else i can do? =(

    the commands you gave me to put into cmd all worked fine apart from one: regsvr32 wudriver.dll
    to this i have a regsvr32 window pop up saying >>

    The module "wudriver.dll" was loaded but the entry-point DllRegisterServer was not found.

    Make sure that "wudriver.dll" is a valid DLL or OCX file and then try again.

    <<


    wuwebv.dll is version 7.0.600.374

    thanks for all your help. i've now got hold of a microsoft support team guy who is trying to help me too, by email. will post any results here, but i fear it could take some time!
    a

    microsoft support unfortunately only directed me to the links i'd already tried (nothing worked). the final word was that if sfc /scannow wouldn't start in cmd, then i will need to get hold of my OEM windows cd and do a repair startup. Failing that, a reinstall.

    I have no problem with the theory of reinstalling windows, but in real time it would take nearly a whole day to back up data, get all my programs back on, installed etc. Such a dumb waste of time! Plus I don't have the cds to all of them (photoshop cs2, for example), so that would be a huge and expensive pain in the *ss.

    is there any sense in waiting to see if this becomes resolved, soonish?

    i've just noticed that an update has been installed, SINCE i have had this problem: the windows malicious software removal tool -september 2007 (KB890830). This was intalled on 16/09/2007.

    Thought this might be worth mentioning in case it helps determine which files are corrupt. eg is that update something that can be detected via a different route than windows update, which is still giving me the same error (80070424) and not searching for updates.

    right i'm really angry now.
    following vista support's advice, i've been waiting to get hold of my OEM recovery dvd in order to do a 'startup repair' of vista, and now that i have it it only has one option: restore computer to factory settings. no 'repair'.

    in other words not very #%*$($)%)#($ helpful. is there anywhere to go from here? it sounds like i need a handful of system files. is there an online version of SFC, mine not working?

  4. #4
    Joshua Yu Guest

    RE: error 80070424 windows update VISTA

    Hi all,

    I have read though the conversation and got it fixed and thanks to all that
    help.
    The only things I have actually done was the followings:

    Restarted Background Intelligent Transfer Service with services.msc

    Install the lastest version of Windows Update Agent from here:
    http://support.microsoft.com/kb/932494

    Then, restoring the dlls in cmd with the following lines:
    regsvr32 wucltux.dll
    regsvr32 wuaueng.dll
    regsvr32 wups2.dll
    regsvr32 wuapi.dll
    regsvr32 wudriver.dll
    regsvr32 wups.dll
    regsvr32 wuwebv.dll

    While wudriver.dll cannot be restored.

    Then the Windows Update finally change back to green colour and suppose to
    work at this point.

    Hope my exp would help.

  5. #5
    notaguru Guest

    Re: error 80070424 windows update VISTA

    I stumbled onto this thread while also trying to find a solution to "getting
    Windows Updates on Vista... and getting error code 80070490". I tried your
    fix with the:

    net stop wuauserv
    regsvr32 wuapi.dll
    regsvr32 wuaueng.dll
    regsvr32 wucltux.dll
    regsvr32 wudriver.dll
    regsvr32 wups2.dll
    regsvr32 wups.dll
    regsvr32 wuwebv.dll
    net start wuauserv
    exit

    Unfortunately it didn't work, but while doing it, I did get an error saying
    "The module "wudriver.dll" was loaded but the entry-point DllRegisterServer
    was not found. Make sure the that "wudriver.dll" is a valid DLL or OCX file
    and then try again. Does this have anything to do with it? Any other ideas?
    I use Windows Live OneCare. My last good update was two weeks ago, and it
    does not show me any restore points before that date.

    Any help would be appreciated.

  6. #6
    Robert Aldwinckle Guest

    Re: error 80070424 windows update VISTA

    Try some diagnosis? Note that the error code may be represented
    elsewhere by the decimal equivalent of its last half...

    <cmd_output OS="XPsp3">
    E:\>set /a c = 0x490
    1168
    E:\>net helpmsg %c%

    Element not found.
    </cmd_output>


    So try searching all the files that the update created or modified
    for either that value or just the hex characters.

    Also, I would try searching with just 490 (i.e., without the 0x prefix
    which specifies that the characters are to be interpreted as hex
    instead of decimal) because some log messages don't always include
    that and in any case including it would preclude you from finding potentially
    useful context where the equivalent value was reported with leading zeros.

  7. #7
    Join Date
    Mar 2009
    Posts
    1
    I am having issues with the error code 80070424. I tried to register the dlls as suggested above but when I get to the wudriver.dll it gives me the message:
    The module "wudriver.dll" was loaded but the entry-point DllRegisterServer was not found.

    Make sure that "wudriver.dll" is a valid DLL or OCX file and then try again.

    I have not found a fix for this and don't know where to turn now.

    I'm not having a problem with bits it seems that the service is working fine. I'm still not sure what the problem is.

  8. #8
    Robert Aldwinckle Guest

    Re: error 80070424 windows update VISTA

    FWIW I would suspect that wudriver.dll should not have
    been included in those instructions. I just checked the one
    that I have with DependencyWalker and found that it
    would not be registerable.

    The meaning of the code isn't clear

    <cmd_output OS="XPsp3">
    E:\>set /a c = 0x424
    1060
    E:\>net helpmsg %c%

    The specified service does not exist as an installed service.
    </cmd_output>

    So, *which* service is the "specified" service?

    In case it's BITS you could use bitsadmin /util (in a cmd
    window Run as... Administrator) to check or repair that service.

  9. #9
    Robert Aldwinckle Guest
    Then you will have to use your logs to figure out
    which service the error is referring to. Use ProcMon
    to supplement whatever diagnostics you are getting
    if necessary when you retry.

    Alternatively, since it is probably still something happening
    in the download phase you could download whatever update
    it is manually and install it manually, thus bypassing whatever
    problems you are having with AU/WU/MU. Then you could
    request help from a newsgroup which specializes in whatever
    product the update involves. Etc.

    Hello, I Belive this is the Error code in which you must Reinstall your
    operating system to fix it.

  10. #10
    ivson Guest

    Re: error 80070424 windows update VISTA

    I have resolved similar problem on my Windows Vista Home Premium x64 sp1. The
    problem was caused by the lack of TrustedInstaller service. I don't know why
    and when this service has disappeared from my system but when I realized this
    I restore it as follows:

    1. Add to registry (save text below to temporary .reg file and import it in
    regedit):

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TrustedInstaller]
    "DisplayName"="@%SystemRoot%\\servicing\\TrustedInstaller.exe,-100"
    "ImagePath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
    74,00,25,00,5c,00,73,00,65,00,72,00,76,00,69,00,63,00,69,00,6e,00,67,00,5c,\
    00,54,00,72,00,75,00,73,00,74,00,65,00,64,00,49,00,6e,00,73,00,74,00,61,00,\
    6c,00,6c,00,65,00,72,00,2e,00,65,00,78,00,65,00,00,00
    "Description"="@%SystemRoot%\\servicing\\TrustedInstaller.exe,-101"
    "ObjectName"="localSystem"
    "ErrorControl"=dword:00000001
    "Start"=dword:00000003
    "Type"=dword:00000010
    "ServiceSidType"=dword:00000001
    "FailureActions"=hex:84,03,00,00,00,00,00,00,00,00,00,00,03,00,00,00,14,00,00,\
    00,01,00,00,00,c0,d4,01,00,01,00,00,00,e0,93,04,00,00,00,00,00,00,00,00,00
    "BlockTime"=dword:00002a30
    "PreshutdownTimeout"=dword:0036ee80
    "Group"="ProfSvc_Group"

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TrustedInstaller\Security]
    "Security"=hex:01,00,14,90,90,00,00,00,a0,00,00,00,14,00,00,00,34,00,00,00,02,\
    00,20,00,01,00,00,00,02,c0,18,00,00,00,0c,00,01,02,00,00,00,00,00,05,20,00,\
    00,00,20,02,00,00,02,00,5c,00,04,00,00,00,00,02,14,00,ff,01,0f,00,01,01,00,\
    00,00,00,00,05,12,00,00,00,00,00,18,00,ff,01,02,00,01,02,00,00,00,00,00,05,\
    20,00,00,00,20,02,00,00,00,00,14,00,8d,01,02,00,01,01,00,00,00,00,00,05,04,\
    00,00,00,00,00,14,00,8d,01,02,00,01,01,00,00,00,00,00,05,06,00,00,00,01,02,\
    00,00,00,00,00,05,20,00,00,00,20,02,00,00,01,02,00,00,00,00,00,05,20,00,00,\
    00,20,02,00,00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TrustedInstaller\Enum]
    "0"="Root\\LEGACY_TRUSTEDINSTALLER\\0000"
    "Count"=dword:00000001
    "NextInstance"=dword:00000001

    2. Copy TrustedInstaller.exe from C:\Windows\WinSxS to C:\Windows\servicing,
    to do this you have to temporary change the permissions to
    C:\Windows\servicing directory. My C:\Windows\WinSxS directory contains three
    versions of TrustedInstaller.exe, I taken the middle version.

    After this Windows Updates started working and i have installed sp2
    successfully

  11. #11
    Join Date
    Feb 2010
    Posts
    1

    Re: error 80070424 windows update VISTA

    hi ivson,

    Could you please explain how to import this reg file to RegEditor.

    Thanks,

    VistaHelp

  12. #12
    Join Date
    Feb 2010
    Location
    MD
    Posts
    1

    Re: error 80070424 windows update VISTA

    I am a novice when it comes to pc systems.
    I was hoping you could please explain, step by step, how to import this / these reg file to RegEditor.

    Thanks

Similar Threads

  1. windows update error 80070424
    By Pete in forum Windows Update
    Replies: 19
    Last Post: 14-04-2010, 05:40 AM
  2. Vista update error 80070424
    By Ebor Fairlie in forum Windows Update
    Replies: 6
    Last Post: 17-03-2010, 06:58 AM
  3. error 80070424 windows update VISTA
    By getalexfr in forum Vista Help
    Replies: 5
    Last Post: 30-09-2009, 10:28 AM
  4. Vista Ultimate 64-bit edition Update error 80070424
    By incubation in forum Windows Update
    Replies: 3
    Last Post: 08-04-2009, 02:09 AM
  5. Vista and Avast Update error 80070424
    By ailin.moeller@gmail.com in forum Windows Update
    Replies: 1
    Last Post: 29-07-2008, 08:35 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,638,121,722.99665 seconds with 17 queries