Results 1 to 11 of 11

Thread: WinXP SP2 Repaired, Windows Update Sees updates, fails to install

  1. #1
    tourque3000@gmail.com Guest
    Just some background: I have run a repair of Windows XP SP2 and it
    seems to be working fine, however when I try to install windows
    updates from the site, they do download but do not install.

    I am able to manually install the updates, however there are about 78
    of them and this could be quite troublesome.

    The machine is going to be Ghosted, so I do no want to have to
    manually install on all the computers I ghost as well.

    An update to the information above: I have tried deleting the
    softwaredistribution folder in windows, forcing windows update to
    redownload all of the updates. Although it redownloaded the updates, I
    was receiving the same problem. I tried checking the history on
    windowsupdate.com, but it just tells me that I have not tried to
    download or install any updates from there.

  2. #2
    Robin Walker [MVP] Guest

    Re: WinXP SP2 Repaired, Windows Update Sees updates, fails to install

    What is the nature of the install failure? Error numbers? Have you looked
    in the WindowsUpdate.log file for what went wrong?

    It is possible that if you have done a Repair of XP SP2, you might need to
    zap the C:\WINDOWS\SoftwareDistribution folder, reboot, and allow it to
    rebuild afresh.

  3. #3
    MowGreen [MVP] Guest

    Re: WinXP SP2 Repaired, Windows Update Sees updates, fails to install

    Since the updating history shown on the Microsoft/Windows Update sites
    is irrelevant due to the Repair Install, then suggest you do this ...
    Show hidden files, folders, and system files

    Go to Start > Run > type in

    net stop wuauserv
    Click OK or press Enter
    Using Windows Explorer, navigate to the WINDOWS\SoftwareDistribution
    folder and delete all of the contents including the subfolders, or just
    rename the folder to SoftwareDistribution.old
    Back to Start > Run > type in

    net start wuauserv

    Click OK or press Enter
    Install the latest Windows Update Agent :
    (*For 32 bits XP*)
    http://download.windowsupdate.com/v7...gent30-x86.exe
    SAVE the update, do NOT run it
    When the download completes, close the browser and any other open programs
    Now install WindowsUpdateAgent30-x86.exe

    Revisit the Windows Update site and the SoftwareDistribution folder will
    be recreated/repopulated, depending on whether you've deleted the
    contents or renamed the folder.
    You can now delete the SoftwareDistribution.old folder if you renamed it.

  4. #4
    tourque3000@gmail.com Guest
    I do not receive any error messages that makes sense. When I check
    windows update, it shows a list of high priorit updates (74 of them).
    I tried just clicking on one or mutliple, but i get the same result of
    them not installing. the process is thus:

    I click on install updates (it shows that they have already been
    downloaded and just need to be installed)

    The update process runs, and every one fails

    it gives me a screen saying that "the following updates were not
    installed"

    The next screen gives a summary. If i click on "review your update
    history", it says i have not installed any. I do not receive any error
    numbers that I can report. Like I said i can do manual installs by
    going to the windows/SoftwareDistribution/download folder.

    Also, I have gotten rid of the SoftwareDistribution folder, but after
    reboot and retry, the same thing occurs

    Here is a line from my ReportingEvents.log

    FATAL: Error: 0x80004002. wuauclt handler: failed to spawn COM server
    Handler FATAL: 0x80004002: ERROR: Remote update handler container
    process created (PID: 1780), but exited before signaling event
    Agent * WARNING: Exit code = 0x80004002

    I will try re-registering my windows update DLL's, to see if that
    fixes the problem

    I already have this service installed, but i tried it anyway, thanks.

    BTW i re-registered the Windows update DLL's
    http://forums.techarena.in/showthread.php?t=626681

    However, that did not help out. the problem must lie within the Fatal
    Error.

    FYI I have the problem fixed, I will post the solution momentarily....

    Okay. So this is the process that I went through to get it working:

    1. stopped the windows update service ( Start > run > net stop
    wuauserv )

    2. renamed the directory windows/SoftwareDistributionto windows/
    SoftwareDistribution.old

    3. uninstalled the windows installer 3.1 (KB893803)

    4. created a batch file that went through and registered the
    associated DLL's, Here is the structure of that batch file

    net stop wuauserv

    regsvr32 wuweb.dll
    regsvr32 wups2.dll
    regsvr32 wups.dll
    regsvr32 wucltui.dll
    regsvr32 wuaueng1.dll
    regsvr32 wuaueng.dll
    regsvr32 wuapi.dll
    regsvr32 wups.dll
    regsvr32 wuaueng.dll
    regsvr32 wucltui.dll
    regsvr32 wuweb.dll
    regsvr32 msxml.dll
    regsvr32 msxml2.dll
    regsvr32 msxml3.dll
    regsvr32 urlmon.dll
    regsvr32 softpub.dll
    regsvr32 initpki.dll
    regsvr32 mssip32.dll
    regsvr32 wintrust.dll
    regsvr32 dssenh.dll
    regsvr32 rsaenh.dll
    regsvr32 gpkcsp.dll
    regsvr32 sccbase.dll
    regsvr32 slbcsp.dll
    regsvr32 cryptdlg.dll
    regsvr32 jscript.dll

    net start wuauserv

    5. restarted the computer

    6. Opened a browser and went to windows update

    7. Downloaded the Windows installer 3.1 --> success!

    8. Restarted

    9. Downloaded the rest of the updates

    If you have any comments or want any clarification on steps, dont
    hesitate to post!

  5. #5
    Keith Guest
    I'd be especially grateful for any help anyone can provide, because I'm into
    this process for a solid two weeks now and really need to get on with life.

    This looks like EXACTLY my problem and EXACTLY the fix I need to run,
    EXCEPT, it won't let me at the DataStore directory, claiming another process
    is using the files (datastore.edb and, in the logs directory, edb and
    tmp.edb). Just can't delete or rename them through either Windows or DOS

    My guess is that I need to stop another process first, but I don't know
    which one.

    Actually, I did stop Automatic Update and it still wouldn't let me at them.
    Also rebooted, but that didn't let me at them either.

    I had the same problem : the destruction of destruction of the
    SoftwareDistribution directory did not solve it. But the execution of your
    registration batch did it alone. Very good shot !!!

  6. #6
    MowGreen [MVP] Guest
    You need to stop the Automatic Updates service via the Services console
    Start > Run > type in
    services.msc
    Click OK or press Enter
    Or, just go to Start > Run > type in
    net stop wuauserv
    Click OK or press Enter

    To restart the service, Start > Run > type in

    net start wuauserv
    Click OK or press Enter

    The Automatic Update service or Automatic Updates in the Control Panel
    are two different beasts. If stopping the AU service did not allow
    access, then perhaps stopping the Background Intelligent Transfer
    Service [BITS] must also be done. Since it's set to Manual here, haven't
    seen this issue that your system is experiencing.

    Also, open Task Manager and if wuauclt.exe is a running Process, click
    once on it to highlight it, then click the End Process button.

    If even that doesn't allow access to the folder, then boot to Safe Mode
    as neither service will be Started in SM.

    Open a Command Prompt, at the prompt type in the following, pressing
    Enter after each command

    net stop wuauserv
    regsvr32 wups2.dll
    net start wuauserv
    exit

    No need to register *ALL* those files:
    http://support.microsoft.com/kb/943144

    The command registers the .dll. Seems there's an old reference in the
    registry that is retained through a Repair installation and registering
    it points to the proper file [CLSID] and path.

  7. #7
    EZ$ Guest
    Step 1: Re-register Update components
    ======================================================

    1. Click “Start”, click “Run”.
    2. Type “cmd” and press Enter
    3. In the opened cmd window, please type the following commands one per line
    to register the update engine

    regsvr32 wuapi.dll
    regsvr32 wups.dll
    regsvr32 wuaueng.dll
    regsvr32 wuaueng1.dll
    regsvr32 wups2.dll
    regsvr32 wucltui.dll
    regsvr32 wuweb.dll

    Please check if you receive any error when trying to re-register these
    components. If yes, please do not hesitate to let me know and go ahead to
    reinstall the update engine. (OF COURSE YOU CAN'T DO THAT)

    Step 2: Reinstall Windows Update Agent 3.0
    ======================================

    1. Please download the file from the following link:
    http://download.windowsupdate.com/v7...gent30-x86.exe
    2. Save the file to C: drive.
    3. Click “Start”-> “Run”, type: “C:\WindowsUpdateAgent30-x86.exe /wuforce”
    and then press Enter to install the Windows Update engine.

    There is a space between "C:\WindowsUpdateAgent30-x86.exe" and "/wuforce"

    After that, please access the update site to check the result. If the
    updates still cannot be installed, please let me know whether any error was
    encountered when reinstall the update agent 3.0. In addition, please also
    send me the latest "WindowsUpdate.log" file as it records the detailed
    updating process.

    It worked great for me.

    The instructions you would be given would be specific to your symptom description.
    So, for example, if it was known that your wuauserv was not working
    you would not be given any instructions to stop it before doing the same
    type of repair actions. If the service is running when you try some repair
    actions they will fail. That is why that first step to stop it is given.

  8. #8
    slugbug Guest
    I have a similar problem in that Microsoft Windows Installer 3.1 (K8893803)
    and Windows Genuine Advantage Validation Tool (KB892130) will not install.
    This came about after running the Repair routine for Windows XP .

    I'm interested in trying the steps you outlined, but have a couple of issues
    that I could use some input on ......

    1. In checking the "install history" on the computer, I find that no
    updates have been installed. Therefore I have no Windows Installer 3.1 to
    uninstall. I assume that is ok.

    2. I am not familiar with the creating a batch file. Are there some simple
    instructions that can be provided as to how one does this?

    3. Assuming I get to where I can create a batch file, will the regserv32
    line items be exactly the same ones that you included in your batch file? Or
    will they be unique to my computer? If they are unique to my computer, how
    do I determine which ones to include in the batch file.

    You can undoubtedly tell that you are hearing from a "novice" who is getting
    into some territory that is new (and scary).

    Any assistance you can provide will be greatly appreciated.

    Also, if there is any way we could talk by phone to work through this, that
    would be of interest to me.

    After doing a repair on XP I had the same Update failure prob as mentioned
    above. Jared's batch alone (other steps not needed) did the trick.

  9. #9
    C Sear Guest
    These 4 lines worked for me too, thanks !
    net stop wuauserv
    regsvr32 wups2.dll
    net start wuauserv
    exit

    In my case, astonishingly, I'd only freshly installed Windows (probably SP1
    or earlier), installed SP2 from a disk, and run Windows Update to get XP SP3
    and high priority updates ! No other software was ever installed on this PC !
    I got the error "Some updates were not installed" and "The following updates
    were not installed" (all the high priority updates were listed underneath).

    For the record, here's what steps led me to the problem:
    Installed Win XP (probably SP1 or earlier)
    Set up a couple of users
    Installed XP Service Pack 2 from a cover disk on a magazine (not knowing SP3
    existed)
    Ran Windows Update, which downloaded and installed XP Service Pack 3
    Ran Windows Update, which downloaded but failed to install any of the 34
    high priority updates.
    After this stage, shutting down using "Install updates and turn off" led to
    the computer switching off before update 1 of 34 had completed.
    Repeated use of "Microsoft Update" gave the same problems.
    Saw this thread, typed the following four lines at the command prompt:
    net stop wuauserv
    regsvr32 wups2.dll
    net start wuauserv
    exit
    Ran Microsoft Update, and every thing was fine again !

  10. #10
    kemperstudent Guest

    Re: WinXP SP2 Repaired, Windows Update Sees updates, fails to inst

    I tried your four line process, but after typing in "net stop wuauserv" it
    shows "System error 5 has occurred. Access is denied." I purchased this
    cumputer brand new from BestBuy and am the only user, therefore the only
    administrator. Any ideas how to fix that?

  11. #11
    Shenan Stanley Guest

    Re: WinXP SP2 Repaired, Windows Update Sees updates, fails to inst

    You'd probably be better off asking on a conversation that did not start
    over three years ago, eh?

    I am assuming you have 32-bit WIndows XP with SP2 or later installed - after
    all - you gave no information on *your* system. If you want to give some
    information on your system (advised) - please do this first:

    Start button --> RUN --> type in:
    (No "RUN", press the WindowsKey+R at the same time.)
    winver
    --> Click OK.

    That will give you (picture at top) the full name of the operating system.
    That will give you (in the test) the Service Pack you have installed.

    How to determine whether a computer is running a 32-bit version or 64-bit
    version of the Windows operating system
    http://support.microsoft.com/kb/827218

    Now - assuming you have Windows XP 32-bit with SP2 or later installed,
    follow this advice:

    Reboot and logon as administrative user.

    Download, install, run, update and perform a full scan with the following
    (freeware version):
    SuperAntiSpyware
    Reboot and logon as administrative user.

    Download, install, run, update and perform a full scan with the following
    (freeware version):
    MalwareBytes
    Reboot and logon as administrative user.

    Download and run the MSRT manually:
    http://www.microsoft.com/security/ma...e/default.mspx
    Reboot and logon as administrative user.

    Fix your file/registry permissions...

    Ignore the title and follow the sub-section under "Advanced Troubleshooting"
    titled, "Method 1: Reset the registry and the file permissions"
    http://support.microsoft.com/kb/949377
    *will take time
    ** Ignore the last step - even if you have not *yet* installed SP3..
    Reboot and logon as administrative user.

    Download/install this:
    http://support.microsoft.com/kb/290301

    After installing, do the following:

    Start button --> RUN --> type in:
    "%ProgramFiles%\Windows Installer Clean Up\msizap.exe" g!
    --> Click OK.
    (The quotation marks and percentage signs and spacing should be exact.)
    ..
    Reboot and logon as administrative user.

    Download/Install the latest Windows Installer (for your OS):
    ( Windows XP 32-bit : WindowsXP-KB942288-v3-x86.exe )
    http://www.microsoft.com/downloadS/d...displaylang=en

    Reboot and logon as administrative user.

    Download the latest version of the Windows Update agent from here (x86):
    http://go.microsoft.com/fwlink/?LinkID=91237
    .... and save it to the root of your C:\ drive. After saving it to the root
    of the C:\ drive, do the following:

    Close all Internet Explorer windows and other applications.

    Start button --> RUN and type in:
    %SystemDrive%\windowsupdateagent30-x86.exe /WUFORCE
    --> Click OK.

    (If asked, select "Run.) --> Click on NEXT --> Select "I agree" and click on
    NEXT --> When it finishes installing, click on "Finish"...

    Reboot and logon as administrative user.

    Visit this web page:

    How do I reset Windows Update components?
    http://support.microsoft.com/kb/971058

    .... and click on the "Microsoft Fix it" icon. When asked, select "RUN",
    both times. Check the "I agree" box and click on "Next". Check the box
    for "Run aggressive options (not recommended)" and click "Next". Let
    it finish up and follow the prompts until it is done. Close/exit.

    Reboot and logon as administrative user.

    Visit http://windowsupdate.microsoft.com/ and select to do a
    CUSTOM scan...

    Every time you are about to click on something while at these web pages -
    first press and hold down the CTRL key while you click on it. You can
    release the CTRL key after clicking each time.

    Once the scan is done, select just _ONE_ of the high priority updates
    (deselect any others) and install it.

    Reboot and logon as administrative user.

    If it did work - try the web page again - selecting no more than 3-5 at a
    time. Rebooting as needed.

    The Optional Software updates are generally safe - although I recommend
    against the "Windows Search" one and any of the "Office Live" ones or
    "Windows Live" ones for now. I would completely avoid the
    Optional Hardware updates. Also - I do not see any urgent need to install
    Internet Explorer 8 at this time.

    Come back - especially if you get stuck someplace, but even if you don't -
    and let everyone know how it turns out.

Similar Threads

  1. Windows update will not install updates for XP
    By pj_singh in forum Windows Update
    Replies: 16
    Last Post: 18-09-2011, 12:07 PM
  2. Vista SP1 Fails to Install From Windows Update
    By Lucile in forum Vista Setup and Install
    Replies: 2
    Last Post: 03-06-2010, 11:01 PM
  3. Fails to install updates winxp
    By dellinspiron8600winxp001 in forum Windows Update
    Replies: 6
    Last Post: 16-08-2008, 09:48 AM
  4. Security Update for IE7 WinXP KB950759 fails to install
    By david331 in forum Windows Update
    Replies: 2
    Last Post: 04-07-2008, 10:54 PM
  5. WinXP SP3 - Fails to install updates
    By James in forum Windows Update
    Replies: 5
    Last Post: 28-06-2008, 04:25 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,642,708,831.33297 seconds with 17 queries