Results 1 to 4 of 4

Thread: .NET Framework 1.1 installs, SP1 fails

  1. #1
    Join Date
    Nov 2011
    Posts
    2

    .NET Framework 1.1 installs, SP1 fails

    I have tried all kinds of variations on the theme - including all the various methods found here and on Microsoft forums - all no joy. I have completely removed all .NET framework stuff scores of times. I can get .NET framework 1.1 (dotnetfx.exe) to install just fine. Then reboot computer. I then try to install anything else - and I get a failure message in a dialog telling me msiexec failed and asks me to report it to Microsoft (which I do each and every time in a futile attempt that perhaps some lackey has nothing else to do than fix this crap).

    This is a computer for a Boy Scout Camp I'm trying to fix for them. The OS is M$ XP Home Edition Version 2002 updated to SP3 running on an ancient Pentium 2, 400Mhz, with a mere 256MB of PC100 RAM. The MSIEXEC is version 3.01.4001.5512; IE is version 8.0.6001.18702. This computer had some memory problem that was resolved by swapping out their failing sticks with some I had laying around. Got the OS up and running, gave them the free AVG antivirus program and started updating the OS with winders updates. It failed on a .NET 3.5 security update and following a couple of KB articles on MSDN, and rebooting a number of times using a few automated stuff. I eventually removed all .NET framework stuff with the removal tool, downloaded dotnetfx.exe (version 1.1.4322.573) manually as well as the SP1 update - NDP1.1sp1-KB867460-X86.exe and the full dotnetfx35.exe along with their critical NDP20SP2, NDP30SP2, and NDP35SP1. Then rebooted - installed .NET 1.1 - rebooted again - tried running NDP1.1sp1-KB867460-X86.exe and I get a failure each and every time. Extensive research and troubleshooting has led me here (and other places) - but not to a solution. I can't figure out where's the problem. I have an error in the the application log shows an info event id 1000 "faulting application msiexec... faulting module msi.dll, version 3.1.4001.5512, fault address 0x000edcae" followed by fault bucket 1174926580

    I currently have WUAUSERV disabled so it doesn't try anything - and I even went so far as to uninstall the AVG program so I know for sure it's not blocking something.

    Any suggestions?

    --

  2. #2
    Join Date
    Dec 2007
    Posts
    2,291

    Re: .NET Framework 1.1 installs, SP1 fails

    Have you tried to manually remove the .NET Framework, and then reinstall the .NET Framework? Otherwise you can also try to remove the .NET Framework by using the Installation Cleanup Utility, and then reinstall the .NET Framework. For more information you can visit this site - http://support.microsoft.com/kb/922377

  3. #3
    Join Date
    Nov 2011
    Posts
    2

    Re: .NET Framework 1.1 installs, SP1 fails

    Please re-read my post a little more carefully. I already used the "cleanup" tool and have manually downloaded all the files. I am patiently awaiting a well-reasoned and meaningful solution that does not regurgitate what is readily available by googling ".NET Framework 1.1 Service Pack 1 fails". Thanks for the consideration, nonetheless! :)

    --

  4. #4
    Join Date
    Dec 2007
    Posts
    2,291

    Re: .NET Framework 1.1 installs, SP1 fails

    If it is a problem with the msi.dll which is the Windows Installer, download the msi.dll file from some dll site by googling and save it inside C:\New, follow the below methods then:
    1. Restart Computer in Safe mode or Safe mode command prompt
    2. Type the following line in the command prompt window
    3. Copy C:\Windows\System32\msi.dll
    4. Rename the copied file from "msi.dll" to "msi.bak"
    5. Type the following line in the command prompt window
    6. Copy C:\New\msi.dll C:\Windows\System32\
    7. Restart the system.

Similar Threads

  1. KB928416 .NET framework 3.0 fails with 0x80070643
    By Guus Ellenkamp in forum Windows Update
    Replies: 3
    Last Post: 09-01-2014, 09:35 AM
  2. .NET Framework 3.0 - KB982524 FAILS
    By JamesKB in forum Windows Update
    Replies: 5
    Last Post: 03-07-2010, 12:34 AM
  3. .net framework 3.5 sp1 installation fails
    By stanshoe in forum Windows Update
    Replies: 4
    Last Post: 17-07-2009, 11:59 PM
  4. Net Framework, Version 2.0 (KB928365) fails to install
    By David F. Sage in forum Windows Update
    Replies: 4
    Last Post: 24-04-2008, 04:11 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,638,089,728.59068 seconds with 17 queries