Results 1 to 4 of 4

Thread: Logitech Gaming Software not starting up

  1. #1
    Join Date
    May 2012

    Logitech Gaming Software not starting up

    I am using Logitech Gaming Software on my Windows 7 pc with Logitech G300 mouse. The software was working fine but suddenly dont know what went wrong now whenever I try to open it, nothing happens. It just wont open. I tried running it from the original launcher in program files but yet nothing.

    While searching somewhere i found that due to firewall also this type of problem occurs, hence I have turned off firewall and tried launching the software but yet the same problem. Finally I uninstalled Logitech Gaming Software, run registry cleaner and reinstalled the same. but yet the same problem. Now please tell me what should I do to solve this problem?

  2. #2
    Join Date
    May 2011

    Re: Logitech Gaming Software not starting up

    You should perform clean boot in your computer try to start Logitech Gaming Software. If it works than there is no problem with the Software, instead your pc is having some problem. To perform clean boot in your computer you have to follow these steps:

    • Open start menu, type "msconfig", press Enter.
    • Now go to General tab, 'selective startup', Select services tab, Check “Hide all Microsoft services”, and click on 'Disable all' button.
    • Select OK button and then reboot your PC.

    Also i would like to know if you are using the latest version of Logitech Gaming Software ? If not, than download the latest v8.20.74 and install it. I think installing latest version will fix your problem. Try it and reply with the results

  3. #3
    Join Date
    May 2012

    Re: Logitech Gaming Software not starting up

    Thanks a lot for your help friend, really appreciated. But unfortunately no one of those worked for me. Neither clean boot nor installing the latest version worked.

    Now what should I do? Please help.

  4. #4
    Join Date
    Jun 2011

    Re: Logitech Gaming Software not starting up

    I have solution to fix this problem. This problem occurs because of the any of the XML file in the Logitech Gaming Software is damaged. You have to perform below steps to solve this problem:

    If you have windows XP Operating systems then follow these steps.
    You have to open Documents and Settings folder from C drive and then open the folder with your username. From local setting folder you have to open application data and then go to the Logitech folder. Now open Gaming software folder and then delete xml files from there.

    For windows 7 and vista follow these steps.
    Open my computer and open your user folder from the C drive. Now double click on the AppData folder and then go to the Local folder. Now open Logitech and you will see the Gaming Software fodder. In Gaming Software folder you will find the xml files and you have to remove it.

    After doing above steps when you start Logitech Gaming Software again at that time you will not get any problems.

Similar Threads

  1. Logitech Gaming Software 8.35 download available?
    By ermahgerd in forum Hardware Peripherals
    Replies: 4
    Last Post: 15-09-2012, 06:52 PM
  2. Launching Logitech Gaming Software 7.0 gives Runtime Error
    By Mr. Anderson in forum Windows Software
    Replies: 8
    Last Post: 22-05-2012, 05:43 PM
  3. Replies: 4
    Last Post: 22-05-2012, 04:22 PM
  4. Logitech Gaming Software 7.00.291 forces to restart
    By Techie-JI in forum Hardware Peripherals
    Replies: 3
    Last Post: 22-03-2011, 08:52 AM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,708,634,562.99386 seconds with 17 queries