Results 1 to 4 of 4

Thread: Set the Macro Security Level in Excel 2007

  1. #1
    Join Date
    Jul 2006
    Posts
    339

    Set the Macro Security Level in Excel 2007

    Hello,
    I need to open an Excel file that contains macros. Excel 2007 does not activate them or not. As a result, the file is not working as it should. Could you tell me what menu I can find access to the macro security level ?

    Thank you in advance.

  2. #2
    Join Date
    Apr 2008
    Posts
    4,088

    Re: Set the Macro Security Level in Excel 2007

    I found the solution. I you do share this in case anyone interested.

    Case 1: when opening the file, Excel displays a message over 1res cells: "Security Warning: The content asset has been disabled." with the Options button. Click on it and check the "Enable this content.

    Case 2: The above message does not appear.
    • Click on the bubble Office (top left)
    • Click on Excel Options (bottom right of the drop-down list)
    • In the Management Center of confidentiality, click the Settings Management Center of confidentiality ...
    • Parameter macros, select the option you want as appropriate. In mine it is Enable all macros.


    I hope this helps someone

  3. #3
    Join Date
    May 2008
    Posts
    4,570

    Re: Set the Macro Security Level in Excel 2007

    In Microsoft Office Excel, you can change the macro security settings to control which macros run and under what circumstances when you open a workbook. For example, you might allow macros to run based on whether they are digitally signed by a trusted developer.

    For more information see here http://office.microsoft.com/en-us/ex...969191033.aspx

  4. #4
    Join Date
    Apr 2008
    Posts
    4,642

    Re: Set the Macro Security Level in Excel 2007

    Follow these steps to view and set the macro security level in Excel 2007:
    1. On the Developer tab, click the Macro Security button in the Code group.

      The Trust Center dialog box appears with the Macro Settings tab selected.
    2. Set a security level:
      • Disable all macros without notification: Allows you to run only those macros stored in a trusted location. Click the Trusted Locations setting in the left pane to manage these trusted locations. Also, since the macros are automatically disabled, this option disables security alerts.
      • Disable all macros with notification: Displays a security alert when a workbook with macros opens. You can then decide whether to enable the macros associated with the workbook. This is the Excel default setting.
      • Disable all macros except digitally signed macros: You can run only those macros that are digitally signed.
      • Enable all macros: Allows macros to run without a notification. This can be helpful if you run a lot of macros, but be aware of the risk when using macros from unknown sources.

    3. Click OK.

Similar Threads

  1. Excel 2003 Macro doesn't work in Excel 2007
    By jjaw in forum Windows Software
    Replies: 3
    Last Post: 03-01-2014, 03:28 PM
  2. How to change Macro security level in MS PowerPoint
    By Protectors in forum Windows Software
    Replies: 4
    Last Post: 23-02-2010, 01:49 PM
  3. Unable to change Macro Security Level in Microsoft word
    By Prashobh Mallu in forum Windows Software
    Replies: 5
    Last Post: 22-01-2010, 02:44 PM
  4. Excel 2007 macro help needed
    By AZUL in forum Software Development
    Replies: 4
    Last Post: 19-11-2009, 06:10 PM
  5. Macro sum problem in excel 2007
    By Radley in forum Windows Software
    Replies: 2
    Last Post: 07-04-2009, 09:46 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,652,889,700.53881 seconds with 17 queries