Results 1 to 4 of 4

Thread: Problem with Microsoft Word 2007

  1. #1
    Join Date
    Dec 2008
    Posts
    65

    idea Problem with Microsoft Word 2007

    Hey Everyone,

    I would like to know that how do i stop TOC updates while printing any word document? I would like to split my large Word 2007 document into two separate documents. It works fine until i give any print command to it, but while updating or by looking into the print preview, TOC automatically appears on the first document. I had turn off my automatic updates for each TOC style level and even had turn off Update fields, before i give any print command in word options. Does any one have any idea about the above issue? Kindly help me out.

    Thanks.

  2. #2
    Join Date
    Apr 2008
    Posts
    4,642

    Re: Problem with Microsoft Word 2007

    There's a bit of a misconception when applying heading styles to Word document content when it comes to TOCs. You do not have to use Word's built-in styles, i.e., Heading 1, Heading 2, and so on. You can create your own, custom heading styles with your own, custom naming conventions and set up the TOC formatting dialog box to recognize your styles. In fact, the only time you must use built-in Word styles (only, as far as I know) is when you plan to setup a cross-reference to a Heading (Insert--> Reference--> Cross-reference--> Heading). In that case, content using your custom heading styles won't display in the dialog box as possible choices for the cross-reference link. Only headings with Word's built-in heading styles will be displayed. Depending on your needs, you may be able to get around that one by using Word's Style Reference field. But why make things more difficult for yourself? If you know you'll also need to reference headings in your document (which requires built-in styles), you might as well use the built-in headings throughout (versus creating custom heading styles) and just plug them in for your TOC as well.

    But if you won't be needing heading cross-references, then you can create your own styles and call them for your TOC. However, if you're new to Word or new to creating TOCs, you might want to stick with Word's heading styles for now, just to make your life easier and TOC creation simpler.

  3. #3
    Join Date
    May 2008
    Posts
    4,570

    Re: Problem with Microsoft Word 2007

    Here are a few suggestions that may ease your pain.

    1. When working with long and/or complex documents, it helps to have a lot of RAM and hard drive space. If your computer has plenty of room to maneuver, you will be less likely to have problems. Processing speed is less important. But you can't change your computer at this point.

    2. That said, there are several things you can do to reduce the load on Word.

    a. It's generally a good idea to get all the text entered before you try to add pictures, index entry fields, or a TOC.

    b. Linking to graphics instead of embedding them will reduce file size, but if you're having a problem with links updating, at the very least disable the "Update automatic links at Open" option on the General tab of Tools | Options. You can update the links explicitly using F9.

    c. Work in Normal view as much as possible. This reduces the load on your graphics driver and on Word.

    d. Turn off the display of pictures by clearing the check box for "Drawings" and checking the box for "Picture placeholders" on the View tab of Tools | Options. Don't forget to reverse the process when you need to see the pictures in place; even with these options set, however, you'll be able to see the graphics in Print Preview.

    I'm not clear what you mean about using cross-references to update your index automatically. When you have inserted index entry fields (XE fields), the index (INDEX field) will update automatically whenever you select it and press F9 or when you print (provided you have "Update fields" checked on the Print tab of Tools | Options). If you are referring to a table of contents (TOC field), this will also update when you print, and cross-references are not required, since Word creates its own bookmarks when you insert a TOC field (Insert | Reference | Index and Tables).

  4. #4
    Join Date
    May 2008
    Posts
    4,345

    Re: Problem with Microsoft Word 2007

    Now you need to instruct Word to run the PasteUnformattedText macro each time you press the ALT+V keyboard shortcut.

    1. On the Tools menu, click Customize.
    2. Click the Keyboard button.
    3. Make sure the Save changes in box displays Normal.dot.
    4. In the Categories list, click Macros.
    5. In the Macros list, click PasteUnformattedText.
    6. Click in the Press new shortcut key box, press ALT and V at the same time. The Press new shortcut key box displays Alt+V.
    7. Click Assign.
    8. Click Close and then click Close again.

Similar Threads

  1. Replies: 3
    Last Post: 14-05-2011, 08:28 PM
  2. Replies: 5
    Last Post: 18-01-2011, 03:42 PM
  3. Discussion on Microsoft Word 2007
    By CACTUS101 in forum Windows Software
    Replies: 4
    Last Post: 11-11-2009, 11:21 PM
  4. Microsoft Word 2007 Tips
    By Yuvraj in forum Tips & Tweaks
    Replies: 1
    Last Post: 26-09-2008, 07:41 PM
  5. how to unlock microsoft word 2007
    By AngerEyes in forum MS Office Support
    Replies: 2
    Last Post: 08-06-2007, 10:33 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,675,251,658.54860 seconds with 17 queries