Results 1 to 15 of 15

Thread: Windows cannot access the specified device path or file.

  1. #1 Guest

    Windows cannot access the specified device, path, or file."

    I am getting the above error when I try to run ANY .exe file on a
    Windows 2003 server but only when I create a NEW user. This problem
    does not occur unless its a brand new user. I have "stared and
    compared" at user settings between old and new and it all looks the
    same. I even assign the new user to the admin group and get the same
    thing. I remap the drives with no luck. I am not sure what else to

  2. #2 Guest

    Re: Windows cannot access the specified device, path, or file."

    How are you accessing these executables on the Windows server? On the
    console? Via RDP? Over a network CIFS share?

    Also, you say that it occurs for brand new users, does the problem
    clear up after the user account has been active for a while? If so,
    then this implies a problem at the domain controller level.

  3. #3
    Join Date
    May 2008
    Not sure if the problem ever clears up with new users. I just keep
    trying to fix this by making new test user accounts.

    I am using terminal services when attempting to open the executables.

    Well trying this I have further narrowed down the problem. I can run
    ..exe's off the local C and D drives of the Win2K3 server. Its when I
    go to the mapped drives on the Netware servers that I hit this snag.
    Looking at the inherited rights of a few I tired, the Everyone group is
    there with nearly full rights.

    The Netware server is where the main apps are the company uses.
    Good point, I think I have seen that one, too. I am not sure that I
    would open up the Internet security zone, however. We worked around it
    by adding the server's names into the Intranet zone. This granted
    sufficient access to non-Windows network resources, without opening too
    wide of a hole.

    when i try to run most *.exe i get this message:

    Windows cannot access the specified device, path, or file. You may not have
    the appropriate permissions to access the item.

    whats going on?

    Do you have the admin rights?Are you thr admin?

    Download and run #12 lefthand side EXE (lnk and regfile) Fix for Windows XP
    Save the REG File to your hard disk. Double click it and answer yes to the import prompt.

    Its a reg fix in xp.

    Do i have to do anything to the registry to stop the message ? about not having admin rights ?

    i checked my settings and says i am the admin,when the computer loads up and i use my disk burner, i try to access other stuff like go to open a folder or notepad or similar i get the windows cannot open path,or file etc havent got admin permission.Also when i use my int explorer bar and pick a place to go it freezes for a few seconds before letting me go to the site in question.
    i need to know how i access the registry to alter the admin line tried the reg fix but nothing happens after its added

    Ok i have found a solution that fixed it for me - in my case it seemed to be a registry file that somehow managed to get deleted:

    i was able to get a fix on your problem. this is not a virus problem. if you are using trendmicro internet security 2007. try turning the system alarm off under virus and spyware settings or change the restrictions. i'm not sure if this would work with other trendmicro versions. so far that's what i found out. thanks, hope this helps....

    Ok here is what happened to me, IE security actually controls the permissions for the OS (at least in xp) (as stupid as that is) ...
    I had to go into IE 's security make sure it was set to Enable or Prompt for "Launching applications and unsafe files" this fixed it for me and I was getting that exact error.

    oh! Oops! Thanks :)

  4. #4 Guest

    Re: Windows cannot access the specified device, path, or file."

    Alright. Let us pick an executable, say calc.exe (under
    C:\Windows\system32). Find that exe file, right click, properties,
    Security Tab. Verify that the local COMPUTER\Administrators group has
    full control permission. Create a user, make a member of
    Administrators, login over RDP and try to launch Calc. What happens?

    Please try this out and let us know.

  5. #5 Guest

    Re: Windows cannot access the specified device, path, or file."

    Alright. Netware's security model is separate from Netware. Hence, the
    question becomes whether this is a Novell or a Microsoft permissions

    If you logon to Windows as Administrator and Netware as a user, can you
    launch an exe? Alternatively, if you logon to Windows as a user and
    Netware as admin.tree, can you launch?

    The former, if the answer is no, indicates that your new users do not
    have appropriate Netware rights. The latter suggests that this is a
    Windows issue.

  6. #6
    SCesarin Guest

    Re: Windows cannot access the specified device, path, or file."

    Hey guys, maybe this info is important for you.
    I got the same problem; accesing files thru the network were not possible
    due to permissions and so...
    The problem comes from IE 7. I uninstalled and restore the IE6sp1 and
    everything worked as usual.
    Another way, if you don't want to uninstall IE 7 is to grant access in
    internet options / security / Internet all those stuff about accesing and
    so... (a lot of work overthere)

  7. #7
    Lorraine Guest

    Windows cannot access the specified device path or file.

    I started getting this message yesterday, for nearly every application I try
    to open. The 1st time, I rebooted and things started working again, but the
    problem is back and rebooting is not helping. The only application I can
    open directly now is Spy Sweeper; I tried running a sweep to see if it would
    find anything amiss, and noticed that it is not scanning any folders (it
    should scan everything on C). I was only able to start Internet Explorer
    indirectly, by clicking the "check for program updates" option on Spy
    I am running Windows XP, with automatic updates, so everything should be
    current. I subscribe to Windows Live OneCare; it is one of the applications
    that I cannot open -- when I click the icon in the tray at the bottom of my
    screen, I get the "Windows cannot access..." message, and another box
    "Windows Live OneCare has encountered a problem and cannot open. To correct
    this problem, try restarting your computer. If the problem continues,
    contact Help Center." with a "Go to Help Center" link. Restarting doesn't
    work, as I already mentioned, and the link doesn't go anywhere.
    Suggestions? Remember, I can't open applications....

  8. #8
    RRG Guest

    "Windows cannot access the specified device, path, or file...

    When I try to run executables, dos prompt, regedit, control panel,
    anything... I get the following message.

    "Windows cannot access the specified device, path, or file. You may not have
    the appropriate permission to access the item"

    I am running XP Home, (SP2). I am an administrator user and I have tried
    system restore to a previous date with no success.

    I have run system restore in safe mode, it completes but does not solve the

    I am using PCcillin from TrendMicro and it reports that I have no threats
    found. I believe that I may have had a virus that changed something, and
    though PCCillin has cleaned the virus, the problem has been left behind.

  9. #9
    Gary English Guest
    Hi Mark,

    I am somewhat computer "illiterate" but I found your posts via a search.

    I have the same problem trying to open any program files, Windows Updates,
    etc...same message continually appears.

    My system is Windows XP Home Edition.

    I followed the instructions written by Aaron Stebner but when I attempt to
    "run" the downloaded file SubInACL.exe, I get the following error message:

    "Windows Installer - The feature you are trying to use is on a network
    resource that is unavailable. Click OK to try again, or enter an alternate
    path to a folder containing the installation package "subinacl.msi" in the
    box below:"

    The "box below" shows Desktop as the only location. When I browse the
    Windows files I do not see a folder called "WindowsResource Kits\Tools"
    anywhere on my system.

    I saved the downloaded file to the folder "Downloaded Installations" in any
    event, but when I click the file to run it, I get the same exact message as

    When I click OK, the following message appears:

    "The installation source for this product is not available. Verify that the
    source exists and that you can access it."

    I am frustrated beyond measure and would greatly appreciate any and all
    pertinent advice.

  10. #10
    Gary English Guest
    I have deleted Windows Installer and successfully downloaded and installed a
    newer version.

    Subsequently, I have followed Aaron's instructions to the letter...

    And I STILL have the same message whenever I try to open any program files,
    Windows Update, etc:

    "Windows cannot access the specified file, path or device. You may not have
    the appropriate permissions..."

    A colleague suggested it may be caused by a Worm which has control of the
    registry files although nothing shows in any scans...

  11. #11
    Rob Guest

    Windows cannot access the specified device, path, or file........

    All, how come, when logged onto a server as the domain admin, I can not
    execute any exe or batch files off a different machine? When I do, I get the
    error: "Windows cannot access the specified device, path, or file. You may
    not have the appropriate permissions to access the item."

    If its not an executable or batch file, the app opens fine. Any help would
    be appreciated.

  12. #12
    iluvambiguity Guest
    Well, for me, that blog seems to address an installation problem. As far as
    I can tell, I'm able to install. I'm just not able to execute an .exe file
    after the installation. When I try, I get the error message, "Windows
    cannot access the specified device, path, or file" that pops up when trying
    to activate an .exe file

    I have Windows XP, Professional, Service Pack 2, and I use an Administrator

    I recently installed google desktop, which added a google desktop exe file
    onto my desktop. Whenever I click it, I get a modal window saying "Windows
    cannot access the specified device, path, or file."

    I've seen lots of suggestions for this problem here and many other sites,
    none of which applies to my situation. Those of us with XP do NOT have the
    option of de-selecting IE Enhanced Security--because no such option exists
    with XP. Likewise, XP users cannot push "reset", as no such button exists
    with XP.

    This is my work computer. I do have a firewall and anti-virus protection,
    but I am disallowed from uninstalling or even tweaking these security
    measures. I've tried the "unblock" trick from the initial properties screen
    from the exe file. No luck. I've modified the file ownership and have
    granted God-like permissions to as many folders and files I could find that
    seem remotely connected to google desktop.

    At this point, I just want to get rid of the google desktop. However, I
    can't even uninstall it because, whenever I try accessing the "uninstall"
    feature, you guessed it, I get the same insidious, infuriating
    message..."Windows cannot access the specified device, path, or file." I've
    gone to the google desktop site to find alternate methods of uninstalling,
    none of which works.

    I'd rather not mess with registers, if at all possible!

    I’ve seen people on this board and others advise folks with this problem to
    "just add your file server in the trusted site from internet explorer tools".
    I know how to add things to the trusted sites. This may be my last hope.
    However, I have no idea what the name of "my" file server is. Please could
    someone tell me how to find out the name of the file server I might need. My
    system uses a shared drive and apparently LOTS of servers (according to a
    co-worker). Is there a path, command or method I could use to zero in on the
    name of the particular file server that I need to add to trusted sites so
    that I'll no longer get the "windows cannot access the specified device..."
    error? If so, I'd really appreciate this information. .

  13. #13
    Join Date
    Oct 2009

    Re: Windows cannot access the specified device path or file.

    Please help!

    I downloaded SuperAntiSpyware on my home computer last night. After it ran its test, it asked that I restart my computer to get rid of the viruses. Once my computer restarted, I was unable to get into any files, programs, or Internet Explorer! I kept receiving the error message "Windows cannot access the specified device, path or file..."

    I did my research on the internet on another computer to find out how to get rid of this message and everyone says that I need to uninstall Internet Explorer enhanced Security Configuration but the problem is, I CANNOT click on Add/remove programs in the control pannel because I receive the same error message nor can I get into my security center!! I also can't get into Internet Explorer and go through the tools>internet options>security to fix this problem.

    I really do not know much about computers so please someone help!


  14. #14
    Join Date
    Apr 2012

    Re: Windows cannot access the specified device path or file.

    the delinquent is your antivirus program which is blocking all your exes.

  15. #15
    Join Date
    Apr 2008

    Re: Windows cannot access the specified device path or file.

    Recently I was also facing similar kind of problem and what happened is that when passing an executable over the network from one computer to another, I for the heck of myself do not for sure why, but I blocked the executable. Thus you can click on the file Properties, and in the bottom look to see if you can see the file that has been blocked for security, if so, then clicking on Unblock will let you run it.

Similar Threads

  1. Replies: 2
    Last Post: 03-05-2012, 06:55 PM
  2. Replies: 22
    Last Post: 03-05-2012, 02:06 PM
  3. Windows cannot access the specified device path or file
    By shadowplayer2 in forum Operating Systems
    Replies: 4
    Last Post: 18-03-2012, 10:59 PM
  4. Replies: 3
    Last Post: 19-12-2010, 07:57 AM
  5. Windows cannot access the specified device path or file problem
    By Gilbert in forum Windows Server Help
    Replies: 5
    Last Post: 25-01-2009, 09:37 PM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,664,735,292.87390 seconds with 17 queries