Results 1 to 8 of 8

Thread: Diagnostics Policy Service won't start

  1. #1
    squire Guest

    Diagnostics Policy Service won't start

    I have a problem with Vista Home Premium (surprise!)

    I have a connection to a home wireless network, which works: 2 computers
    running XP can access it. Up until a couple of days ago mine was working too.
    Now everytime I open internet explorer v.7, it won't display the webpage.
    Network Diagnostics won't work because the Diagnostics Policy Service won't
    start (even after trying to manually start as administrator) and I get the
    msg: "Error 5: Access is denied" even though all users have full control and
    read permissions.

    I have also tried:
    * ringing Microsoft tech support: they can't help me
    * system restore: won't work or fails to complete restore
    * run the repair function through bios (the computer just goes back to
    startup with the same problem
    * uninstall the most recent update (KB940510). Strangely, it appear in the
    'update history' folder, but not in the 'installed updates' folder, so I
    can't uninstall it.
    * starting Windows Firewall or the DHCP client service - same problems

    Any ideas short of a complete re-install of vista? I'm beginning to suspect
    there's something wrong with one of the registry keys &/or system files, but
    I'm not computer literate enough to know how/what to change.

  2. #2
    Mark L. Ferguson Guest

    Re: Diagnostics Policy Service won't start

    I'm sure there are several technical ways to address this security error,
    but perhaps the best way for you is to go at it wholesale. Unless you have
    spent a lot of time with Permissions so far, resetting to defaults may be a
    good solution for you. My thinking is, 'It worked before, so change it
    back".

    HOW TO Reset Security Settings Back to the Defaults:
    http://support.microsoft.com/default...b;en-us;313222

    If this diagnostic problem is just a side issue, you may have luck with IE
    pages by simply clearing the IE cache. IE, tools menu, "Delete Browsing
    History"

  3. #3
    moabs_my_life Guest
    I have the exact same problem word for word.
    mine started on march 8th. I'm starting to think this hos some thing to do
    with windows update. I can't do a repair and it won't start my wireless too.
    I hope someone figures this out.

    I also have the exact same problem and also am connected wireless but with no
    internet connection, I have a suspision it is also a windows update that
    caused it, please someone help us resolve this.

    I am having the same problem. ie: Can't connect to the internet. DPS
    service wont run.

    I don't have a system restore point established.

    Following the above instructions, I forceibly took control of the
    services to run them. This resulted in "Error 1114".

    I don't know what the trouble making DLL is. This problem happens with
    every service I try to run.

    Has anyone determined what to do here?

  4. #4
    Johannes919 Guest

    Re: Diagnostics Policy Service won't start

    I have a solution that worked for me!

    First, try a System Restore...don't worry, it won't touch your personal
    files..just the system settings.

    Go to Start, Control Panel.
    Type System Restore into the search box and chose the second option
    under System.

    It should be:

    Restore System Files and Settings from a Restore Point.

    Choose it and then pick a restore from before the problem started. If
    that doesn't work...like if a message comes up saying System Restore
    didn't complete properly, you need to try it again with a different
    approach.

    You may want to write these instructions down:

    1. Restart your computer.
    2. When it starts up again press F8 repeatedly before it hits the
    loading screen.
    3. Select the first option.
    4. Log in as your usual user (I am unsure what the Admin pass is)
    5. Select System Restore and select a date before the problem started.
    ~If you cannot see the system restore, move the main box out of the
    way.~
    6. Let is restore and hopefully the problem should be fixed.

    It feels good to be telling people how to fix it! It took me 5 days to
    work out the solution...and now, hopefully this solution will work for
    everyone

  5. #5
    Ryan Bartlett Guest
    I think I have solved the problem. Came across several postings about this and related. Forgive me for not being more articulate with communicating techincal terms, but I will try and keep it short. I will check to see if it helps or anyone needs more info. First I read in a thread posting the problem could have something to do with group policy on my computer "Local Service" not being established. The thread, as I remember, refered to a "netsh command" under the CMD prompt to establish the "Local Service" group ( for the newby I guess, many services belong to this group) exsisted. I found out that I received an error because my group did. Probably good to check any way. Next, the thread, not sure if it was the same one fore mention, (I have been spending quit a bit of time trying to solve this problem with out crashing my computer. So fellow newbys beware!) I ran a pre-exsisting snap-in console "Comexp.msc" and checked the security settings for "my computer". If needed I will go into more details about securty settings for any that may need or want. But I prefer at this point you try looking into other threads on that subject if you are that new. Started this task because of frustration with vista. But, don't want to seem basis about software. Since the economy is bad, freely shared info to solve problems (whether good or bad) I think is the solution to many problems. Thanks for this form and community! Hope this thread helps.

    I had a slightly different problem; I could start Diagnostics Policy
    Service, but it would stop abruptly. The course of action that I took
    (which worked) was to disable the service (services.msc) and then
    restart the computer. My computer restarted with internet and then I
    could restart the DPS without any problem. However, this is on my
    family's desktop which I installed Windows 7 RC 32 bit on. Hopefully it
    will work for you.

    I had the same thing happen last night, boy was I mad! It started when
    I interrupted some sort of update. I fixed my computer by doing a
    system restore. I didn't lose any files and my computer is working
    great again. Just thought I'd share my info.

  6. #6
    Join Date
    Jan 2010
    Posts
    1

    Re: Diagnostics Policy Service won't start

    And here goes another one with exactly same story....
    Can't connect to the internet. DPS service wont run. Trying to start it manually only results in error 1114.
    Looking into other treads, others have been recommend to run a system restore.

    But,...
    I don't have a system restore point established.

    PS
    My girlfried seems to recall that maybe she was interrupting some update... - back in mid-December, when this problem occurred out of nowhere. Anyhow, don't know how to undo thus online-update, since... - yeah, you guessed it, I cannot get online....

  7. #7
    Join Date
    Feb 2010
    Posts
    1
    SOLUTION in WIN7:

    1. Go to device manager
    2. Uninstall all the networ devices you have there, maybe "VMware's network cards", "Hamachi", and ofcourse your nework card.
    Uninstall them all, dont worry, you can just redo the other bs's you have.
    3. Scan for hardware changes, your device will then automatically be installed over again.
    4. Wholla, the MS BS works..

    SOLUTION in VISTA:

    1. Go to device manager.
    2. Uninstall all the network devices including the network card.(Don't delete the driver)
    3. Restarted the computer and it automatically found and installed the network card and the driver for it.
    4. Wholla, the internet and associated groceries worked normally again...

  8. #8
    Join Date
    Jul 2010
    Posts
    2

    Re: Diagnostics Policy Service won't start

    OMG! This just started for me this past Sunday. Everything was fine before that. the only way I can get online is through 'Safe Mode.' Now, I've tried the System Restore several times, rebooting, and the deletion of the Network Devices. When I tried to start the DPS manually, the system cycles, but I get error message 1053, system did not respond in time to the request. I see this is a prevalent occurrence but I wanted to know how did it happen and how can I get this repaired without taking the computer back to factory specs.

Similar Threads

  1. Replies: 4
    Last Post: 17-01-2012, 01:41 PM
  2. Cannot start Diagnostic Policy Service
    By artzoop in forum Vista Help
    Replies: 9
    Last Post: 17-09-2010, 07:47 PM
  3. Replies: 2
    Last Post: 01-12-2008, 05:21 AM
  4. Group Policy - Start/stop specified service....
    By prash_mate in forum Active Directory
    Replies: 1
    Last Post: 31-10-2008, 06:24 PM
  5. Replies: 4
    Last Post: 13-08-2006, 12:09 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,708,550,917.52182 seconds with 17 queries