Results 1 to 14 of 14

Thread: Marvell Yukon Ethernet Controller

  1. #1
    frustrated_lady Guest

    Marvell Yukon Ethernet Controller

    sMy Toshiba Satellite laptop running Vista Home Premium has been crashing and
    rebooting itself. When I try to determine what caused the error, I get this

    "This problem was caused by Marvell Yukon Ethernet Controller. Marvell Yukon
    Ethernet Controller was created by Marvell Semiconductor.

    A solution is available that will solve this problem."

    So I went to the Marvell website and looked for the solution, but it doesn't
    give me any info. I have to start from scratch entering info about my
    computer. There is a whole list of downloads from which to choose, but I have
    no idea which one is the correct one for my computer. I went to my Device
    Manager and found the ethernet controller, then did a search for updates that
    way. The results from that search say my driver is current:-/

    Another recently-developed problem is that when I shut down my computer, it
    goes through all the steps, then hangs on the screen that says it's shutting
    down. The first time it did this, I didn't realize it until the next morning,
    when I discovered it hadn't shut down the night before.

    Does anyone have any suggestions?

    Many thanks!

  2. #2
    Rick Rogers Guest

    Re: Marvell Yukon Ethernet Controller


    Click start, type msinfo32 in the search box and hit <enter>. Expand the
    components, then network, and click on adapter. Now, in the right pane
    scroll down about halfway to locate the 'name' line. Post back with the
    information on this line.

  3. #3
    frustrated_lady Guest

    Re: Marvell Yukon Ethernet Controller

    Is this what you needed?

    Name [00000004] Marvell Yukon 88E8039 PCI-E Fast Ethernet Controller
    Adapter Type Ethernet 802.3
    Product Type Marvell Yukon 88E8039 PCI-E Fast Ethernet Controller
    Installed Yes
    PNP Device ID PCI\VEN_11AB&DEV_4353&SUBSYS_FF101179&REV_14\4&367B9776&0&00E0
    Last Reset 11/26/2007 4:16 PM
    Index 4
    Service Name yukonwlh
    IP Address
    IP Subnet
    Default IP Gateway
    DHCP Enabled Yes
    DHCP Server
    DHCP Lease Expires 11/27/2007 5:19 PM
    DHCP Lease Obtained 11/26/2007 5:19 PM
    MAC Address 00:A0:D1:75:8D:EC
    Memory Address 0xF0600000-0xF06FFFFF
    I/O Port 0x00002000-0x00002FFF
    IRQ Channel IRQ 16
    Driver c:\windows\system32\drivers\yk60x86.sys (, 216.50 KB (221,696
    bytes), 1/9/2007 10:00 AM)

  4. #4
    Charlie Tame Guest

    Re: Marvell Yukon Ethernet Controller

    Unzip it and read the readme and if the link to instructions fails (it
    did here) the folder is the various language versions - I think 409 was
    the English version but the readme might work for you.

    The stupid search thing always says the driver is the most up to date,
    because it doesn't look very far :)

    Shutdown issues are not uncommon and not exclusive to Vista, but this
    crashing thing may have triggered that, it may have hosed a registry
    setting or the driver for ACPI... try to get the networking sorted out

  5. #5
    Rick Rogers Guest
    That'd be the one, thanks for looking it up for me.

  6. #6
    frustrated_lady Guest

    Re: Marvell Yukon Ethernet Controller

    Thanks, guys!

    Charlie, I followed your instructions (the link didn't work for me, either),
    and I opened 409. I followed these instructions for updating a driver:
    3.2 Updating the Driver

    To update the driver:

    1. On the desktop, right-click on MY COMPUTER.
    2. Select MANAGE.
    3. In the "Device Manager", double-click your adapter.
    4. Select DRIVER.
    5. Click UPDATE DRIVER...
    6. Follow the instructions given by the operating system to locate the
    7. If the driver which is found to be the latest is not the one you want to
    install, select the check box "Install one of the other drivers".
    8. Click NEXT.
    9. From the driver list, select the driver to be installed.
    10. Click NEXT.
    11. If a message is displayed saying the driver is not digitally signed by
    Microsoft, click YES.
    12. Click FINISH to complete the installation.

    NOTE: The latest version of the driver is available for download from our
    web site.

    Step 7. is where I'm stuck because it doesn't show any drivers, nor does it
    show any alternatives.

    I browsed my computer for driver software and came up with this list.

    Generic Marvell Yukon 88E8039 PCI-E Fast Ethernet Controller
    Generic Marvell Yukon Chipset based Ethernet Controller
    Marvell Yukon 88E8039 PCI-E Fast Ethernet Controller (Marvell)
    Marvell Yukon 88E8039 PCI-E Fast Ethernet Controller (Microsoft)

    Which one do you suggest I use?

    Many thanks!

  7. #7
    Rick Rogers Guest

    Re: Marvell Yukon Ethernet Controller


    Download the file from the link Charles posted to your desktop. Then right
    click on it and select 'extract all'. It will create a folder on your
    desktop and you can delete the .zip file. Then you search for an updated
    driver by right clicking the network adapater in Device Manager and choosing
    "Update Driver Software". Choose the second option to browse the computer,
    then browse again and select your Desktop from the top of the folder dialog.
    Check the box to include subfolders and click next. You should be able to
    follow the prompts from here.

  8. #8
    james4747 Guest

    Re: Marvell Yukon Ethernet Controller

    Sorry to bring this topic back up. I have had virtually the same
    problems as the above poster on my computer. I'm also running Windows
    Vista. I didn't have any problems until one day my machine hung while
    shutting down. Now I see the same error as the above poster when the
    machine turns back on.

    I tried updating my driver using the link above, to what I believe to
    be version However, when checking this using the msinfo32
    command it appears as version If I check it through the
    device manager it appears as (Release date 29/11/2007)

    Since the problem continued I tried removing the Marvell Yukon driver
    and shut down before vista had time to install it again. This allowed
    me to shut down successfully, so this is defiantly a driver issue.
    However, after vista reinstalled the driver shut down problems
    continued, and updating the driver to v10.28.3.3 once again still
    didn't solve it.

    The only time this is a problem is when shutting down, my computer does
    not seem to crash at any other time due to this issue. Any help would be
    greatly appreciated, as I'm out of ideas on this one!

    Below is the information from msinfo32

  9. #9
    SB52 Guest

    Marvell Yukon Ethernet Controller

    Had a message that windows (vista) recovered from an unexpected shutdown and
    it was caused by following:

    This problem was caused by Marvell Yukon Ethernet Controller, which was
    created by Marvell Semiconductor.

    What is the solution to this problem please?

  10. #10
    Mick Murphy Guest

    RE: Marvell Yukon Ethernet Controller

    The solution is for you to go to Marvell Yukon's or Marvell Semiconductor's
    website, and see if they have an updated vista compatible driver/patch for
    your Ethernet Controllor.
    It is your computer, and you know the version of Drivers installed!

  11. #11
    Richard G. Harper Guest
    Check with your PC/laptop/motherboard manufacturer for updated drivers for
    the device. If it's happened only once it may not necessarily be something
    that needs fixing.

  12. #12
    qtz20 Guest

    RE: Marvell Yukon Ethernet Controller

    I have exactly the same problem. I have updated the drivers and the problem
    still persists., I'm getting random BSODs and restarts. Have also updated
    from MSUpdate. Have you got any idea of what to do?

  13. #13
    DarkSentinel Guest
    I have seen this issue before. What version of the driver is being used? The
    solution for the user I helped before was to roll back to a previous version
    of the driver. I have the same controller, but have had no issues with it.
    That solution has helped others that HAVE had problems however.

  14. #14
    Join Date
    May 2008
    Disable the onboard nic, and use a PCI NIC, works perfect no problems at all, appartly Nvidia will adress to issue in a future Bios update which will be passed on to your MOBO manuafacture.

Similar Threads

  1. Need information on ASUS P7H55-M/USB3 Marvell Controller
    By Patcy in forum Motherboard Processor & RAM
    Replies: 7
    Last Post: 14-10-2011, 10:21 PM
  2. SATA 6Gb/s is useless with Marvell controller?
    By Aerona in forum Hardware Peripherals
    Replies: 5
    Last Post: 28-05-2011, 10:25 AM
  3. Replies: 4
    Last Post: 13-04-2011, 10:38 PM
  4. Marvell Yukon 88E8056 Gigabit connecting @ 100Mbps on Auto-Negotiate
    By Dharitree in forum Windows Vista Network
    Replies: 1
    Last Post: 25-10-2008, 05:09 AM
  5. Marvell Yukon 88E8053 PCI-E Gigabit Ether net Controller
    By Aadimoolan in forum Small Business Server
    Replies: 1
    Last Post: 24-02-2007, 07:37 AM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,696,093,760.48861 seconds with 17 queries