Results 1 to 6 of 6

Thread: Error=429 : ActiveX component can't create object

  1. #1
    Join Date
    Sep 2004
    Posts
    17

    Error=429 : ActiveX component can't create object

    Hi, recently upgraded one of my laptops which were running on Windows XP to Vista Home Premium. Now there are two programs which i use for my business, they were working good in XP but not on Vista. One of them is created on VB while other is in a script environment. Whenever i try to install any of these programs on my Vista laptop, it ends up with an error message saying:

    "Error 429 : ActiveX component can't create object"

    I did some searches on web and found an article saying to run "regsvr32 scrrun.dll" from the CMD prompt as an Administrator to fix the problem. I did the same and both the programs got installed without any error. I was so happy. But it was just until the next reboot.

    Every time i reboot the system i get the same error message again. For more troubleshoot i went to MSCONFIG and disabled all the start-up programs from but that dint made any difference. I guess there is some problem in registry, probably a corrupt key loading at startup. Now i dont have any idea what to do. Hope any one of you can help me out. Many thanks.

  2. #2
    Join Date
    Jun 2006
    Posts
    206

    Re: Error=429 : ActiveX component can't create object

    Yeah, you are correct dude. Probably the problem is somewhere in registry permission. Anyway, there is a fix for the same. You can download a utility called "Regmon" from this Microsoft link. In the Filter dialog, uncheck "Log Successes"Clear the entries and run "regsvr32 scrrun.dll" again.

    By doing so you can see all the keys that regsvr32.exe accesses to perform this command. If you find any key saying "ACCESS DENIED" simply change the permissions for that particular key.

  3. #3
    Join Date
    Sep 2004
    Posts
    17

    Re: Error=429 : ActiveX component can't create object

    Thank you very much for your help MikeY007. As you suggested i downloaded the Regmon from MS and applied. It came up with a message saying it had been replaced in Vista by SysInternals Process Monitor. Later i found several entries for "regsvr32" using Process Monitor.

    Captions were as follow: Success, No more entries, Name not found, Fast IO disallowed and Reparse. Apart from all these, i found two entries saying "Access Denied" for "Set Basic Information File" into "c:\Windows" and "c:\Windows\System32". From this result I would surmise that I need to make these system
    folders able to be written to by regsvr32.

    Can you tell me if it is as simple as removing the "read only" attribute in Folder Properties ? Thank again.

  4. #4
    Join Date
    Sep 2005
    Posts
    95

    Re: Error=429 : ActiveX component can't create object

    It seems like there would be a duplicate registry entry where the wrong one is found first? Could be permissions actually, maybe something can't be overwritten by the installer but can be created new at runtime?

  5. #5
    Join Date
    Sep 2004
    Posts
    142

    Re: Error=429 : ActiveX component can't create object

    I can tell you that but I'm not familiar with the inner workings of Vista. I know that UAC will cause Registry writes to dummy HKCU keys in some cases without telling you that it's not allowing you to write the real value. There are also complications if you've got 64-bit, but again, I don't know the details.

    When you create an object it goes through HKCR (CLASSES_ROOT). For instance, if you're getting
    the error with the FileSystemObject:

    When you create a FileSystemObject instance it gets created by looking up the ProgID in HKCR. In the case of script you have something like:

    Set FSO = CreateObject("Scripting.FileSystemObject")

    Scripting.FileSystemObject is the ProgID of the object. An object can be found in HKCR by either its ProgID or CLSID. So to trace the path of how COM is trying to load the object, you start by looking at the ProgID key:

    HKCR\Scripting.FileSystemObject

    The CLSID subkey there has a default value that points to a key under HKCR\CLSID. That seems to be {0D43FE01-F093-11CF-8940-00A0C9054228} So you then look under HKCR\CLSID\{0D43FE01-F093-11CF-8940-00A0C9054228}

    The subkey there named InProcServer32 has a default value that should be a string representing the full path to scrrun.dll. In some cases that will be a LocalServer32 subkey, but either way, that's the basic COM setup for figuring out which library to load given a ProgID.

    It might also help to run Regmon to see what is *actually* being accessed in the Registry when your program is run, but I don't know whether Microsoft has blocked Regmon from running on Vista. They bought out sysinternals.com and are now saying that Regmon has been "replaced" on Vista
    by Process Explorer. But procexp.exe is actually an entirely different thing. (Search for Regmon at Google if you don't know what I'm talking about.)

  6. #6
    Join Date
    Jan 2011
    Posts
    2

    Re: Error=429 : ActiveX component can't create object

    I dont know much about all this, I get the same error, and was informed it was a coding issue with MS software vista and win 7 do it. something to do with late bindings, its a bug and nothing to do with the software your trying to run. MS seems to have changes the file ext from .cab to something else and thats where the confusion appears to start. (confusion between the os and the program your running )
    Thought I'd pass that along, hope it helps.

    For me it happens when I try to run a rpgmud program I mess around with, and have messed with for years. I recently did a clean install of windows 7 pro
    and now i get the '429' message. After asking around and alot of surfing the only perm. fix is writing a script apparently until they come out with a pack/patch
    Hope this helps somewhat.

Similar Threads

  1. ActiveX component can't create object error
    By Abe Simpson in forum Windows x64 Edition
    Replies: 8
    Last Post: 14-06-2011, 11:32 PM
  2. Error 429 : ActiveX component can't create object
    By GunTher in forum Vista Help
    Replies: 8
    Last Post: 30-01-2011, 03:04 AM
  3. Replies: 2
    Last Post: 01-06-2010, 04:00 AM
  4. Replies: 2
    Last Post: 25-12-2008, 03:01 PM
  5. Error=429: ActiveX component can't create object
    By vibhub in forum Vista Help
    Replies: 2
    Last Post: 23-12-2008, 07:41 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,642,928,419.18413 seconds with 17 queries