Results 1 to 6 of 6

Thread: Scan Button Event

  1. #1
    Join Date
    Sep 2004

    Scan Button Event

    I am using a Windows Vista Home Premium 32-bit desktop with Canon PIXMA MP600. Suddenly something went wrong with this system. I am now no more able to change the program that handle scan events. Whenever i try to do the same, it ends up with the following error message:

    "Event Registration Failed
    The attempt to change the register event handler failed. Please make sure the device is turned on and connected properly."

    This error pop up use to have OK button which on clicked dont do anything. Its parent process is ImagingDevices.exe running on my system. As per troubleshooting i already tried re-installing drivers, updating drivers but that doesn't seems to be working. Later i also tried contacting Canon Support for help but they said the problem is with Vista and not with their product.

    Thats really very annoying. Is there anyone else facing this problem or just me? Any working solution? Many Thanks.

  2. #2
    Join Date
    Oct 2007
    I have the same problem. Just bought a Canon MP530 and am trying to configure the Color and B&W scan buttons but keep getting the error "Event registration failed."

    It happened on both my laptop (Toshiba M400) and new desktop. Both are running Windows Vista Ultimate. I downloaded the latest drivers and software from Canon but it didn't fix the problem.

    I suspect its a bug with Vista. Anybody have any idea how to fix?

    I have the same problem with a Cannon Canoscan 8800F that I just installed. From reading elsewhere others have reported that it may be a registry permissions problem where one of the registry keys does not have the right permission to allow changes. However, I've not found any such problems yet, and other references on the web do not mention specific registry keys.

    I finally found and fixed the problem. The issue is that when the cannon installer sets up certain registry information it does not set the permissions to allow LOCAL SERVICE full permission in Windows Vista. Thus the control panel cannot write the changes. For the Cannon Canoscan 8800F scanner, the registry key named [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{6BDD1FC6-810F-11D0-BEC7-08002BE2092F}\0005\Events] must be set so it and its descendants have full permission for LOCAL SERVICE. The exact "events" key that needs this fix will vary depending on the exact model of scanner that is installed.

    I have exactly the same problem as outlined above (Event Registration Failed, etc.)

    I was delighted to find the solution posted by daled and elzingap. However, in attempting to implement the solution I'm not sure I know how to set the permissions to allow LOCAL SERVICE full permission. I'm using Windows Vista Home Premium.

    I right clicked on the key and its subkeys in the Registry Editor, then clicked on Permissions... The Group or user names listed are: CREATOR OWNER, SYSTEM, Administrators (Owner-PC\Administration), and Users (Owner-PC\Users). When I click on the Advanced button and then Edit, there are check marks in the Allow boxes but they are greyed out. I have to go up to SYSTEM before I get to Allow boxes that aren't greyed out. But all of these show Allow as well.

    Am I in the wrong area? Should I be looking elsewhere for LOCAL SERVICE to set full permission?

    Any and all help will be greatly appreciated!

    Same problem on the CanoScan LIDE 100. What I really need is a step-by-step guide on what to do. I have never edited a registry entry before.

  3. #3
    Join Date
    Nov 2004

    Re: Scan Button Event

    Hey guys, even i am facing a very similar problem. In my case, i have installed Nuance PaperPort 11 for Windows Vista. I also installed the Vista drivers for my HP ScanJet 5590.From Control Panel's Events tab on the Scanners and Cameras i am able to assign the five buttons on the front of the 5590, also i'm able to assign particular scan profiles for each of those buttons from the Oprions/Buttons menus in PaperPort. But when i try to change the Action on the Event menu in the Control Panel applet, it gives me the following error message:

    "Event registration failed" error that states, "The attempt to change the registered event handler failed. Please make sure the device is turned on and connected properly."

    I ensured that device is turned on and connected properly. Then where is the problem?

  4. #4
    Join Date
    Feb 2009

    Re: Scan Button Event

    Great solution! Thank you for finding out what the problem was. It is indeed the permissions to a registry key. The key I had to change permissions for is slightly different (I also have a CanonScan 8800F):
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{6BDD1FC6-810F-11D0-BEC7-08002BE2092F}\0004.
    I did not have an Events subkey, so I changed permissions of the key above and all of the subkeys.

  5. #5
    Join Date
    Jun 2010

    Re: Scan Button Event

    Here's what I had to do in Vista, step by step.
    1. Click on the Start button, go to Programs, then Accessories.
    2. RIGHT click on Command Prompt, and choose "Run as Administrator".
    3. Click Continue when Windows asks for permission.
    4. In the Command Prompt Window, type "regedit" (without the quotes). The explorer-like Registry editor will open.
    5. Navigate down the tree as follows:
    C. CurrentControlSet
    D. Control
    E. Class
    6. This is the tricky part. There are a bunch of entries (keys) with seeming random numbers. Click down through them to find one whose first line on the right hand side of the window says "Imaging devices". This should be the key for your printer/scanner.
    7. When you open this key there may be one or more subkeys that look something like "0000", "0001", "0002", etc. Click on each of these and look at the right hand part of the window to see which one displays your printer/scanner name.
    8. When you find the correct one, open it and choose the key "Events".
    9. In my case there were three button events, the right hand pane of "Button0" was "Scan Button". That's the one that needs it's permissions changed.
    10. Right click on "Button0" (or whatever your's says) and choose "Permissions".
    11. Click on "Add" and type in "Local Service" in the window, then click "OK".
    12. Click on the line in the upper window that says "LOCAL SERVICE" and click the "Allow" "Full Contro" checkbox in the lower window.
    13. Finally, click "OK" and close all the windows.
    14. Whew! Take a break and congratulate yourself on a job well done!

  6. #6
    Join Date
    Sep 2011

    Re: Scan Button Event

    I have the same problem with Windows 7 Home Premium. I followed the above steps but software will still not open. Should I just return the device and forget it?

Similar Threads

  1. Replies: 4
    Last Post: 09-09-2011, 10:18 PM
  2. My HP Photosmart C4280 is not having a scan button in System
    By Swiz in forum Hardware Peripherals
    Replies: 5
    Last Post: 04-09-2011, 10:07 PM
  3. Replies: 7
    Last Post: 15-06-2011, 07:39 AM
  4. HP C4580 scan button not working with Snow Leopard
    By SajalSOFT in forum Hardware Peripherals
    Replies: 6
    Last Post: 07-09-2010, 11:59 PM
  5. Event Log Error: Event Source:WinMgmt Event ID:10
    By BlackSunReyes in forum Small Business Server
    Replies: 2
    Last Post: 01-03-2007, 03:27 AM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,664,261,740.01275 seconds with 16 queries