Results 1 to 6 of 6

Thread: Error message: insufficient privileges to modify this file

  1. #1
    Philly lawyer Guest

    Error message: insufficient privileges to modify this file

    I have a brand new (purchased in May) Dell PC with Vista Premium. Since it
    is a family computer, I set up each user (husband, teenaged daughter, and
    self) with administrater accounts so we would all have full access.
    Nevertheless, we continue to have issues with downloading, installing, or
    updating certain software and sometimes with trying to uninstall programs
    we've decided to get rid of; we frequently receive the dreaded Error message:
    "You have insufficient privileges to modify this file." I have then gone in
    and tried to change the privileges to try to give at least myself full access
    to whatever file we're trying to modify, since I am by default the
    (self-taught) "techie" for the family. This sometimes works, sometimes does
    not. The latest most annoying problem in this regard is with I-tunes. The
    version on the computer, which we tranferred from our old computer, needs
    updating, but Vista wouldn't allow it. I then tried to broaden the access
    privileges, and was unsuccessful. I can't seem to find any way to get Vista
    to allow updating on this file. Does anybody know how to resolve this
    problem for I-tunes in particular and for the system overall, since it is a
    recurring problem?

  2. #2
    PaulB Guest

    RE: Error message: insufficient privileges to modify this file

    Right click on the iTunes.exe file and select "Run as administrator".

  3. #3
    Philly lawyer Guest

    RE: Error message: insufficient privileges to modify this file

    PaulB, I tried this and got a similar error message saying I don't have
    sufficient privileges to modify the file "itunes.icxs," which I can't find on
    my computer.

  4. #4
    Philly lawyer Guest

    Re: Error message: insufficient privileges to modify this file

    I didn't know this was possible. Can you tell me how to do it? I'll be more
    than happy to give that try, we really don't need the this kind of control.

  5. #5
    Paul Randall Guest

    Re: Error message: insufficient privileges to modify this file

    I don't recommend leaving UAC turned off, but ...

  6. #6
    Philly lawyer Guest

    Re: solution to Error message: insufficient privileges

    Unfortunately, turning off the UAC did not resolve my problem concerning
    privileges to access files. After I turned off the UAC, I tried updating
    ITunes and QuickTime again and received more, similar error messages
    concerning first, the Apple updater, then various subfolders in the ITunes
    and QuickTime’s folders. Every time I corrected the privilege issue with one
    file, the next try resulted in another error message about another file.

    The good news is that after much trial and error (which is the way I've
    learned most of what I know about computers, with occasionally tips from
    helpful people like you all to send me on the right trail,) I finally
    resolved my issue and think what I did will be a fix for any future similar
    issues. In short, I discovered that every single file and subfile you are
    trying to access and modify must be both owned by the Administrator and have
    all the relevant privileges enabled. I also discovered that not all subfiles
    (at least of a downloaded program) are designated as owned by the
    administrator and even if a file is owned by the admin, the privileges are
    not necessarily enabled.

    At first, I thought I had to go through each and every folder and subfile to
    check and change everything manually, but I finally discovered a shortcut
    that appears to work (though I'm not going to hold my breath that it will
    always do so.) Right click on the main folder in the Program Files directory
    and go to Properties. Go to the Security tab and click on Advanced, then
    Owner to see who owns the file. If it is not Administrator, click on Other
    Users or Groups to change ownership. Type Administrator into box, click
    Check Names, and the name of your Administrator will appear; click OK. When
    you get back to the Owner page, click on name of Administrator until it
    appears as name of Current Owner. NOW, HERE’S THE IMPORTANT PART: at the
    lower left is a box that says “Replace owner on subcontainers and objects.”
    CHECK THIS BOX! If you don’t you will have a bunch subfiles that will still
    be a problem.

    After that, click OK, then OK again and you should be back at the Security
    tab. Click on Edit, highlight the administrator’s name in the box, and click
    on Full Control under the Allow column. Click OK, then OK again, and you
    should be done. Check a couple of subfolders to be sure. If this doesn’t
    work, either you missed a step, I missed step in my directions (I don’t think
    I did, but I can’t be sure, there’s a lot of them,) or my theory only worked
    on my one problem and is not a universal cure-all. If anybody tries this on
    a similar problem with Vista and another “insufficient privileges” problem,
    please let us know how it goes.

    Thanks, everybody for your efforts to help me out. I hope I’ve contributed
    something useful.

Similar Threads

  1. Replies: 1
    Last Post: 25-10-2012, 04:40 PM
  2. Insufficient Privileges as an Administrator in Windows 7
    By Wamika in forum Operating Systems
    Replies: 4
    Last Post: 30-12-2010, 11:41 PM
  3. Insufficient memory message is displayed during the file scan
    By PuppETR in forum Networking & Security
    Replies: 3
    Last Post: 23-12-2010, 07:26 PM
  4. Insufficient Privileges Error while Copy and Pasting Files
    By Dewei in forum Hardware Peripherals
    Replies: 6
    Last Post: 30-05-2010, 06:26 AM
  5. Insufficient privileges error during tablespace creation
    By Adriana_andros in forum Software Development
    Replies: 5
    Last Post: 13-02-2010, 07:15 PM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,680,119,904.20743 seconds with 17 queries