Results 1 to 7 of 7

Thread: How to set default keyboard layout in Welcome screen to English?

  1. #1
    Alek Davis Guest

    How to set default keyboard layout in Welcome screen to English?

    When I configured Windows Vista Home Basic on a new laptop, I picked Russian
    regional setting (language, keyboard, etc) wrongly assuming that it would
    localize Vista. Now that I know that it would not work like this, I need to
    switch all settings back to English. I modified all regional settings leaving
    just English (US) keyboard layout, but when I power on the system, the
    default language in the Welcome screen is Russian (with RU showing in the
    corner). I can change it by clicking the RU button and selecting EN, but it's
    a hassle to do it every time I log in. Is there a way to set the default
    keyboard layout back to English? I don't quite understand why both languages
    show up even if the Russian keyboard is not installed. Thanks.

  2. #2
    Saucy Guest
    Use Regional and Language settings to remove the Russian keyboard.

    There is a setting somewhere on the Regional Settings tabs, to make the
    current settings the default for all users. Try that.

  3. #3
    Alek Davis Guest
    As I mentioned in the original post, I had already removed Russian keyboard
    (from Regional Settings), so after logging on, I do not see the keyboard
    switch or anything related to local languages. But for some reason, the
    default keyboard on the Welcome screen is set to Russian and I cannot figure
    out how to switch it back to English.

    I spent almost an hour yesterday looking all over Regional Settings for
    something like this and I gave up. There is a a button which applies the
    currently defined settings to future accounts, but the documentation says
    that it does not apply to the already existing accounts. This makes sense
    assuming that the current settings are applied to the immediate account
    (under which I'm making changes). And they do, but only after logging in.
    What I can't figure out is how to make them take effect on the Welcome
    screen, i.e. before I log in.

  4. #4
    Saucy Guest

    Re: How to set default keyboard layout in Welcome screen to English

    Control Panel (classic view) > Regional and Language Settings > Keyboards
    and Languages tab > Change keyboards... button > the Text Services and Input
    Languages dialogue box pops up

    Is it set to Russian (Russia) with a only US keyboard listed underneath? Or
    describe what's listed?

    My default input language is set to English (Canada) -US , but I removed all
    the keyboards but the US keyboard so it looks like:

    EN English (Canada)
    -Keyboard
    -- - US

    -Other
    -- - Ink Correction

  5. #5
    brink Guest

    Re: How to set default keyboard layout in Welcome screen to English?

    Check these settings in Regional and Language Options:

    1. Click the Administrative tab.
    2. Under "Language for non-Unicode programs", make sure that you have
    "English (United States)" selected.
    3. Under "Reserved accounts", click the "Copy to reserved accounts"
    button.
    A) Click Continue for UAC prompt.
    B) Check "System accounts....." and click OK.

  6. #6
    Alek Davis Guest
    In the Default input languages, I see English (United States) - US; there is
    nothing else present in the drop-down list box. Under Installed services, I
    see just English (United States) - Keyboard - US. That's it.

    I have already done this with the exception of System Accounts. Will try it
    for System Accounts when I get home. Thanks.

    Thank you, brink. The "System accounts" option did it. I had to click the
    "System accounts" button for the keyboard to take affect. I appreciate the
    help.

  7. #7
    Nasho23 Guest

    Re: How to set default keyboard layout in Welcome screen to Englis

    Sorry to cut in on this Vista thread.
    Is there a similar fix for XP SP3.
    When I bootup, I get a Russian "Welcome" and when I shutdown the text is in
    Russian. All working screen text is now in English after changing it in
    Regional and Language Settings.

Similar Threads

  1. Replies: 3
    Last Post: 31-07-2013, 11:26 AM
  2. How to change Keyboard layout on startup / logon screen
    By Gerrit Horeis in forum Windows Server Help
    Replies: 3
    Last Post: 20-02-2013, 01:22 AM
  3. Windows 7: Unable to remove default English keyboard
    By Rufta in forum Operating Systems
    Replies: 5
    Last Post: 13-01-2012, 09:29 PM
  4. How to take print screen with Mac layout keyboard
    By Indudeep in forum Windows Software
    Replies: 3
    Last Post: 16-09-2011, 09:08 AM
  5. Keyboard layout changes
    By aleangelico in forum Vista Help
    Replies: 6
    Last Post: 30-01-2009, 01:04 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,642,932,972.27430 seconds with 17 queries