Results 1 to 3 of 3

Thread: How to remove "Open File - Security Warning" window?

  1. #1
    Echevil Guest

    How to remove "Open File - Security Warning" window?

    Content-Type: text/plain; charset=UTF-8; format=flowed
    Content-Transfer-Encoding: 7bit

    Hi

    After installing vista, almost all shortcuts that I put into the LINKS
    folder prompts an "Open File - Security Warning" message window when
    opened. These shortcuts point to safe local files and could be opened
    directly in win xp.

    It's getting annoying now. Is it possible to remove it? I guess it has
    something to do with security setting of IE7.

    BTW, I always like to put shortcuts in the Links folder and use them
    instead of Quick Launch. The difference is, folders in Links folder are
    opened as sub-menus when clicked on, while in quick launch, an explorer
    window will open the folder itself.

    ____
    Regards
    Chen PANG

  2. #2
    Join Date
    Jun 2009
    Posts
    1
    This does indeed have to do with the new security features of IE7 and
    Windows Vista. The reason this extra prompt is in place is because IE7 can
    create and modify files inside of your favorites folder, which includes the
    links folder. Since a malicious website or IE plug-in could potentially
    create a link in this folder that performs an unwanted action, Windows takes
    greater care when opening files in this location.

    Normally I would suggest just using another folder to store your links in,
    but if you do that you no longer get the "menu" behavior that you are
    wanting. If there is a way to change the behavior of the quick links or
    custom toolbar to display folders as links, then that would be a much better
    solution; however, I was not able to find a way to do this.

    Instead, there is a way to change the security on the links folder so that
    these prompts are not displayed.

    ** Instructions

    NOTE: This procedure will change default security settings. See below for
    details.

    SIDE EFFECTS: After performing this procedure, you will have to go through
    extra confirmation steps when using internet explorer's favorites pane to
    delete items inside the links folder. This only affects IE (not Windows
    Explorer or the links toolbar on your taskbar).

    - Click start
    - Type: cmd
    - Right-click cmd.exe when it appears and click Run As Administrator
    - Type the following commands exactly as shown, pressing enter after each
    line:

    cd %userprofile%\favorites
    icacls links /setintegritylevel (CI)low

    ** Restoring default security settings

    If you wish to restore the default security settings, follow these steps:

    - Click start
    - Type: cmd
    - Right-click cmd.exe when it appears and click Run As Administrator
    - Type the following commands exactly as shown, pressing enter after each
    line:

    cd %userprofile%\favorites
    icacls links /setintegritylevel (OI)(CI)low

    ** More information

    When IE7 is running in protected mode (default), it can only write files to
    locations that have been marked as "low integrity". IE7 must ask for your
    consent to write to any other locations. This helps to prevent hackers and
    malware from taking over IE7 and using it to compromise your system.

    Your favorites folder (and the links folder within) and most files that are
    created, copied, or moved inside it are marked as "low integrity." This
    allows IE7 to create and delete files inside of your favorites folder
    without asking you for consent.

    Since files marked with "low integrity" are modifiable by potentially
    untrusted programs and webpages, Windows takes greater care when opening
    these types of files, especially in the case of a shortcut.

    The solution I gave will change the integrity level of items inside your
    links folder from low to medium. This will allow them to open without
    displaying the "Open File - Security Warning" prompt.

    I have vista and everytime I try to open a program or file it says open file - security warning do you want to run this file

  3. #3
    Join Date
    Nov 2009
    Posts
    1

    Re: How to remove "Open File - Security Warning" window?

    To all-

    I have the solution to this problem. Every time I tried to run certain programs in Vista, a window would pop up asking me to confirm if I wanted to run the program (Open File - Security Warning).

    The solution for me was thru Internet Explorer -

    -Open IE, goto Tools>Internet Options
    -Click 'Security' tab
    -Select 'Internet'
    -Click 'Custom Level...'
    -Scroll down to 'Miscellaneous'
    -Scroll to 'Launching applications and unsafe files'
    -Select 'Enable (not secure)'
    -Click Apply then OK etc

    After doing this the popups no longer occur. The only downside is that IE browser displays a security warning drop-down when you use it. But IE blows and I use FF all the time so it doesn't affect me.

Similar Threads

  1. Replies: 6
    Last Post: 31-08-2011, 12:33 AM
  2. Getting "file download security warning"
    By Charles1 in forum Technology & Internet
    Replies: 4
    Last Post: 01-03-2011, 08:22 AM
  3. <A HREF="#" onClick="window.open ('sitename.html') ...>
    By Amy Adams in forum Software Development
    Replies: 4
    Last Post: 11-05-2010, 12:45 PM
  4. Replies: 1
    Last Post: 06-11-2007, 02:18 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,716,884,068.17058 seconds with 17 queries