Results 1 to 4 of 4

Thread: Cities: Skylines stops working and crashes at every 1 hour time

  1. #1
    Join Date
    Jul 2013
    Posts
    49

    Cities: Skylines stops working and crashes at every 1 hour time

    I am having an AMD FX-8350 CPU along with GTX 970 video card. I recently got hands on this new game Cities: Skylines and installed it on my pc properly. I can even play this game but after every hour or so this game will crash with an error message that says "Cities.exe has stopped working". I dont know why this problem is happening with this game. There is also no overheating issues while playing, I have monitored the temp as well. So what other reason would be there that is causing the crash?

  2. #2
    Join Date
    Apr 2009
    Posts
    3,974

    Re: Cities: Skylines stops working and crashes at every 1 hour time

    Even I was facing this random crashing of this game. But later I finally found a fix for this problem. What you need to do is just right click on the game icon and go to Properties and then go to Browse local files. After that find the exe file that is used to launch the game. Simply right click on the exe file and then go to Properties and then choose Compatability tab and tick mark the box to different operating system and then try to play the game without any issues.

  3. #3
    Join Date
    Aug 2009
    Posts
    3,786

    Re: Cities: Skylines stops working and crashes at every 1 hour time

    I would suggest you to verify the game cache and see if that works:
    • Completely exit Steam
    • Right-click on the shortcut which you use to launch Steam
    • Select "Run as Administrator"
    • Launch Steam again and continue to the section of this article titled "Verify integrity of game cache"

    Source: https://support.steampowered.com/kb_...2037-QEUH-3335

  4. #4
    Join Date
    Apr 2008
    Posts
    2,465

    Re: Cities: Skylines stops working and crashes at every 1 hour time

    There was a used on Steam community who said that if your game is crashing every half an hour or so then you should try to reactivate the Windows Paging file function and it will solve the issue. Simply go to My Computer > Properties > Advance System Settings that is located in the left corner of the Window > Advance > Click on the settings for performance > Advance > Change Set initial size as 16 mb and maximum size as 4000 mb or more or less but not less than 1000 mb.

Similar Threads

  1. Time is automatically adjusted to one hour before in HTC HD2
    By mANICKAVASAN in forum Portable Devices
    Replies: 3
    Last Post: 13-12-2010, 06:56 PM
  2. Rapidshare Happy Hour for unlimited downloads without time limit
    By Seymour in forum Technology & Internet
    Replies: 3
    Last Post: 13-04-2009, 03:22 PM
  3. Replies: 4
    Last Post: 30-10-2008, 09:56 PM
  4. Replies: 3
    Last Post: 06-08-2008, 08:56 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,696,051,398.47489 seconds with 17 queries