Results 1 to 4 of 4

Thread: Shadowrun: Dragonfall Director's Cut crashes on desktop

  1. #1
    Join Date
    Jun 2013

    Shadowrun: Dragonfall Director's Cut crashes on desktop

    I have got myself this new game called Shadowrun: Dragonfall Director's Cut and whenever I am trying to start either the Director's Cut or the normal game then it will crash immediately to the desktop. I have already followed all the troubleshooting method but nothing is working out for me. I have all the latest drivers installed in my machine and all other games are running fine as well. So, does anyone know whether there is some bug in this game or what? Thanks

  2. #2
    Join Date
    Jun 2009

    Re: Shadowrun: Dragonfall Director's Cut crashes on desktop

    Can you try to exit the Steam client and then start it again and login and then load up the game and check if it works properly. If still it is not working then first backup your save files and then uninstall the game completely. After that ensure that the lingering directories that can be found on the wiki of this game, are deleted. Now restart your computer and then install the game again. It might be possible that some other things on your computer updated which was causing this problem because it is affecting your originally game working install as well.

  3. #3
    Join Date
    Apr 2008

    Re: Shadowrun: Dragonfall Director's Cut crashes on desktop

    Can you try to clear the UGC from Shadownrun Returns and see if that works. To do that exit Steam and then re-open it again. After that open the Steam workshop under Shadowrun Returns. Now click on "Subscribed Items" and then click on "Unsubscribe" on each item listed. Now try to find any previously downloaded UGC files, take refrence from here - http://shadowrun-returns.wikispaces....ocations+by+OS. Try to delete any UGC files found and then launch the game to see if it opens.

  4. #4
    Join Date
    Aug 2009

    Re: Shadowrun: Dragonfall Director's Cut crashes on desktop

    Have you tried to verfiy the game cache and checked if it worked. Try to follow the below method:
    1. Exit and re-open Steam
    2. Open Steam to the Game Library
    3. Right/Cmd click on Shadowrun Returns
    4. Click on “Properties”
    5. Select the “Local Files” tab
    6. Press the “Verify Integrity of Game Cache…” button
    7. Launch Shadowrun Returns

Similar Threads

  1. Need help to run shadowrun server
    By kolton in forum Video Games
    Replies: 5
    Last Post: 10-12-2010, 12:02 AM
  2. Shadowrun very cheap at the microsoft store
    By Mahican in forum Video Games
    Replies: 4
    Last Post: 08-12-2010, 10:16 AM
  3. No accurate Aiming in Shadowrun using mouse
    By Gerri in forum Video Games
    Replies: 3
    Last Post: 03-12-2010, 08:10 PM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,695,452,822.10377 seconds with 17 queries