Results 1 to 4 of 4

Thread: Castlevania: Lords of Shadow 2 graphical artifacts problem

  1. #1
    Join Date
    Jul 2013
    Posts
    56

    Castlevania: Lords of Shadow 2 graphical artifacts problem

    I am facing graphical issues on my computer while playing Castlevania: Lords of Shadow 2. I am running a 2 HD 6870 graphics card in crossfire and if I am choosing any graphics settings then I am getting visual artifacts and the screen will also flicker. I have also enabled Vsync and if I turn it off then I cannot play the game at all because of the visual artifacts I am not able to see anything. Can anyone tell me how do I solve this issue? Thanks

  2. #2
    Join Date
    May 2008
    Posts
    2,464

    Re: Castlevania: Lords of Shadow 2 graphical artifacts problem

    I have checked in the game folders that there is a directx setup file which you can try to run and update your system to it. If that is not working then the obvious reason might be some issues related to Crossfire, so try to disable them completely. I was facing the flickering problem in the game and when I did this then the game was running very smoothly on my pc. Try to do these things and see if it works for you.

  3. #3
    Join Date
    May 2009
    Posts
    1,952

    Re: Castlevania: Lords of Shadow 2 graphical artifacts problem

    You can also try to turn off or lower the settings for Motion blur and see if that works for you. Or else, as said above, this could be a crossfire problem, so try to set alternative rendering in the RadeonPro for your Crossfire setup and see if that helps, you can download this Radeon Profile Tool or RadeonPro from this link - [http://www.radeonpro.info. The actual problem is with the graphics card only and not with the game developers.

  4. #4
    Join Date
    Apr 2008
    Posts
    2,465

    Re: Castlevania: Lords of Shadow 2 graphical artifacts problem

    I will ask you to do a clean install of your graphics driver to the latest one and then test the game by playing it again. If still you are getting problem with the artifacts then you will have to request an RMA for your graphics card. It could be also motion blur issue which you need to turn off. I hope that your machine is also not overclocked because it could be memory problem too.

Similar Threads

  1. Soon Castlevania: Lords of Shadows is coming for Xbox and PS3
    By Rodriguez_bronx in forum Video Games
    Replies: 2
    Last Post: 08-06-2012, 03:15 PM
  2. Replies: 6
    Last Post: 13-03-2011, 05:07 PM
  3. Replies: 4
    Last Post: 28-01-2011, 07:15 AM
  4. ATI Radeon HD 4870 Artifacts problem
    By KAILEY in forum Monitor & Video Cards
    Replies: 6
    Last Post: 05-06-2010, 11:56 PM
  5. Graphical Error Problem with ATI HD 2400PRO
    By Sachit in forum Motherboard Processor & RAM
    Replies: 3
    Last Post: 29-01-2009, 11:24 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,669,994,696.95830 seconds with 17 queries