Results 1 to 7 of 7

Thread: Cannot change homepage in Firefox 12 to 'use current page'

  1. #1
    Join Date
    Apr 2012
    Posts
    33

    Cannot change homepage in Firefox 12 to 'use current page'

    Yesterday I have updated the Firefox browser and now the version shows as 12. It working quite well with all add-ons installed and so on and so far no issues at all. I hope there might be soon. Today I have got one problem and that is, I cannot changes the homepage to 'use current pages'. This is the only option highlighted and that even don’t work for me. If I set the current page to different one, it still the previous 'current page' remains as my homepage. There is no way I can 'make my homepage'. It is still on default now. What is wrong with this thing?

  2. #2
    Join Date
    Aug 2011
    Posts
    308

    Re: Cannot change homepage in Firefox 12 to 'use current page'

    I don’t see this kind of issue in Firefox. if so, you should try re-installing the Firefox. There won’t be a problem with re-installation because you won’t gonna lose your bookmarks and add-ons. The problem may be due to the Damaged preference file. The prefs.js file may be damaged, causing Firefox not going to write. You can reset the file by removing it. This will make all your self-installed and settings for many extensions. But if this does not work I can always reinstall Firefox yet.

  3. #3
    Join Date
    Jan 2011
    Posts
    270

    Re: Cannot change homepage in Firefox 12 to 'use current page'

    I think that for this issue you should reset the browser.startup.homepage_override.mstone preferences by right-clicking on the context menu and set to default on the about:config page. After this restart the Firefox which will restore the default blank about:home page. The step by step procedure is as follows:
    • Open the about:config page using the location bar
    • Type in the Filter bar: mstone
    • Right-click the browser.startup.homepage_override.mstone line and choose: Reset
    • Close and restart Firefox

  4. #4
    Join Date
    Aug 2011
    Posts
    580

    Re: Cannot change homepage in Firefox 12 to 'use current page'

    Home page the default browsers is not always what we would like to use. Fortunately, you an customize the Homepage under Firefox.
    • In the Toolbar, scroll down the menu "Tools" and select "Options."
    • Select the "General" tab.
    • You then have several choices. First, you can manually fill the field "Homepage". Otherwise, you can choose a link from your bookmarks. Finally, you can choose as your home page the web page you're visiting by clicking on "Current Page". Note that it is also possible to find any time to the default home page by clicking "Restore default configuration". To finalize this choice, click "OK".
    • However if you want to set the single site as your Home page, then open the site which you want to set. Now click and drag the icon to the left of the web address toward the Home button and release it. When the prompt appears, click Yes to set this as home page. In order to set a Blank page as your Home page, Open a new Tab and follow the same procedure. Make sure that any other third party programs, plug-ins or add-ons not changing your Firefox preferences automatically.

  5. #5
    Join Date
    Jan 2011
    Posts
    172

    Re: Cannot change homepage in Firefox 12 to 'use current page'

    It seems to me that your Firefox 12 is not able to save any kind of preferences or settings. AS far as I know that the preferences or settings are saved in inside the prefs.js file (or the prefs.js.moztmp file, if it exists). This file might have locked or corrupted. If it locked or write-protected, you have to unlock it. If it is corrupted, you have to replace the file with new file or a back up file. New file can get from the Mozilla site. To perform steps:
    • Open your profile folder: By going to into Help menu> Troubleshooting Information. This will open a new tab. There under Application Basics section, click on Open Containing Folder. It will open a window with profile files
    • There you have to find a prefs.js file ( or prefs.js.moztmp file if present).
    • Right click on it and choose Properties. Check that under Attributes, and uncheck the Read Only option for either file.
    • Delete whichever prefs-n.js files where n is a number (e.g. prefs-2.js).
    • Also delete Invalidprefs.js if it exists.
    • Restart the Firefox. That’s it. Now the firefox will be able to save your preferences.

  6. #6
    Join Date
    Feb 2010
    Posts
    766

    Re: Cannot change homepage in Firefox 12 to 'use current page'

    There are many ways to proceed. Here is the easiest: Go to the Web page you want to make your home page. Of course if you use the original theme of Firefox, the background color will be different, and the icons too. What is important is to properly identify the small icon that is located just left of the address bar, and I surrounded by a red one for the best mark. Of course the image of the icon is not fixed. It is the logo of the site you visit. Click with the left click mouse and hold your finger. This will allow you to drag the icon to the button a little left over which is a house (right button with the cross). Release the left mouse button. A dialog box then appears asking if you really want to make this page your homepage. Answer yes, and it's good.

  7. #7
    Join Date
    Jul 2011
    Posts
    640

    Re: Cannot change homepage in Firefox 12 to 'use current page'

    I would also take in about: config look. Since Firefox saves all settings. Just use about: config in the location bar of Firefox and enter the Enter key. If you do this for a first time, you get first a warning. Since you do not have much to attract and you can just click the button in that window. Then you see all the settings of Firefox. With the Filter bar at the top, you can search on a particular setting or value. Tap it once iMesh example in so you can see if there are certain institutions that refer to iMesh. If that yields something, you can right-click on this setting and choose Reset. This gives this setting, the default value and no longer refers to iMesh. Because I have the strong suspicion that iMesh is not just your home page has changed, but also search pages from your browser.

Similar Threads

  1. Replies: 4
    Last Post: 30-11-2011, 04:40 PM
  2. Replies: 6
    Last Post: 20-08-2010, 12:35 AM
  3. Is it possible to get the current URL in my JSP page
    By Sean J in forum Software Development
    Replies: 3
    Last Post: 19-05-2009, 09:27 PM
  4. How to change Opera Homepage
    By Claudius in forum Technology & Internet
    Replies: 4
    Last Post: 01-05-2009, 02:53 PM
  5. Cannot Change IE homepage
    By Preetish in forum Technology & Internet
    Replies: 4
    Last Post: 28-02-2009, 09:38 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,664,451,085.37158 seconds with 17 queries