Results 1 to 4 of 4

Thread: SqlException: Cannot insert duplicate key row in object 'dbo.tbDep

  1. #1
    Join Date
    Sep 2004
    Posts
    51

    SqlException: Cannot insert duplicate key row in object 'dbo.tbDep

    Today i have approved all Security Updates on my master server but since then some of my downstreams are coming up with below Synchronization error:

    SqlException: Cannot insert duplicate key row in object 'dbo.tbDeployment'
    with unique index 'nc_RevisionID_TargetGroupID_ActionID'.
    Failed to create implicit deployment
    Failed to create scan deployment for latest revision

    By now i have tried deleting downstream replica server and have set them back and have tried using wsusutil reset as well but these things are no making any difference in my case. Is there anything that i can try out further???

  2. #2
    Join Date
    Sep 2005
    Posts
    229
    In that case i will suggest you to uninstall WSUS and delete the database first and make clean installation of WSUS . Just make sure that you are backing up downloaded content.Once you reinstall WSUS it will create fresh database after checking out the downloaded content in the folder pointed during installation. You should also reset your policies after reinstalling WSUS and set detection Interval, so when your server gets rebuilt your clients will be ready for detecting rebuilt server. If things goes as suggested then you will be able to identify required updates after Interval that you might have set and delete filesystem which is not required running Server Cleanup Wizard. Hope that helps!!!

  3. #3
    Join Date
    Jul 2011
    Posts
    330

    Re: SqlException: Cannot insert duplicate key row in object 'dbo.tbDep

    There is a hotfix available for the same. That you can run to resolve the issue. You can find that on the official site of Microsoft. There is no direct reason available why this issue appear. What is the cause of this problem. Microsoft offer you a free hotfix through which the error can fixed. You can find the download on the below link. Just run the same and you will be able to get out of the error. Try to reset the update service if possible. This will also help you to get rid of the issue. But if this thing is constant then you might have to reconfigure everything from scratch.

    SqlException Error Hotfix

  4. #4
    Join Date
    Jul 2011
    Posts
    265

    Re: SqlException: Cannot insert duplicate key row in object 'dbo.tbDep

    This issue can be resolved by updating WSUS. I am giving you a link below where you can find more details about the download. This new version will resolve the issue offering you a stable solution for running Windows Update. A number of people are still using the old version due to which they are facing problem. But after updating the same to a new one the issue is fixed. You have to apply SP2 update on WSUS 3.0. Click on the link below to get more detail about the same. You can follow up instructions for performing the update.

    Windows Server Update Services 3.0 Service Pack 2 Update

Similar Threads

  1. Replies: 6
    Last Post: 14-05-2011, 11:06 PM
  2. How can you remove and insert an object in the array list ?
    By GOOL in forum Software Development
    Replies: 4
    Last Post: 03-01-2011, 11:29 PM
  3. Cannot insert object in excel 2007
    By Darpak in forum Windows Software
    Replies: 3
    Last Post: 04-08-2009, 07:06 PM
  4. How to perform Insert on duplicate key update in MySQL
    By Xena in forum Software Development
    Replies: 3
    Last Post: 18-05-2009, 09:49 PM
  5. Replies: 0
    Last Post: 08-01-2009, 08:27 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,674,864,104.56981 seconds with 17 queries