Results 1 to 5 of 5

Thread: Error 0x8007000e running Automatic Updates

  1. #1
    Join Date
    Jul 2006
    Posts
    273

    Error 0x8007000e running Automatic Updates

    I am using Windows Server 2003 and it is not reporting back to WSUS. The WSUS will show the missing updates for the server but it will still show that it hasnt reported in any amount of days. I have tried to search for this error but am unable to find any solution for it. I have included portions of the windowsupdate.log file below:

    AU ## START ## AU: Search for updates
    AU #########
    AU <<## SUBMITTED ## AU: Search for updates [CallId =
    {602E6B3A-41B4-47B5-8610-928484089C0C}]
    Agent *************
    Agent ** START ** Agent: Finding updates [CallerId = AutomaticUpdates]
    Agent *********
    Setup *********** Setup: Checking whether self-update is required
    ***********
    Setup * Inf file:
    C:\WINDOWS\SoftwareDistribution\SelfUpdate\Default\wusetup.inf
    Setup Update NOT required for C:\WINDOWS\system32\cdm.dll: target version =
    5.8.0.2469, required version = 5.8.0.2469
    Setup Update NOT required for C:\WINDOWS\system32\iuengine.dll: target
    version = 5.8.0.2469, required version = 5.8.0.2469
    Setup Update NOT required for C:\WINDOWS\system32\wuapi.dll: target version
    = 5.8.0.2469, required version = 5.8.0.2469
    Setup Update NOT required for C:\WINDOWS\system32\wuauclt.exe: target
    version = 5.8.0.2469, required version = 5.8.0.2469
    Setup Update NOT required for C:\WINDOWS\system32\wuauclt1.exe: target
    version = 5.8.0.2469, required version = 5.8.0.2469
    Setup Update NOT required for C:\WINDOWS\system32\wuaucpl.cpl: target
    version = 5.8.0.2469, required version = 5.8.0.2469
    Setup Update NOT required for C:\WINDOWS\system32\wuaueng.dll: target
    version = 5.8.0.2469, required version = 5.8.0.2469
    Setup Update NOT required for C:\WINDOWS\system32\wuaueng1.dll: target
    version = 5.8.0.2469, required version = 5.8.0.2469
    Setup Update NOT required for C:\WINDOWS\system32\wucltui.dll: target
    version = 5.8.0.2469, required version = 5.8.0.2469
    Setup Update NOT required for C:\WINDOWS\system32\wups.dll: target version =
    5.8.0.2469, required version = 5.8.0.2469
    Setup Update NOT required for C:\WINDOWS\system32\wups2.dll: target version
    = 5.8.0.2469, required version = 5.8.0.2469
    Setup Update NOT required for C:\WINDOWS\system32\wuweb.dll: target version
    = 5.8.0.2469, required version = 5.8.0.2469
    Setup * IsUpdateRequired = No
    Agent * WARNING: Exit code = 0x8007000E
    Agent *********
    Agent ** END ** Agent: Finding updates [CallerId = AutomaticUpdates]
    Agent *************
    Agent WARNING: WU client failed Searching for update with error 0x8007000e
    AU >>## RESUMED ## AU: Search for updates [CallId =
    {602E6B3A-41B4-47B5-8610-928484089C0C}]
    AU # WARNING: Search callback failed, result = 0x8007000E
    AU #########
    AU ## END ## AU: Search for updates [CallId =
    {602E6B3A-41B4-47B5-8610-928484089C0C}]
    AU #############
    AU AU setting next detection timeout to 2006-07-05 12:37:31
    Report REPORT EVENT: {9C856293-F476-4269-A118-04D8980529AE} 2006-07-05
    07:38:59-0400 1 148 101 {00000000-0000-0000-0000-000000000000} 0 8007000e AutomaticUpdates Failure Software
    Synchronization Error: Agent failed detecting with reason: 0x8007000e
    Report Uploading 1 events using cached cookie, reporting URL =
    http://someserver/ReportingWebServic...ebService.asmx
    Report Reporter successfully uploaded 1 events.
    Agent *************
    Agent ** START ** Agent: Finding updates [CallerId = MBSA]
    Agent *********
    Agent * WARNING: Exit code = 0x8007000E
    Agent *********
    Agent ** END ** Agent: Finding updates [CallerId = MBSA]
    Agent *************
    Agent WARNING: WU client failed Searching for update with error 0x8007000e
    Report REPORT EVENT: {9F5A08C1-19D4-4AEA-A9CC-E2927A1EB257} 2006-07-05
    07:50:40-0400 1 148 101 {00000000-0000-0000-0000-000000000000} 0 8007000e MBSA Failure Software
    Synchronization Error: Agent failed detecting with reason: 0x8007000e
    PT Initializing simple targeting cookie, clientId =
    6fad0b99-d320-4187-9127-31ea9e047233, target group = , DNS name =
    problemserver.ott.cginet
    PT Server URL = http://someserver/SimpleAuthWebService/SimpleAuth.asmx
    Report Uploading 1 events using cached cookie, reporting URL =
    http://someserver/ReportingWebServic...ebService.asmx
    Report Reporter successfully uploaded 1 events.
    ++++++++++++++++++++++++++

    If I logon to the server then I am not able to get the "Globe"/"Shield" that usually tells me that updates are available for download. Can anyone tell me a solution for this problem? Thanks

  2. #2
    Join Date
    Oct 2005
    Posts
    725

    RE: Error 0x8007000e running Automatic Updates

    I have asked microsoft about this issue and they suggested me somethings. It seems that the MSI has a known memory leak that brings up the process svchost memory utilization to a high value. So when AU starts the detection cycle, it calls MSI to do so. So, the solution is to bring down the detection to 24 hours course and then restart the server.

  3. #3
    Join Date
    Aug 2006
    Posts
    122

    Re: Error 0x8007000e running Automatic Updates

    Even we are having similar kind of problem on Windows server 2000. If the auto-updates tries to run then one of the svchost processes shoots way up in memory utilization and we then get the same error 0x8007000e. Does anyone have any other information on this error or is there any hotfix available for same.

  4. #4
    Join Date
    Apr 2007
    Posts
    2

    I Have a Fix

    I worked with Microsoft tech support to fix the error: Agent failed detecting reason: 0x80070000e

    Microsoft had me search microsoft.com for KB898708, download and install this hotfix on my WSUS server including a reboot. It didn't fix the problem, however. My WSUS server is Win2003 Standard SP1, and I have WSUS Build 2.0.0.2620.

    Microsoft then had me search microsoft.com for KB927891 and install this hotfix on my WSUS clients, including a reboot. This fixed the problem. My clients are WinXP SP2.

    So, you may be able to get by just installing the KB927891; I'd try that first.
    Last edited by Jeff S; 03-04-2007 at 09:32 PM. Reason: include some more specific info

  5. #5
    Join Date
    Apr 2007
    Posts
    2
    In fact, I did rebuild my Win2003 server and reinstall WSUS from scratch, including a new database, just two months ago when a bunch of my PCs first started showing this error. However, the problem came back.

    Microsoft's explaination to your considering that this hotfix is also not associated with the 0x8007000e error was that this hotfix fixes a bunch of different problems with WSUS clients, not just 0x8007000e.

Similar Threads

  1. error 1058 and automatic updates
    By dirtydboi in forum Windows Update
    Replies: 12
    Last Post: 25-11-2011, 04:02 PM
  2. Automatic Updates Service won't start - Error 2
    By shamrin in forum Windows Update
    Replies: 6
    Last Post: 28-06-2010, 06:01 AM
  3. Automatic Updates Generating Error and Closing
    By Ashy-B in forum Windows Update
    Replies: 17
    Last Post: 14-01-2009, 03:28 AM
  4. Vista Automatic Updates Error 0x80070424
    By Shane R. in forum Windows Update
    Replies: 2
    Last Post: 07-11-2008, 11:23 AM
  5. Automatic Updates - Error Message 1058
    By Moonves in forum Windows XP Support
    Replies: 1
    Last Post: 15-05-2008, 02:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,653,087,271.52741 seconds with 18 queries