Results 1 to 5 of 5

Thread: WSUS 3 SP1 Problem EventID 10032 and sometimes 364

  1. #1
    Join Date
    Sep 2004

    WSUS 3 SP1 Problem EventID 10032 and sometimes 364

    I am not able to download some update, i have gone through log and i see error "10032" every-time. I am not using any proxy for downloading the updates and i have checked out firewall settings and all. I have made clean installation of WSUS 3 SP, i have tried changing "Update Services" service to use the Local Service but no avail. I want to know if i can download these updates without any further issues.

  2. #2
    Join Date
    Oct 2008
    While looking after your issue i came across below article....
    Error message when you try to download a file by using the Background Intelligent Transfer Service: "Content file download failed"
    Just go through the resolution that has been mentioned there and let me know if your are able to fix your issue.

  3. #3
    Join Date
    Oct 2011

    Re: WSUS 3 SP1 Problem EventID 10032 and sometimes 364

    After spending about a week searching and searching and searching for a solution to this problem, I finally found it. Most sites and forums all said the same thing: set BITS to automatic, start/restart BITS & WSUS services, synchronize, checkhealth, etc. Other sites said to make sure that NT Authority\Network Service had permissions on the root. None of that worked. Thanks to Google's translation of a German tech. forum and a blog describing something similar, I found the resolution:

    It turns out that there was a Windows Defender definition file was stuck while trying to download. To get rid of it, perform the following on the server hosting WSUS:

    1. Open WSUS
    2. Select the server (don't expand, just click on it).
    3. In the middle pane, on the right side, you'll see where it says "Synchronization Status." Just under that, you'll see "Download Status." If it says that you have any "Updates needing files" with 0.00 MB of x.xx MB downloaded, then this is your problem. [Attached is a screenshot showing what I'm talking about.]
    4. Go to the Synchornizations page.
    5. Open up a sync that has the same number as the one from step 3 (this may take a few times to find).
    6. Click the update to bring up the details of the update.
    7. In the new window, select Tasks, then decline.
    8. Try to synchronize again, then go to command prompt. Browse to the WSUS install directory, then cd Tools.
    9. Execute the following command: wsusutil checkhealth
    10. Check event viewer.

    Keep in mind that this worked for a Windows Defender definition file. I cannot say for certain that it will work for other files that are stuck, but it appears that Defender def. files have a tendency to do this; my theory is that they are released so frequently.

    I hope this helps out anyone out there that runs into this problem in the future. The error was driving me nuts, because it looked like everything was working fine, but the error claimed otherwise. Furthermore, there was only 1 of dozens of sites that actually dealt with the problem I was having. Since I figured it out, I thought I'd share. Best of luck.
    Attached Thumbnails Attached Thumbnails wsus_error_correction-jpg  
    Last edited by LeGoat; 25-10-2011 at 10:06 PM.

  4. #4
    Join Date
    Oct 2011

    Re: WSUS 3 SP1 Problem EventID 10032 and sometimes 364

    A BIG correction to what I posted above. It turns out that it's not the Defender definition file. The picture I attached was the same view I kept having after performing the above steps. Also, there is a MUCH quicker way to figure out which file is causing the problem:

    To figure out which file did not download correctly, and thus is causing this error, you have to go to the All Updates section of the WSUS, select "Approved" in the Approval drop-down box and "Any" in the Status drop-down box. Here's the piece of information people tend to leave out, but suggest you do: add a column. Which column? Right-click on the column headers and check "File Status." Sort by File Status and looks for the beautiful red X. That is the culprit. Once that file is declined, check the main WSUS page (image in the previous post), run another sync and then another healthcheck. The problem should be gone.

    The reason you have to make sure that the Approval drop-down box is set to "Approved" is because the error occurs when you have an approved update that has not downloaded properlly. Declined updates (assuming that you have run the cleanup wizard in the Options section) will not have downloaded updates, so there is not point in seeing those updates, too. There is a chance that you may need to run the cleanup wizard a few times to get rid of this problem. This is kind of like a shampoo run: rinse and repeat until the problem is fixed. Hope this helps someone out there.
    Last edited by LeGoat; 26-10-2011 at 12:11 AM.

  5. #5
    Join Date
    Aug 2011

    Re: WSUS 3 SP1 Problem EventID 10032 and sometimes 364

    Thanks for such helpful suggestion. This puts more light on the issue. Usually it is really hoard to figure out why the error appears. I had gone through a number of threads on internet and all of them have maximum discussion. There are no proper troubleshooting help yet given. I hope this can surely help out to someone which is facing this kind of problem.

Similar Threads

  1. How do I fix a Vista WMI EventID 10 problem?
    By Stan in forum Vista Help
    Replies: 8
    Last Post: 18-08-2009, 08:35 PM
  2. Problem: EventID 4321
    By azianai in forum Operating Systems
    Replies: 4
    Last Post: 19-02-2009, 10:56 AM
  3. WSUS Error, EventID: 7053
    By aghuvi in forum Server Update Service
    Replies: 1
    Last Post: 29-01-2008, 02:24 AM
  4. WSUS Synchronization Issues (Event 10032 & 10022)
    By Lynette in forum Server Update Service
    Replies: 2
    Last Post: 16-11-2007, 04:15 AM
  5. WSUS not downloading update event id's 364 & 10032
    By Mr Frances in forum Server Update Service
    Replies: 2
    Last Post: 09-10-2007, 06:05 PM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,680,336,981.50975 seconds with 18 queries