Results 1 to 3 of 3

Thread: Used Mac OS X system working very slow

  1. #1
    Join Date
    Jun 2013
    Posts
    117

    Used Mac OS X system working very slow

    I just purchased a used Mac OS X system. It has OS X 10.7.5. I am not able to figure out why this thing is so slow. It takes a long time to open up a page or simply work on the same. It is also very hard to open a web browser. I am quiet sure there will be some option to fix it. I had tried a lot to remove few old things but it does not work well. The same was working well in the shop. The seller has already told me that it is not in warranty and I must buy this on my own risk. Now I cannot even take it back.

  2. #2
    Join Date
    Nov 2009
    Posts
    792

    Re: Used Mac OS X system working very slow

    There can be some applications that are causing the issue. Just turn it on back again and then simply go in System Preferences > Users & Group. Click on the user from the left side and then click on Login items. You will see the apps which are configured to work on startup. You have to remove the tick from all those apps which you do not need. Just disable everything and then try back. This will definitely speed up the mac system. Or else you can go ahead with full mac restore after restarting the same.

  3. #3
    Join Date
    May 2011
    Posts
    434

    Re: Used Mac OS X system working very slow

    Clearing your memory will also work in fixing the system output. You can use Memory Diagnostics for the same. It is a tiny app that will help you to empty all the application cache form the system. It is fast and easy to use. There are many apps like this which are kind of system cleaner. Just download and install the same and then run it. I am quiet sure it will start working and will give you a proper output. But if nothing works then re-installing mac back again will be a lot more better options.

Similar Threads

  1. Replies: 4
    Last Post: 19-07-2013, 04:24 PM
  2. System working very slow after installing Threatfire antivirus
    By Haimi-32 in forum Networking & Security
    Replies: 2
    Last Post: 22-06-2012, 10:18 AM
  3. why my system is working slow
    By Narragansett in forum Hardware Peripherals
    Replies: 5
    Last Post: 04-09-2010, 12:42 PM
  4. AMD System working slow
    By nishanemo in forum Motherboard Processor & RAM
    Replies: 1
    Last Post: 09-03-2010, 12:38 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,669,620,708.54162 seconds with 17 queries