Results 1 to 4 of 4

Thread: playing Risk II game on Windows 7?

  1. #1
    Join Date
    Jun 2014
    Posts
    19

    playing Risk II game on Windows 7?

    I am on a Windows 7 64bit edition computer with Intel onboard graphics. I am trying to run Risk II game on my computer with so many methods but none is working. When I am trying to launch the game then it loads fine but after getting to the main screen and when I click on single player the screen doesnt move at all. I have all the latest graphics driver installed on my pc. Can anyone please help me out to solve this issue? Thanks

  2. #2
    Join Date
    Apr 2008
    Posts
    3,267

    Re: playing Risk II game on Windows 7?

    You can try to make older games run in the latest version of Windows. To do that open the Program Compatibility troubleshooter by clicking the Start button Picture of the Start button, and then clicking Control Panel. In the search box, type troubleshooter, and then click Troubleshooting. Under Programs, click Run programs made for previous versions of Windows. Follow the instructions in the troubleshooter. For more information, you can visit this website here - http://windows.microsoft.com/en-us/w...#1TC=windows-7

  3. #3
    Join Date
    Apr 2008
    Posts
    3,295

    Re: playing Risk II game on Windows 7?

    If the above method is not working for you then try to install Windows XP in your pc Virtually. This way you will be able to install the game in Windows XP mode. To do that, you need to first of all download and install Windows XP mode from this link - http://windows.microsoft.com/en-us/w...e-in-windows-7. After that click Start and then click All Programs and then click Windows XP mode. Now try to open the game setup file and install it in your pc. Just try to test by launching the game whether it is running or not.

  4. #4
    Join Date
    Nov 2009
    Posts
    792

    Re: playing Risk II game on Windows 7?

    If still the above solutions doesnt work then try to use the Windows XP Compatibility mode and see if that works. To do that right click on the .exe file of the game and go to Properties. After that click on the Compatibility mode and then choose the option to Run this Program in Compatibility mode and tick mark Windows XP Sp3. Another option would be to simply add the extension of "-noavi" without the quotes at the games shortcut, like this for example: "C:\Program Files (x86)\Risk II\RiskII.exe" -noavi

Similar Threads

  1. Replies: 5
    Last Post: 22-12-2011, 07:10 PM
  2. No sound while playing Risk Factions
    By Ansuna in forum Video Games
    Replies: 8
    Last Post: 20-12-2011, 11:20 AM
  3. Replies: 6
    Last Post: 19-12-2011, 07:17 PM
  4. Playing Risk faction game is really amazing
    By @nki$achi in forum Video Games
    Replies: 5
    Last Post: 19-12-2011, 07:13 PM
  5. Risk: Factions game is just not worth playing
    By ShaggyBoy in forum Video Games
    Replies: 4
    Last Post: 19-12-2011, 07:12 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,708,699,053.25506 seconds with 17 queries