Results 1 to 4 of 4

Thread: thread_stuck_in_device_driver error in Windows 8.1

  1. #1
    Join Date
    Jul 2013
    Posts
    106

    thread_stuck_in_device_driver error in Windows 8.1

    I have been using Windows 8 on my computer without any problems. But after installing the latest Windows 8.1 update, whenever I am trying to turn on my pc then a screen comes up with an error message stating as "thread_stuck_in_device_driver". I have tried to search for some solutions for this problem but cannot find anything. So if anyone knows how to solve this problem then please let me know about it. Thanks

  2. #2
    Join Date
    Apr 2008
    Posts
    3,267

    Re: thread_stuck_in_device_driver error in Windows 8.1

    It seems that you are getting this error because a device driver installed in your pc is causing the OS to stop unexpectedly. I suspect that you have a defective graphics card driver. So to solve this issue, press Windows + X key from desktop and then select Device Manager. After that do you see any yellow exclamation mark next to Display Adapters? If yes, then right click on the device and then click on Properties to check the device status for any error.

  3. #3
    Join Date
    Apr 2008
    Posts
    3,522

    Re: thread_stuck_in_device_driver error in Windows 8.1

    I was facing the same problem and found out that it was happening due to the graphics drivers. When I upgraded to Windows 8.1 in my computer then it didnt use to sleep anymore. Also updating the graphics drivers or even uninstalling it using the graphics software used to give blue screen error with this same error called thread_stuck_in_device_driver. Afterwards I uninstalled all the graphics drivers from my pc and reinstalled the latest one by downloading it from the manufacturer's website. Now the problem seems to be solved for me.

  4. #4
    Join Date
    May 2008
    Posts
    2,681

    Re: thread_stuck_in_device_driver error in Windows 8.1

    For many people the yellow exclamation mark is showing for the USB-IF xHCI USB Host Controller Intel WiUSB device. So, if you a yellow exclamation mark displays in Device Manager for the device labeled USB-IF xHCI USB Host Controller Intel WiUSB then it means that this issue impacts systems running Intel Wireless Display, or Intel WiDi. To solve this issue install WiDi software version 3.5 or higher. See the Intel WiDi Update Tool to download the latest version from here - http://supportkb.intel.com/wireless/.../article/16168

Similar Threads

  1. Replies: 3
    Last Post: 04-05-2012, 12:24 PM
  2. Replies: 6
    Last Post: 16-03-2012, 03:51 PM
  3. Replies: 4
    Last Post: 04-04-2010, 12:37 PM
  4. Error message: Stop 0x000000ea thread_stuck_in_device_driver
    By MobilePhoneGuru in forum Operating Systems
    Replies: 3
    Last Post: 03-12-2009, 03:55 PM
  5. Replies: 1
    Last Post: 07-11-2009, 11:15 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,675,595,302.61592 seconds with 17 queries