Results 1 to 4 of 4

Thread: LogiLDA.dll module missing after updating to Windows 8.1

  1. #1
    Join Date
    Jun 2013
    Posts
    122

    LogiLDA.dll module missing after updating to Windows 8.1

    I was running Windows 8 on my computer and yesterday when I updated it to Windows 8.1 then I started getting error message that was saying "There was a problem starting C:\Windows\System32\LogiLDA.dll. The specified module could not be found". Whenever I am trying to sign into my account i am getting this error? I have checked for some solutions on the internet but cannot find anything related to it? Does anyone out there help me out? Thanks

  2. #2
    Join Date
    Apr 2008
    Posts
    3,522

    Re: LogiLDA.dll module missing after updating to Windows 8.1

    I was too facing this issue after upgrading to Windows 8.1. But I have now solved this issue. Just try to open Task Manager and and under Startup tab search for LogiLDA, right click on it and select disable. After that open Registry editor and then go to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run and search for entry called Logitech Download Assistant, right click on it and choose to remove it.

  3. #3
    Join Date
    Nov 2009
    Posts
    792

    Re: LogiLDA.dll module missing after updating to Windows 8.1

    If the above solution doesnt work for you then try my method to solve this problem. First of all insert Unified Logitech Dongle into an open usb port on the computer that is getting the LogiLDA.dll error. When the computer detects the ULD and loads its proper software then verify that the mouse works through the ULD. If yes, then restart your computer and then try to login, you will not get the error message any more.

  4. #4
    Join Date
    Jun 2013
    Posts
    122

    Re: LogiLDA.dll module missing after updating to Windows 8.1

    Thanks alot for the suggestions that you have given, it worked for me atlast. I did exactly the same thing by going into Task Manager and then disabling the LogiLDA. After that I restarted my pc and now there is no error message on login. Because I was not getting any error messages now, so I didnt follow the Registry editor method. Thanks again.

Similar Threads

  1. Replies: 7
    Last Post: 11-01-2014, 06:52 PM
  2. Audio hardware missing after updating to Windows 8
    By Harbira in forum Operating Systems
    Replies: 7
    Last Post: 17-09-2013, 03:12 PM
  3. Bluetooth 365 module driver missing in Dell XPS 8300
    By Mykola in forum Hardware Peripherals
    Replies: 4
    Last Post: 03-06-2011, 10:37 AM
  4. Wi-Fi application missing after updating Nokia X6
    By Sanurag in forum Portable Devices
    Replies: 5
    Last Post: 18-05-2011, 08:00 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,642,885,830.63430 seconds with 17 queries