Results 1 to 7 of 7

Thread: Ubuntu 'net usershare' returned error 255

  1. #1
    Join Date
    Jul 2009
    Posts
    58

    Ubuntu 'net usershare' returned error 255

    When i try to share a folder i get this error by Ubuntu 'net usershare' returned error 255: net usershare add: cannot share path /media/disk/disk as we are restricted to only sharing directories we own.
    Ask the administrator to add the line "usershare owner only = False"
    to the [global] section of the smb.conf to allow this. What is this error, I cannot share any folder on my Ubuntu, but everything works fine from Windows XP. Please help...

  2. #2
    Join Date
    Jan 2009
    Posts
    289

    Re: Ubuntu 'net usershare' returned error 255

    Smb.conf is located in /etc/samba You need to configure this file so the you can share non-owned partitions, folders This is because ubuntu can only share the directories that are owned by ubuntu. You need to modify the samba configuration file to let Ubuntu share non-owned folders. I hope this helps...

  3. #3
    Join Date
    May 2008
    Posts
    4,085

    Re: Ubuntu 'net usershare' returned error 255

    Open the smb.conf file with admin rights [open as root], Then add this line to the file :
    Code:
    usershare owner only = False
    Now save the changes and close the file. Now reboot the system and see if can share the folder. This is how i configured my shares on a non-owned hard disk partition onto a windows network or you can say samba network... Hope this is helpful...

  4. #4
    Join Date
    Jul 2009
    Posts
    58

    Re: Ubuntu 'net usershare' returned error 255

    Hello friends, thanks for helping me. Solomon, i did as you said, I add the line "usershare owner only = False" in my smb.conf file, but still i get this error message. One thing i noticed that the file doesn't allow me to save changes to it. It tells me i do not have enough permission or similar thing. How do i save the file? Please help...

  5. #5
    Join Date
    Jan 2009
    Posts
    1,738

    Re: Ubuntu 'net usershare' returned error 255

    Ok, this is what you have to do :
    • Open terminal
    • type : "sudo gedit /etc/samba/smb.conf" without quotes
    • then in the file add "usershare owner only = False"
    • save the file [it will be saved now]
    • close the file
    • Try to share now

    Does it work now? All the best!

  6. #6
    Join Date
    Jul 2009
    Posts
    58

    Re: Ubuntu 'net usershare' returned error 255

    Quote Originally Posted by Rudra.J View Post
    Ok, this is what you have to do :
    • Open terminal
    • type : "sudo gedit /etc/samba/smb.conf" without quotes
    • then in the file add "usershare owner only = False"
    • save the file [it will be saved now]
    • close the file
    • Try to share now

    Does it work now? All the best!
    Thanks for the help, I could save the file after editing, but still now luck in sharing i still get the same error. Any help? Please help, I two computers on which i have clean installed Windows and i want to restore the data which i have backed up from each computer's hard disk... Please help...

  7. #7
    Join Date
    Jan 2009
    Posts
    1,738

    Re: Ubuntu 'net usershare' returned error 255

    Quote Originally Posted by Unix'EM View Post
    Thanks for the help, I could save the file after editing, but still now luck in sharing i still get the same error. Any help? Please help, I two computers on which i have clean installed Windows and i want to restore the data which i have backed up from each computer's hard disk... Please help...
    Again open the file smb.conf and remove the files which you added. Now goto the start of the file and slowly scroll down and look for a section called "Global". Now under this section add this lines : "usershare owner only = False". Now save the file again and no need to reboot the computer. Try again, the shares will be created now...

Similar Threads

  1. Replies: 4
    Last Post: 27-11-2011, 10:11 PM
  2. WDM call returned error: 4200
    By Madison in forum Operating Systems
    Replies: 4
    Last Post: 29-01-2010, 11:53 PM
  3. Error returned while creating the volume shadow copy
    By BlackSunReyes in forum Small Business Server
    Replies: 2
    Last Post: 11-11-2009, 03:00 PM
  4. Replies: 3
    Last Post: 24-06-2009, 12:56 PM
  5. The remote server returned an error: (400) Bad Request
    By Drewski in forum Software Development
    Replies: 3
    Last Post: 15-05-2009, 09:38 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,713,845,516.78296 seconds with 17 queries