Results 1 to 4 of 4

Thread: [warn] (2)No such file or directory: Failed to enable the 'httpready' Accept Filter

  1. #1
    Join Date
    Apr 2008
    Posts
    240

    [warn] (2)No such file or directory: Failed to enable the 'httpready' Accept Filter

    Whenever I start the Apache server, I get this error message,
    [warn] (2)No such file or directory: Failed to enable the 'httpready' Accept Filter

    What is the problem with Apache server and what does this error means? I am using Apache 2.1.4 and FreeBSD 5.4 RC2.

  2. #2
    Join Date
    Jan 2008
    Posts
    3,388

    Re: [warn] (2)No such file or directory: Failed to enable the 'httpready' Accept Filter

    You need to load "accf_http.ko" by kldload.
    (kldload can load dynamically kernel module without rebuilding kernel.)

    # sudo kldload accf_http.ko

    And enable it in loader.conf

    # vi /boot/loader.conf

    accf_http_load="YES"

  3. #3
    Join Date
    May 2008
    Posts
    2,680

    Re: [warn] (2)No such file or directory: Failed to enable the 'httpready' Accept Filter

    FreeBSD has special driver called accf_http. It will buffer incoming connections until a certain complete HTTP requests arrive to speed up and optimize performance.

    The utility of accf_http is such that a server will not have to context switch several times before performing the initial parsing of the request. This effectively reduces the amount of required CPU utilization to handle incoming requests by keeping active processes in preforking servers such as Apache low and reducing the size of the file descriptor set that needs to be managed by interfaces such as select(), poll() or kevent() based servers.

    Just open shell prompt and type the following command to load accf_http under FreeBSD :
    # kldload accf_http

    Restart apache:
    # /usr/local/etc/rc.d/apache22 restart

    Update /boot/loader.conf file
    Type the following command so that driver get loaded at the time of booting system:
    # echo 'accf_http_load="YES"' >> /boot/loader.conf


    Courtesy: Cyberciti.Biz

  4. #4
    Join Date
    Nov 2005
    Posts
    3,026

    Re: [warn] (2)No such file or directory: Failed to enable the 'httpready' Accept Filter

    If you get the following error in your apache logs:
    [warn] (2)No such file or directory: Failed to enable the 'httpready' Accept Filter

    Then add:
    accf_http_load="YES"
    to your /boot/loader.conf

    and run:
    kldload accf_http

Similar Threads

  1. How to Enable or Disable Windows 8 SmartScreen Filter
    By RedZot in forum Guides & Tutorials
    Replies: 2
    Last Post: 11-01-2014, 09:56 AM
  2. Replies: 5
    Last Post: 05-11-2010, 12:04 AM
  3. "Failed to open stream No such file or directory" error in PHP
    By EULALIA in forum Software Development
    Replies: 3
    Last Post: 13-07-2009, 02:40 PM
  4. Enable share folder in Active directory
    By BrunoK in forum Active Directory
    Replies: 4
    Last Post: 02-10-2008, 05:40 PM
  5. Replies: 1
    Last Post: 18-02-2006, 12:26 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,713,599,270.47523 seconds with 17 queries