Results 1 to 5 of 5

Thread: Gigabyte Z87X-HD3 usb 3.0 problem

  1. #1
    Join Date
    Dec 2013
    Posts
    12

    Gigabyte Z87X-HD3 usb 3.0 problem

    I am recently picked up this motherboard and when I am trying to install the intel usb 3.0 drivers then everytime all the usb port stops working including the usb 2 ports and front ports. I can easily solve this by connecting a PS/2 keyboard and uninstall the intel software and driver. But still the issue remains because the USB 3 ports run at USB 2 speeds when I am using USB 3 devices in them. Occasionally I also get unknown device in device manager? Can anyone please help me out? Thanks

  2. #2
    Join Date
    Oct 2005
    Posts
    1,217

    Re: Gigabyte Z87X-HD3 usb 3.0 problem

    Can you tell us from where you are getting the drivers and installing it on your machine? You should actually get all your motherboard drivers from Gigabyte's manufacturer website. So, you need to go to this link - http://www.gigabyte.us/products/prod...Z87X-HD31.1#dl. They have listed all the latest drivers available for your motherboard. Note that if you dont have any RAID configuration then dont install any of those drivers.

  3. #3
    Join Date
    May 2008
    Posts
    816

    Re: Gigabyte Z87X-HD3 usb 3.0 problem

    Did you try to check in Device Manager to see if there is any yellow exclamation mark on the USB devices? You should try to uninstall whatever driver is installed for the usb device and then immdiately install the proper ones from Gigabyte website. Just download and save a copy of it on your hard drive somewhere. If still this doesnt work then try to delete all the devices together and then install the correct one.

  4. #4
    Join Date
    Sep 2005
    Posts
    1,434

    Re: Gigabyte Z87X-HD3 usb 3.0 problem

    Well, for using USB 3.0 you will need to install drivers for same in your system and then only usb 3.0 devices would work on it. As you are describing, even after installing the correct usb 3.0 drivers it is failing then surely there seems to be some issues with the motherboard itself. So what you can do is try to RMA the board for a new one or else get it repaired. It will be having atleast 3 years of warranty period left on it. After 15-20 days you will get a working board.

  5. #5
    Join Date
    Jan 2013
    Posts
    56

    Re: Gigabyte Z87X-HD3 usb 3.0 problem

    Dear Irfan Khan,

    Please try re-installing OS & Download the latest drivers from our website:
    http://www.gigabyte.in/products/prod...px?pid=4764#dl

    Which SMPS(Power Supply) are you using ?

Similar Threads

  1. Difficulty in accessing bios of Gigabyte GA-Z87X-D3H motherboard
    By jacob2013 in forum Motherboard Processor & RAM
    Replies: 3
    Last Post: 03-02-2014, 09:25 AM
  2. PCIe slot issue with Gigabyte Z87x UD3H
    By Reecher in forum Official GIGABYTE Motherboard Forum
    Replies: 3
    Last Post: 21-01-2014, 10:46 AM
  3. Gigabyte GA-Z87X-UD3H BSOD
    By Fozia in forum Official GIGABYTE Motherboard Forum
    Replies: 3
    Last Post: 29-11-2013, 11:46 AM
  4. Gigabyte 890FXA-UD5 RMA Problem
    By rahulsuraj in forum Official GIGABYTE Motherboard Forum
    Replies: 5
    Last Post: 01-02-2013, 05:17 PM
  5. Problem with Gigabyte P55m-ud2 I5-750
    By Hamlet in forum Motherboard Processor & RAM
    Replies: 11
    Last Post: 18-03-2010, 09:01 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,670,139,021.60704 seconds with 17 queries