Results 1 to 4 of 4

Thread: Asus P8Z77-V-Pro Usb 3.0 problem

  1. #1
    Join Date
    Jun 2014

    Asus P8Z77-V-Pro Usb 3.0 problem

    I have recently purchased a new Asus P8Z77-V-Pro motherboard and have set it up by installing the OS and all the required drivers. But just then I noticed that the Intel Usb 3.0 ports are not working on my pc? I have installed the driver from the CD and it worked but as soon as I installed the Asmedia drivers then they stopped working? I have reinstalled the Intel drivers but still it is not working? So, if anyone knows how to solve this issue then please let me know about it. Thanks

  2. #2
    Join Date
    May 2009

    Re: Asus P8Z77-V-Pro Usb 3.0 problem

    Incase you have not installed your motherboards driver for the 20 pin header then Windows will not be able to know if USB 3.0 exists. Can you try to check for any yellow exclamation mark flags in Device Manager? It might be also possible that the 20 pin connector is not wired properly or is in some way defective. Can you try to access a friends board with 20pin header and then try it on your motherboard and see if that works correctly or not?

  3. #3
    Join Date
    Nov 2005

    Re: Asus P8Z77-V-Pro Usb 3.0 problem

    Can you try to get a USB drive and connect it into your computer. After that download a tool called EZ-Flash on your computer. Now you need to download the latest bios available for your motherboard and then unzip its file to the root of the USB drive. Now, restart your computer and then enter BIOS. After that go to EZ-Flash tools and if it is working fine then you will be able to see the contents of your USB drive listed. Just choose the .ROM file and then follow the instructions given on your screen.

  4. #4
    Join Date
    May 2008

    Re: Asus P8Z77-V-Pro Usb 3.0 problem

    First of all go to Device Manager and then uninstall USB 3.0 driver. After that insert Asus driver and then reinstall the driver and restart your pc. Now, the device might still not work. So, turn off your pc and disconnect everything. Open your chassis and disconnect the card reader from the motherboard. Now check if there are bent pins on the card reader and try to bend it back carefully and then connect it again in the mobo. Now check if the Usb 3.0 is working for you or not.

Similar Threads

  1. error with CPU fan on Asus P8Z77-V PRO
    By salmanyosef in forum Motherboard Processor & RAM
    Replies: 3
    Last Post: 05-04-2014, 12:55 PM
  2. asus p8z77-v pro powers on automatically
    By jacob2013 in forum Motherboard Processor & RAM
    Replies: 3
    Last Post: 05-10-2013, 11:31 AM
  3. ASUS P8Z77 WS vs. GIGABYTE GA-X79-UD3
    By Dolan Duck in forum Motherboard Processor & RAM
    Replies: 5
    Last Post: 18-09-2012, 11:26 AM
  4. ASUS P8Z77-V PRO with ivy is good?
    By baggio in forum Motherboard Processor & RAM
    Replies: 6
    Last Post: 08-09-2012, 11:49 AM
  5. Which is better motherboard ASUS P8Z77-V PRO vs ASUS Sabertooth Z77
    By Farren in forum Motherboard Processor & RAM
    Replies: 8
    Last Post: 11-04-2012, 11:02 PM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,675,725,829.23973 seconds with 17 queries