Results 1 to 5 of 5

Thread: System fail to boot after adding new DDR2 ram

  1. #1
    Join Date
    Jun 2013
    Posts
    98

    System fail to boot after adding new DDR2 ram

    I ordered a used ram from ebay for my system. I have a Core 2 Duo system with Gigabyte board on the same. The ram which I was using before is damage and not working. So I got a used one from web. After adding that when I start my pc there is no display on the screen. At start I got the bios screens but again it failed and not working. I am sure the ram is proper, but there is some other issue. What to do here.

  2. #2
    Join Date
    Aug 2009
    Posts
    922

    Re: System fail to boot after adding new DDR2 ram

    Check the power connection. Try to disconnect and connect it back. A number of time psu is unable to receive the power due to which the system fails to boot. The best thing I will recommend you is to disconnect every cable in the system and clean it. Then connect back and try.

  3. #3
    Join Date
    Jul 2011
    Posts
    245

    Re: System fail to boot after adding new DDR2 ram

    There can be some other problem which you have to check. You said you have a old system, so there are chances that something else in it is not working. First of all when you don't get the bios screen then it means there is some major issue with the motherboard. You will have to fix the same. Many old system boot without ram. You can atleast see the bios. You can try testing that. If the system boot without ram then you bought a faulty stick. But if the system still does not boot then I am expecting a hardware failure in this. The thing you can do here is check the power connectivity. Test out the cable and other stuff. See whether the cpu is placed properly or not. Try to remove the same, clean the surface and add it back. This will be enough to resolve the problem.

  4. #4
    Join Date
    Nov 2013
    Location
    Colorado
    Posts
    3

    Re: System fail to boot after adding new DDR2 ram

    How many sticks of RAM did you buy? If more than one, try one stick at a time and alternate the sticks to see if one of them could possibly be bad. How did the RAM you had before get damaged? Is it possible that other things, such as the motherboard was damaged also?

  5. #5
    Join Date
    Jun 2011
    Posts
    608

    Re: System fail to boot after adding new DDR2 ram

    You are right about that. The board can be damaged. It is necessary that your board must get proper power and if everything is proper you will get the bios screen. Try to check the psu once. I think that is not working.

Similar Threads

  1. System fail to boot after updating the bios of Gigabyte GA-B75M-D3H motherboard
    By Julian.Davide in forum Motherboard Processor & RAM
    Replies: 3
    Last Post: 18-11-2013, 11:10 AM
  2. No boot after adding up 2x 4GB ram on my system
    By Palomi in forum Motherboard Processor & RAM
    Replies: 6
    Last Post: 19-09-2011, 11:42 AM
  3. Boot Fail Warning System
    By garfield1 in forum Operating Systems
    Replies: 1
    Last Post: 12-12-2008, 08:07 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,653,312,434.54746 seconds with 17 queries