Results 1 to 4 of 4

Thread: Games lagging at maximum resolution on Nvidia 650Ti

  1. #1
    Join Date
    Jun 2013
    Posts
    117

    Games lagging at maximum resolution on Nvidia 650Ti

    Nvidia 650Ti is a good graphic card here. But I am having a bit issue with playing Castlevania on this. The game is freezing when I am trying to play on maximum resolution. I had tried many ways to fix it but still the game lags in between. But when I play the game at lowest resolution there is not issue. It works well. Does the gpu is not capable of giving out good gameplay on maximum resolution. I want some help for the same.

  2. #2
    Join Date
    Jul 2011
    Posts
    247

    Re: Games lagging at maximum resolution on Nvidia 650Ti

    There can be some other problem. Your gpu is heating up due to which the game is lagging. The best thing you can do here is install a gpu temp monitor in your pc. And launch the game. If the gpu temperature is above normal then it is a hardware problem. Carry the graphic card to your nearest service center. There are chances that the gpu fan is damaged and is not able to draw out maximum heat. There is no fix available on the software level.

  3. #3
    Join Date
    May 2009
    Posts
    970

    Re: Games lagging at maximum resolution on Nvidia 650Ti

    If temperature is not a problem then just try to update the drivers. You can remove the existing one from Control Panel > Uninstall programs. Just go in that and get rid of Nvidia drivers from it. Then download the fresh copy from its official website and install it again. I think that will be enough to fix the issue. The existing drivers are not proper or can be slow due to which the game output is affected. Just install fresh drivers and check back

  4. #4
    Join Date
    Jan 2009
    Posts
    913

    Re: Games lagging at maximum resolution on Nvidia 650Ti

    There can be some other hardware also in the system which is causing the same issue. Like a slow hard drive or a old ram. You have to simply check that once. Updating the driver will only not help. I had faced the issue while playing games. That was because of a old hard drive in my system. Later on I bought a new one and installed game on that which worked really well. Sometime there are too many background apps that cause this problem.

Similar Threads

  1. No display on Gigabyte GA-Z77X-UP5-TH after adding Nvidia 650Ti GPU
    By messi-m in forum Motherboard Processor & RAM
    Replies: 7
    Last Post: 25-01-2014, 09:44 AM
  2. Replies: 3
    Last Post: 30-03-2013, 04:27 PM
  3. Resolution lagging In Assassin's Creed
    By Zyrren in forum Video Games
    Replies: 4
    Last Post: 09-02-2011, 12:50 AM
  4. Maximum picture resolution for Zune HD
    By Jaimenacho in forum Portable Devices
    Replies: 5
    Last Post: 02-07-2010, 01:42 PM
  5. Maximum resolution blocked
    By Paisley in forum Hardware Peripherals
    Replies: 4
    Last Post: 23-12-2008, 02:31 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,670,478,018.27654 seconds with 17 queries