Results 1 to 4 of 4

Thread: wmp11/vista how can I reinstall corrupt wmp11

  1. #1
    Join Date
    Sep 2005

    wmp11/vista how can I reinstall corrupt wmp11

    I was using Windows media Player 11 on Vista HP Laptop since a year. Now from last couple of days I noticed some weird behavior of WMP. Hence I thought to install some security upgrade for WMP 11 from Windows update. But while doing the same I received the following error message:

    "Unable to create the OMC detect object used to get version information (Invalid class string)"

    I have seen this error for the first time since I’m using computers hence don’t know anything about it. Can you guys please Advice me something? All helps appreciated.

  2. #2
    Join Date
    Nov 2005

    Re: wmp11/vista how can I reinstall corrupt wmp11

    Can you just tell me what happens or what Indiv Version can you see when you click WMP's Help:about:Technical Support Information tool? Meanwhile also click this URL and let me know if you are able to click the UPGRADE button or is it grayed out.

  3. #3
    Join Date
    Sep 2005

    Re: wmp11/vista how can I reinstall corrupt wmp11

    Thanks for the help Rossen. First, the Indi version is and WMP is v11. Secondly, yes I was able to click the upgrade button on that page. Still getting the same problem. Any other help?

  4. #4
    Join Date
    Jun 2008

    Problem Solved


    I don't know if you still have this problem with the Overdrive Media Console, but I found a way to fix it. I ran across this fix while troubleshooting a different problem that turned out to be the same cause. It turns out that some of the registry keys can be created in Vista without correct permissions granted to the Administrators group and System account. I found a procedure on Aaron Stebner's WebLog to reset the permissions on the entire registry.

    OMC started working immediately after I rebooted and I can now download and play audiobooks.

    I'm running 32 bit Vista and it worked fine but there seems to be some discussion around using this utility for 64 bit systems.

    Good Luck.

Similar Threads

  1. XBOX360 Can't see WMP11 but WMP11 can see the XBOX
    By LAMONT D in forum Media Player
    Replies: 3
    Last Post: 02-11-2009, 10:43 AM
  2. reinstall wmp11
    By Izharr in forum Media Player
    Replies: 4
    Last Post: 19-06-2009, 11:56 PM
  3. WMP11: Library will not load, corrupt registry key?
    By Simon Coles in forum Vista Help
    Replies: 8
    Last Post: 28-08-2008, 02:04 PM
  4. WMP11 (Vista) will not play WMA files
    By adrianlag in forum Windows Software
    Replies: 5
    Last Post: 06-08-2008, 12:12 AM
  5. Vista WMP11 can't open media web links
    By HudSon in forum Media Player
    Replies: 7
    Last Post: 25-07-2008, 04:53 AM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,719,098,950.68984 seconds with 17 queries