Results 1 to 4 of 4

Thread: Getting blue screen after adding a new psu

  1. #1
    Join Date
    May 2012
    Posts
    136

    Getting blue screen after adding a new psu

    I am getting blue screen on Windows 7 after changing the power supply. I am having a gaming pc here. And it keeps on getting off whenever I play games on it. Later on after checking out everything I finally found that the problem is with the psu. I replaced that with some 700w corsair. But after that there is more problem. I started getting blue screen errors. And this always occur when there is some serious hardware fault in the system. In my views everything is ok and looks connected. But still the pc just keeps on getting crash on its own.

  2. #2
    Join Date
    May 2011
    Posts
    397

    Re: Getting blue screen after adding a new psu

    You have to check the connection here. The power connection with all your hardware. Like the hard drive, motherboard, processor, etc. And then re-verify the same. I am quiet sure that this will start working once the connections are rechecked. There might be something loose which is causing the problem. To test remove any connected hardware like printer, or a usb hub, etc. Just remove and see whether your pc is working fine or not. If still it gives you blue-screen then go in Event Viewer to checkout more details about the error.

  3. #3
    Join Date
    Sep 2014
    Location
    Singapore
    Posts
    17

    Re: Getting blue screen after adding a new psu

    Hi cech,

    As per Baako update, I agree with him. It’s better to check the hardware connection again.

    If the problem still persist, is there any error message when the blue screen of death (BSOD) appears? If yes, when does BSOD occur?

    Example: A few minutes after switching ON the computer or during playing a specific game? How often are you getting the BSOD? Can you force a BSOD? If possible, please provide a snapshot and the specific error message.

    For the meantime, I’d suggest you to change clean boot settings that may help you to solve the issue.

    Please refer the below link for Clean boot settings

    {support.microsoft.com/kb/929135}

    Hope it helps.

  4. #4
    Join Date
    Jun 2011
    Posts
    383

    Re: Getting blue screen after adding a new psu

    It might happen that while re fixing everything you had not properly added the ram. You have to fix it tightly and it will start working. Remove the ram and change the slot also. Then turn on your system and start playing the games. If still the pc crash then just boot your pc in bios and go in the PC health section. See the current temperature. If it is rising then it means your pc is not able to perform well and might crash again. If this is not a issue then there can be OS related problem also. I think you must post the error report from Event Viewer to get more help.

Similar Threads

  1. After adding a new cpu Intel E5700, Windows 7 crash with blue screen.
    By nimesh.tt in forum Motherboard Processor & RAM
    Replies: 4
    Last Post: 31-07-2013, 06:18 PM
  2. Replies: 6
    Last Post: 06-07-2012, 04:25 PM
  3. Getting blue screen with blue spinning circle in Skype
    By Luna^Ivery in forum Technology & Internet
    Replies: 5
    Last Post: 15-10-2011, 10:25 PM
  4. Replies: 6
    Last Post: 15-08-2010, 06:03 AM
  5. Vista blue screen - can't read blue screen
    By Hemadri in forum Vista Help
    Replies: 4
    Last Post: 06-02-2007, 11:42 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,675,372,387.81099 seconds with 17 queries