Results 1 to 4 of 4

Thread: laptop's touchpad showing as PS/2 mouse

  1. #1
    Join Date
    Jun 2014
    Posts
    15

    laptop's touchpad showing as PS/2 mouse

    I am using a Lenovo laptop which came with some old operating system. So I installed Windows 7 on it. Everything was working fine but after some time I started having issues with the dvd writer of this laptop. So, I took it to the service center and they fixed it as usual. But once I got the laptop I noticed that the multi-gestures were not working. I then reinstalled the drivers but still to no avail. When I go into the driver area then it appears to be a PS/2 mouse and not as touchpad. Does anyone know how to solve this problem? Thanks

  2. #2
    Join Date
    Nov 2005
    Posts
    2,496

    Re: laptop's touchpad showing as PS/2 mouse

    I am thinking that this might surely be a driver related issue. So what you can do is simply go to the Device Manager and then choose Touchpad and right click on it to select Properties and then go to Details Tab. Here you will get the Hardware ID, just post it here in your next reply. Or else you can even choose to reinstall the driver from the below link. Just select the series of the laptop and then below select the Model. On the next page you will get the download link for the drivers.

    http://support.lenovo.com/gb/en/prod...d-netbooks&c=1

  3. #3
    Join Date
    Apr 2008
    Posts
    2,347

    Re: laptop's touchpad showing as PS/2 mouse

    It looks to me that when you gave your laptop to the Service Center then it installed a wrong trackpad driver and not by the same manufacturer that you use. Can you please tell us first what is it exactly called under your Device Manager? You can also try to install a free software called Speccy to check what is the model of the trackpad. Most of the internal PS/2 device is commonly called as a trackpads now a days. So, I think that the driver you have installed might be wrong on the first place.

  4. #4
    Join Date
    May 2008
    Posts
    1,812

    Re: laptop's touchpad showing as PS/2 mouse

    I was facing a similar issue like the OP. I also removed and installed the drivers from differnet locations in my Acer but nothing was working. I got my laptop repaired under warranty but after returning back to me I started facing issues. After that I called my laptop manufacturer and they told me to restore my laptop to factory settings. After a lot of search I found that it was a hardware problem with the Synaptics, so I uninstalled the software and driver and then downloaded and installed the Elantech driver which worked fine for me.

Similar Threads

  1. Need to disable the touchpad with mouse connected in Windows 7
    By Phaedra in forum Hardware Peripherals
    Replies: 5
    Last Post: 18-03-2012, 02:59 AM
  2. Mouse/touchpad tapping--turn off
    By No. 4 in forum Vista Help
    Replies: 7
    Last Post: 14-08-2011, 04:45 AM
  3. LAPTOP TOUCHPAD NOT WORKING AFTER INSTALLING USB MOUSE???
    By Reegan in forum Vista Hardware Devices
    Replies: 4
    Last Post: 15-05-2011, 10:25 PM
  4. PC not recognizing mouse or touchpad clicks
    By CPav in forum Operating Systems
    Replies: 2
    Last Post: 23-09-2009, 07:45 PM
  5. Replies: 2
    Last Post: 13-06-2008, 01:01 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,675,720,409.72711 seconds with 17 queries