Results 1 to 7 of 7

Thread: Logitech c920 is not getting detected after installing LWS

  1. #1
    Join Date
    May 2012
    Posts
    78

    Logitech c920 is not getting detected after installing LWS

    I have been trying to install Logitech Webcam Software but every time at the last screen it comes up with a (/) sign and grayed mic. I don’t think I am missing out anything, the software is not able to detect my Logitech c920. I have tried reinstalling Logitech Webcam Software several times but that’s not helping. Has anyone faced any such issue like this and is aware of any solution to overcome the same???

  2. #2
    Join Date
    May 2011
    Posts
    296

    Re: Logitech c920 is not getting detected after installing LWS

    I wanted to know if this issue is just with Logitech Webcam Software or other webcam software as well. If you are facing this issue with other software’s as well then there are possibilities that there might be something wrong with Webcam. If you have not tried using other webcam software then try using them and let me know the response you get. Since you have mentioned that you have tried uninstalling and reinstalling the software several times I also wanted to know if you have tried making clean installation of it??

  3. #3
    Join Date
    May 2012
    Posts
    78

    Re: Logitech c920 is not getting detected after installing LWS

    Yes I have made clean installation of the driver every time but that’s not making any difference in my case. I am not having any such issues with other third party webcam software’s the issue is just with the Logitech Webcam Software. The webcam is loading fine when I am going in to motion but there I am not able to use any features. I have tried connecting the webcam to different ports and switching between Hi-Speed USB 2.0 port as well as SuperSpeed USB 3.0 but doing that did not made any difference. Is there anything else that I can try out further for fixing this issue?? Any help regarding the same will be appreciated.

  4. #4
    Join Date
    Jul 2011
    Posts
    427

    Re: Logitech c920 is not getting detected after installing LWS

    Which version of Logitech Webcam Software you are using? Which is the operating system in your case?? With which webcam software your Logitech c920 is working fine?? . Just let me know these things so that I can have a better idea of the issue you are facing and will try to help you with possible solutions.

  5. #5
    Join Date
    May 2012
    Posts
    78

    Re: Logitech c920 is not getting detected after installing LWS

    I am using Logitech Webcam Software v1, my system is running on windows 7. The web cam is working fine with cyberlink youcam software and I am currently using the same. I don’t understand how come a Logitech webcam is not working with Logitech Webcam Software and is working with cyberlink youcam software. That’s really appearing to be weird, I have contacted the Logitech support as well and they have suggested the same things like reinstall the software, try using different ports blah blah!! Which were of no use. I have been wandering in different forums as well but I have not yet come across an effective solution for the same. Anyways if anyone finds out any other solution than the ones that have been mentioned here then please let me know, thanks in advance.

  6. #6
    Join Date
    Jul 2011
    Posts
    427

    Re: Logitech c920 is not getting detected after installing LWS

    There might be something wrong with the Logitech Webcam Software anyways I have checked about the same and have found Logitech Webcam Software v1 to be quite old and the latest one is logitech webcam software v2.1 so try downloading and installing that and see if the issue is getting solved by it. Just make sure that you are uninstalling the old software completely and deleting every instance of it from your system. I am not sure if the latest version will help or not but you should give it a try and find it out. Best of luck.

  7. #7
    Join Date
    May 2011
    Posts
    296

    Re: Logitech c920 is not getting detected after installing LWS

    Yes you should try out the latest software for it, here you go:
    Logitech Webcam Software for Logitech HD Pro Webcam c920
    Title: Webcam Software for HD Pro C920
    Software Version: 2.40.845.0
    Post Date: 1-6-2012
    Platform: Windows 7
    File Size: 7 Mb (smart), 140 Mb (full)

    You can download it from here. Just try it out and let us know if your issue is getting solved or not.

Similar Threads

  1. Not able to use Logitech C920 Webcam on my Windows 8 laptop
    By ronaldobrazil in forum Portable Devices
    Replies: 5
    Last Post: 14-06-2013, 03:42 PM
  2. Mac drivers for Logitech HD Pro Webcam C920
    By Oppilaa in forum Hardware Peripherals
    Replies: 3
    Last Post: 27-06-2012, 01:05 PM
  3. Logitech C920 Webcam recording only to MP4
    By $Iain$ in forum Hardware Peripherals
    Replies: 2
    Last Post: 17-03-2012, 10:41 AM
  4. What is the Maximum resolution of Logitech HD Pro Webcam C920
    By Farren in forum Hardware Peripherals
    Replies: 8
    Last Post: 16-03-2012, 11:37 PM
  5. Where can I find Logitech HD Pro Webcam C920 SDK
    By Deshawn in forum Hardware Peripherals
    Replies: 2
    Last Post: 16-03-2012, 02:34 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,675,725,563.02972 seconds with 17 queries