Results 1 to 5 of 5

Thread: iCharger wont work on MSI 970A-G45 with Windows 7 64bit

  1. #1
    Join Date
    May 2012
    Posts
    88

    iCharger wont work on MSI 970A-G45 with Windows 7 64bit

    I have recently bought a iCharger for charging my ipad but it is not working when I am connecting to my system having MSI 970A-G45 running windows 7 64bit then it is not working. I am not having any issues in installing the same and I am getting it's icon in system tray as well but I don’t know for what reason it is having a red X over it. Is there anyone who has faced the same or has an idea about this issue??

  2. #2
    Join Date
    Feb 2012
    Posts
    104

    Re: iCharger wont work on MSI 970A-G45 with Windows 7 64bit

    There are a number of icharger’s so can you mention the specific model of it so that I can have a better idea of the issue you might be having. As far as a workaround is concerned you can try connecting it to some other usb port and see if it is working out fine there. If it does not then I think that there might be something wrong with the iCharger. Have you tested it out, I mean you can connect it to some other system and check out if it is working. As far as I am ware there can be compatibility issue as well, if you are not aware of the same then you can check out for its compatibility from the manual. If it is working fine in some other machine then you can try updating the bios of MSI 970A-G45 and see if you are having any luck with it. Make sure that you are updating to the latest bios. I also wanted to inform you that sometimes you need to have EUP enabled to get such ichargers working. So if you are not having any luck with the above mentioned solutions then you can try enabling and disabling EUP and see if it is helping. Just check out these things and post back the result that you get for further help.

  3. #3
    Join Date
    May 2012
    Posts
    88

    Re: iCharger wont work on MSI 970A-G45 with Windows 7 64bit

    These are the things I have tried out so far:
    • I have tried connecting the icharger to usb 3 as well as usb 2 ports but it is not making any difference and red X over it is not going away.
    • I have tried using other usb cable as well and they are not helping.
    • I am not that aware of the compatibility issue as I am not having its manual.
    • After your suggestion I have tried updating the bios and have made sure that I have updated to the latest but I did not made any difference.
    • I have tried using it with other machine and it is not working there as well. I am just not able to find out the cause of the issue.

    What did you meant by enabling and disabling EUP?? I am not aware of the same, can you let me know the steps required for enabling EUP? Any further help regarding the same will be highly appreciated.

  4. #4
    Join Date
    Feb 2012
    Posts
    104

    Re: iCharger wont work on MSI 970A-G45 with Windows 7 64bit

    For enabling EUP mode in the Setup Utility you can refer to the below steps:
    • First turn off your computer and press and release F1 after turning on the system until you get a logo screen.
    • When you get Setup Utility program screen then select Power from the Setup Utility program main menu and Select EuP lot 6 and hit enter.
    • After that Select Enable and hit enter, when you are done with the same then Press F10 to save and exit.

    Just try it out and see if enabling and disabling EUP is making any difference. Best of luck

  5. #5
    Join Date
    May 2012
    Posts
    88

    Re: iCharger wont work on MSI 970A-G45 with Windows 7 64bit

    I have tried out that now and unfortunately it is not making any difference. Anyways I have checked about the same and have found others having the same issue as well. Some people have mentioned that MSI does not support Ipad and so, is that true? Do you have an idea about the same or I should better contact msi for it??

Similar Threads

  1. Replies: 3
    Last Post: 06-08-2013, 11:29 AM
  2. Replies: 5
    Last Post: 29-05-2012, 10:22 AM
  3. Replies: 7
    Last Post: 11-09-2011, 10:35 PM
  4. Replies: 3
    Last Post: 05-02-2011, 05:08 AM
  5. Windows 7 64bit: ATI CCC.exe does not work
    By Maggie Q in forum Windows Software
    Replies: 4
    Last Post: 19-12-2010, 11:13 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,675,897,069.90405 seconds with 17 queries