Results 1 to 3 of 3

Thread: WD Passport hard drive ejecting itself automatically

  1. #1
    Join Date
    Feb 2012
    Posts
    56

    WD Passport hard drive ejecting itself automatically

    I have purchased the 500 GB WD passport recently and having some problem with that. Whenever I connect that with my computer and transferring any of the files to it shows me error that "WD My Passport 0740 Media is in use and can't be powered off." After some time, it get ejected automatically and transfer cannot be completed. I tried to do it many of the times but all the times it comes with the same thing. This is not the problem with any of the other external drive connected with the system. I am using OS X Lion Update 10.7.1. Can somebody over here guess that what could be the reason for this problem? If you are having any idea regarding this then please let me know that. Thank you!!!

  2. #2
    Join Date
    Jun 2011
    Posts
    2,005

    Re: WD Passport hard drive ejecting itself automatically

    There is possibility that the SMC is having some problem and because of that you are facing this strange behavior from WD Passport hard drive. If you want to get this issue resolved then you will have to reset the SMC. There have been many of the similar cases where this trick worked and so I hope that it will do the same for you as well. It is very easy to do that. Just go through the steps given below:

    1. First of all, detach the power cord from it
    2. Press Mac’s power button and hold that for about 5 seconds
    3. Leave that button after 5 seconds
    4. Attach the power cable again and boot mac as normal

  3. #3
    Join Date
    Jul 2011
    Posts
    2,014

    Re: WD Passport hard drive ejecting itself automatically

    I was also having the similar problem earlier but the reason for this comes out as the WD software which was installed on it. So what I did is, simply uninstalled that from my system and after that reformatted the drive. Once I did that then I am not facing any problem with the drive. That is working great for me. You must try this once before going for the SMC. If none of the solutions helps ou then you can simply call to the WD support and they will help you with this.

Similar Threads

  1. Unable to mount WD My Passport hard drive with Ubuntu
    By Cham-D! in forum Hardware Peripherals
    Replies: 4
    Last Post: 22-05-2012, 04:00 PM
  2. My Passport hard drive cannot be repaired in MAC OS X
    By Cham-D! in forum Hardware Peripherals
    Replies: 5
    Last Post: 22-05-2012, 03:43 PM
  3. Formatting western digital My Passport Essential hard drive.
    By Jai-Ho in forum Hardware Peripherals
    Replies: 8
    Last Post: 03-09-2011, 08:09 PM
  4. Replies: 7
    Last Post: 31-07-2011, 03:06 PM
  5. Replies: 0
    Last Post: 12-03-2009, 10:49 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,716,348,575.02935 seconds with 17 queries