Results 1 to 5 of 5

Thread: I/O device is not working properly with external hard drive

  1. #1
    Join Date
    Dec 2011
    Posts
    61

    I/O device is not working properly with external hard drive

    Hi friends I have Toshiba satellite and an external Seagate 1TB external HD. So recently I was trying to make the connectivity for this laptop ad this external drive but however I fail to do this connection. I have noticed that the I/O device is not working properly with external hard drive. Why this issue occurs I don’t know I have tried several thing to overcome this situation but however I fail to do this. If you guys have any of the suggestion or ideas for this then please let me know. Any of the reply will be appreciated.

  2. #2
    Join Date
    Jul 2011
    Posts
    326

    Re: I/O device is not working properly with external hard drive

    According to my information you must try to make the use of Tuneup utilities for performing the chkdsk of your external hard drive. And make the verification that the external hard drive don’t have to show don’t have any bad clusters. If it has then you have to fix it. And also make sure that the Harddisk have to be shows up in "computer" so that you can open the folders. And the main thing that you have to verify is whether the connection between the devices is proper or not. Make this verification and then try to make the connection.

  3. #3
    Join Date
    Jun 2011
    Posts
    414

    Re: I/O device is not working properly with external hard drive

    You can make the use of the CMD window, so using the CMD window you just have to type chkdsk /r which will shows lists which are "unreadable". This is one of the ways to know about the unreadable file present in the external storage. And for the I/O working issue may be the connection is not proper.

  4. #4
    Join Date
    Jul 2011
    Posts
    338

    Re: I/O device is not working properly with external hard drive

    According to my information may be the Free agent's power supply is not properly working, that means to say may be there are the chances that Free agent's power supply has probably failed. So make the verification and then try to make the connection if it is working properly and if it is fail to work then replace it with the new power supply.

  5. #5
    Join Date
    May 2011
    Posts
    503

    Re: I/O device is not working properly with external hard drive

    This is not that much of big issue you can visit the nearby local computer shop or you can go to seagate retailers and fix this issue. However this is mostly happen when there the connection between the System and the external hard drive is not proper. Or the USB that you are trying to fixed May not working properly. So finally I just want to suggest you that you can go to any of the reputed computer repair shop and fixed this issue.

Similar Threads

  1. Replies: 6
    Last Post: 09-10-2012, 06:38 PM
  2. Replies: 13
    Last Post: 11-05-2012, 10:48 AM
  3. Hard Drive not working properly on Xbox 360-S
    By Jat$In in forum Portable Devices
    Replies: 6
    Last Post: 09-07-2011, 09:23 PM
  4. Apple Macbook Air: external hard drive is not working
    By SchuRacer in forum Portable Devices
    Replies: 4
    Last Post: 14-01-2011, 07:47 PM
  5. Replies: 3
    Last Post: 22-07-2009, 02:41 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,675,912,701.71851 seconds with 17 queries