Results 1 to 4 of 4

Thread: Nook HD not working, dead already?

  1. #1
    Join Date
    Jun 2013

    Nook HD not working, dead already?

    I was using my Nook HD for a year now without any issues. I have also not rooted it but it used to have a N2A card in with Jelly Bean. Now all of a sudden it is not turning on and wont even charge. I tried to charge it in the night but when I checked it in the morning it was still not charged. After connecting it to the charger the light turns red but when I am trying to turn it on then the light goes from green to yellow. Can anyone please tell me how do I get this to work? Thanks

  2. #2
    Join Date
    May 2008

    Re: Nook HD not working, dead already?

    Can you tell us whether the battery holding a normal charge a day before? If yes, then I think there is nothing to worry about. Most of the Nook HD models suffer from a few charging quirks. I was also having this same issue when my Nook HD+ stopped charging. After connecting it into a USB charger, the light was still green no matter what. So, I got it out of that mode and into regular charging mode by plugging it to my computer with USB cable. This connection was enough to wake up my ebook reader. So, you can also try to follow this same method and see if it helps.

  3. #3
    Join Date
    May 2008

    Re: Nook HD not working, dead already?

    You can try to make a basic Clockworkmod bootup card which is described on the XDA website. You can easily do that and afterwards insert the card into your dead Nook HD ebook reader and connect it in the charger. Just leave it connected for atleast 2 hour or so and then press the power button and boot to the Clockworkmod. If it is booting then you will be able to charge the device for sometimes and then exit out of the Clockworkmod. After that put a stock ROM on the card and restart your device.

  4. #4
    Join Date
    Apr 2008

    Re: Nook HD not working, dead already?

    Can you tell us whether there is something physically broken or are you facing problems with the firmware or software? If there is some hardware failure then you can try to send it back to the manufacturer for a replacement, if your ebook reader is under warranty. If it is not under warranty then you will have to perhaps pay for the repair. In any case, can you try to hold down the power button while simultaneously holding down the "n" on the Nook HD and see if that works.

Similar Threads

  1. HBO not working in Nook tablet
    By Muktar in forum Portable Devices
    Replies: 7
    Last Post: 25-11-2011, 02:23 PM
  2. Replies: 7
    Last Post: 24-11-2011, 11:18 PM
  3. Dead Pixels of Nook Color
    By Y-Maker in forum Portable Devices
    Replies: 5
    Last Post: 07-04-2011, 10:24 AM
  4. What at the ways to fix a Nook Color Dead Pixel
    By Calvert in forum Monitor & Video Cards
    Replies: 3
    Last Post: 27-03-2011, 05:50 PM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,696,082,429.39843 seconds with 17 queries