Results 1 to 8 of 8

Thread: Specified server cannot perform requested operation - joining domain

  1. #1
    Join Date
    Jan 2005

    Specified server cannot perform requested operation - joining domain

    Hello. I’m running a Windows 2003 server with Domain Controller. It is patched with Service Pack 2. There are several client workstations connected with the same. Now recently we setup a new workstation which I wanted to add to the same domain. While trying to do the same I received the following error message:

    “The specified server cannot perform the requested operation.”

    Now the computer account is created on the domain, it is disabled. Nothing happens though I reset the account. Any help please?

  2. #2
    Join Date
    Sep 2004
    Hello Keithh. Before you try anything else i will suggest you to first check if FSMO roles are ok from the DC. You can do this with netdom query fsmo. Apart from this also check if the your workstations are syncing the date and time from the domain. I mean it should be the same. Also see if the workstation is having DC as the primary DNS server. It will be better if you can also try joinning the domain with the FQDN name ( Let me know the results.

  3. #3
    Join Date
    Nov 2008

    Re: Specified server cannot perform requested operation - joining doma

    Having the same problem but ONLY with my XP x64 box. XP x86 boxes log in just fine.

    I read this thread and tried everything. The DC names are correct; All possible updates are installed and tried. I tried different nwtwork cards (desperate).

    The x64 box gets to the username/password dialog and then pauses about 1 minute after entry. The I either get the same message as above or an access denied message.

    Oddly, ONE time when I changed computer names on the XP x84 client, did NOT reboot and attempted a domain login. I got a "Welcome to the domain message" followed by a message which told me that the name has reverted to the old name of the computer (or something like that).

    What accompanies this error is the server disabling the computer account after this error occurs.

    I have tried changing client names, different boxes, different NICs, and am considering a small hammer if I can't get this to work. HELP please!

    Thanks in advance.

  4. #4
    Join Date
    Aug 2009
    I fixed this, here's how:

    1. Delete Comp. Acct. in AD User's & Computers on controller.
    2. Wait 5 minutes.
    3. manually set DNS to AD server on workstation.
    4. Renamed local Administrator to Administrator
    5. Re-added, using my domain ID (as domain admin)

    not sure which one was the key step, but that's all of them.

    I am having the same issues with joining winXP clients to 2008 server after having been on a 2000 domain. Did you figure out what the problem was?

  5. #5
    Join Date
    Aug 2005

    Re: Specified server cannot perform requested operation - joining domain

    I'm running Windows 2003 Server with terminal services role and IIS6. Even i had the same problem while adding this to a domain After lots of researches finally i managed to fix it by going into ISA 2006 management console and adding the RDP port into the firwall allow area. So you should give it a try if you too having IIS6.

  6. #6
    Join Date
    Jan 2010
    I have two networks, one home, the other office, linked up by a vpn tunnel.
    I was trying to get a box on the home network running xp pro to join the office domain and having no luck, until I did the following:
    I changed the TCP/IP properties on the local box to "hard wire" the ip address of the box on the local network (just set it at whatever ip was assigned automatically), and specify also the DNS servers (use the remote DC as the primary and the local router if that is your DHCP server on the local network as the Alternate).
    After doing the foregoing I ceased to get the dreaded "Specified server cannot perform requested operation" error message and immediately got a welcome to the remote domain.

    just posting for others in the event they have a similar issue

  7. #7
    Join Date
    Mar 2010

    Re: Specified server cannot perform requested operation - joining domain

    Hi There

    If the Client cannot Join the domain but can ping the server ok, this either that the name already exist within DC/AD or....Windows Firewall/other firewall is blocking it!
    delete computer from DC/AD restart both client and server (so server has a chance to realise it is no longer there, then disable firewalls on BOTH CLIENT AND SERVER.
    And finally join the domain!

    If this does not work, reinstall client and delegate it with a new PC Name.

  8. #8
    Join Date
    Feb 2011

    Re: Specified server cannot perform requested operation - joining domain

    FYI I found this to be that someone else had set a 'Connection specific DNS suffix' when they had setup the DHCP server.

    I *think* this is set under 'DNS domain name' server option, but in my case I only sussed it out after dropping the entire DHCP scope and recreating without the dodgy test domain in it.

    If you lose that setting, then try and re-add to the domain it will work. I suppose it's the client machine saying 'Eh ? You can't add me to that domain, my domain is'
    Last edited by Bigpa; 10-02-2011 at 04:33 PM. Reason: Make clearer, after reading :)

Similar Threads

  1. Replies: 2
    Last Post: 18-05-2011, 10:25 AM
  2. Replies: 6
    Last Post: 13-08-2010, 04:02 PM
  3. Advanced Server Domain - Joining Windows 7 To Windows 2000
    By Ameeryan in forum Operating Systems
    Replies: 3
    Last Post: 03-12-2009, 12:06 PM
  4. Joining a 2008 member server to a 2003 domain?
    By TheTurner in forum Window 2000 Help
    Replies: 1
    Last Post: 02-10-2008, 03:59 PM
  5. Joining windows 2003 server's domain using vista home premium
    By haritable in forum Windows Vista Network
    Replies: 1
    Last Post: 08-01-2008, 02:53 PM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Page generated in 1,679,763,682.46066 seconds with 17 queries