Results 1 to 5 of 5

Thread: AD snapin will not open

  1. #1
    Join Date
    Sep 2005
    Posts
    185

    AD snapin will not open

    If I try to open Active Directory Users and Computers, I am getting some error that states "Microsoft Management Console has encountered a problem and needs to close". After looking at the error message, it shows:

    "AppName: mmc.exe AppVer: 5.2.3790.3959 ModName: kernel32.dll
    ModVer: 5.2.3790.4062"
    The technical data shows exception information of...
    "Code: 0xe06d7363 Flags: 0x00000001"

    I have checked at microsoft article but nothing is working for me. I even tried to install SP2 and Microsoft Management Console 3.0 but when I tried reinstalling MMC 3.0, I got this error "Setup has detected that the Service Pack version of this system is newer than the update you are applying?" Can anyone help. Thanks.

  2. #2
    Join Date
    Jan 2006
    Posts
    2,257

    Re: AD snapin will not open

    Can you tell us whether it is only dsa.msc? You can try to open "mmc -32 dsa.msc" from the run command. Have you tried to reinstall the adminpak and see what happens?

  3. #3
    Join Date
    Aug 2009
    Posts
    1
    I am in the exact same boat with the exact same problems and have attempted the exact same things!!!!!

    This is a application server running a HUGE EMR data base and the last thing I want to do is install everything over again as I nuke the OS to fix it.

  4. #4
    Join Date
    Feb 2010
    Posts
    1
    Hi there, I see that this is quite a old post, but I am willing to give it a try.

    I have the same problem, with dsa.msc everything else works but dsa.msc.
    I also Tried re-installing managment console 3. And also tells me that A newer version is installed.
    I tried Renaming dsa.msc to dsa1.msc and created a new MMC Snapin and saved it as dsa.msc in %windir%\System32. It works but, everytime you go into the MMC saved snapin it asks to save. Witch it is not supposed to do.

    I have tried installing Adminpack SP2 for Server 2003. But the instalation stops responding, and you have to "end process" the task, for it to cancel the installation.

    Using "Run as" and a completly other Enterprize admin Account dsa.msc works fine. even logging on with the other account to the server it works.
    It does not work when you just disable "run this program with restricted access".

    I also took away all privlages to the Primary admin account that is used on the server, and placed it back as it was, to reset permissions, on the file and on the domain for that Admin account. Still had no luck.

    Only thing I did not try yet was Resetting password of that account.
    Deleting and recreating the account is aslo not an option.

    I checked if security policies are correctly inplace for the Admin account. And everything is correct.

    I cant see why dsa.msc just suddenly could not been accessed by the Admin account, because nothing has changed on the server at all. No update's where applied the day or even month before this has happend.

    Are there someone with a solution to this?.

  5. #5
    Join Date
    Sep 2011
    Posts
    1

    Re: AD snapin will not open

    I had this same problem just today.
    The entry above led to the solution:
    Try opening a command window and enter the command "mmc -32 dsa.msc".
    Enter the text between the quotes and not the quotes.

    If this works then the application is working properly and it could well be the Icon shortcut is no longer good.

    Open the properties of the icon (right mouse click - properties)
    In there the target may look something like:

    Target: C:\WINDOWS\system32\dsa.msc
    The start in: C:\WINDOWS\system32

    This is what I had.
    I changed the Target to:C:\WINDOWS\system32\mmc.exe -32 dsa.msc

    Save the change, close the properties and click on the icon to see if it works.
    It worked for me.
    I don't know why this changed or why it stopped working but this fixed it for me.
    Good luck.

Similar Threads

  1. Excel 2003 documents open slow or do not open.
    By MilesAway in forum MS Office Support
    Replies: 43
    Last Post: 25-03-2012, 12:12 AM
  2. Replies: 5
    Last Post: 10-03-2012, 03:04 AM
  3. Replies: 2
    Last Post: 11-08-2009, 11:47 AM
  4. Replies: 3
    Last Post: 22-07-2009, 02:41 PM
  5. Replies: 3
    Last Post: 07-07-2009, 10:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,664,494,843.45818 seconds with 18 queries