Results 1 to 3 of 3

Thread: USB drive doesn't show in My Computer but does in Device Manager

  1. #1
    Join Date
    Oct 2005

    USB drive doesn't show in My Computer but does in Device Manager

    I bought a 120GB External hard drive. When I connect that to my system its shows a new hardware wizard on the screen. After installation or when the entire process finishes the device is not installed. There is nothing in My Computer. But the drive is installed in Device Manager. I find the drive connected. Like this when I use my 4GB usb drive it shows a Removable drive and I can move data in it. Any idea why this problem appears.

  2. #2
    Join Date
    Sep 2004
    Go in Disk Management. Right click on My Computer > Manage. There you would be able to see the drive listed. It is not formatted in windows readable format due to which it is not visible. You have to format that in FAT or NTFS file partition system and so it will be visible. It is not at all complicated to do that. It is a new drive and so it came in raw format. Just for that and it will appear in My Computer.

  3. #3
    Join Date
    Sep 2004
    Check the drive on different usb port. The port might be not proper. I had faced the problem with a 2Gb usb drive. It was having some kind of power issue. It was detected but not visible in Windows so that I can copy paste data in it. In Device Manager if it stays visible you can right click on that and choose update drivers. Go in BIOS and check that your had not disabled any option related to removable storage.

Similar Threads

  1. Replies: 6
    Last Post: 09-10-2012, 06:38 PM
  2. Replies: 2
    Last Post: 09-02-2012, 03:15 AM
  3. Replies: 4
    Last Post: 07-08-2010, 05:29 PM
  4. Replies: 3
    Last Post: 22-07-2009, 02:41 PM
  5. Show All Hidden Devices in Device Manager
    By EDALENE in forum Tips & Tweaks
    Replies: 2
    Last Post: 07-11-2008, 05:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts